Skip to content

GSA+CS crashing servers?

edited November 2012 in Bugs
We recently have some weird issues with either GSA or Captcha Sniper (or both) on our private servers.

We found that our VPS and our Dedi Servers crash over night. They seem to be running, but we can't connect via RDP. After talking to PowerUp (one of our providers and well recommended), he gave us some insight and the issue may have to do with the use of unused RAM resources, subsequently resulting in a system crash - but we are not 100% sure.

We had this issue over more than 5 servers for the last 4-5 days. We are sure we are not the only ones with that problem, but it's rather frustrating to restart servers all the time.

Would be great if any of you could confirm our problem.

330 Proxies per server
~200-300 threads per server
No scraping, just using our own link database.



  • I actually had similar problem connecting to my VPS via RDP for a month or so, but it seems to have stopped in the last week or so. My problem was that I couldn't connect via RDP for a certain time, but if I waited long enough (sometimes an hour, sometimes 5) I could connect again.

    I have started using proper CS so not sure if that's the reason why it's OK now but before I had a cracked version of CS installed and it was happening nearly every day.
  • edited November 2012
    i have the EXACT issue as the OP.

    Unable to access the server via remote access in the AM.

    GSA is crashing my server for the past 2 nights.

    It has never done this before. 2 days ago i upgraded from 4.58 -> 4.61. By this morning i could not access the remote server which meant it was hung up or crashed. I had to do a reset for the 2nd time.

    Finally when i logged in GSA stated it was back at v4.58? How is that possible? I did an upgrade 2 days ago. Then i ran though the upgrade again.

    Whats going on with this?

    Also, you state this in the changelog;  4.60 - new: added a basic default badword filter list that gets added to newly created projects. You still need to enable that option though.

    But where is this option? When i click NEW i dont see this option anywhere.

    Thinking about it, i should not have upgraded to 4.61 again this morning. I should have left it alone and continued to run 4.58 until such time that this issue is fixed. I have no idea how it reverted back after this crash anyway.
  • OzzOzz
    edited November 2012
    can all of you do some test with RamMap? i have a suspicion which i observed some time ago on my vps where my "page table" was maxed out after a while (= danger of running out of memory).

    1) restart all your tools once and make a screenshot of RamMap after restart
    2) let it run for a few hours, stop SER and make sreenshot of RamMap again
    -> compare the "Page Table" stats.

    what else you can test.
    after all your tools have run for a couple of hours take a look into your task manager -> performance, stop all tools and close CS or SER first and monitor the changes in RAM usage. if turning off one of the tools free up unusual high amunt of memory than you have at least a trace if one of the tools could cause a memory failure.

    however, @sven will be back again tomorrow and give you better advice.

  • poweruphostingpoweruphosting Los Angeles
    edited November 2012
    I did a lot of testings and I can assure you that a combination of GSA and CS is causing a memory leak issue.

    For testing purpose, I setup a brand new server, I decided to run only 1 Project @300 threads on the dedicated server. Here are the initial stats:

    CPU : 13%
    RAM: 23%

    I left them running for 24 hours and then the consumption of the resources increased after 24 hours. Here are the stats:

    CPU : 15%
    RAM: 50%

    I decided to leave them running for another 24 hours and the RAM consumption further increased. Here are the stats:

    CPU: 15%
    RAM: 80%

    After this, I decided to close both the programs one by one. Here are the stats after closing GSA.

    CPU: 15%
    RAM: 80%

    So with only CS running (it wasn't even breaking any captchas), above were the stats. So based on these tests, I can make an assumption that GSA is leaving a bad port open for CS which is resulting into a memory leak issue and causing servers to crash.

    I have PMed Sven about this issue and I can setup some more test servers for him to ensure that issue gets fixed very soon.
  • From looking at that I would say CS is the one with the memory leak.
  • @dab, I thought the same and I did contact Mike, the developer of CS and he said this could be due to the bad port which is being left open by GSA for CS.

    Either way, we gotta find out the root cause and get it fixed :)
  • OzzOzz
    edited November 2012
    @poweruphosting:  thx for testing.

    those screenshots i posted at October, 27.

    After fresh start:

    After some hours:

    Page table is increasing massively within some hours and will be cleared when closing CS. So there is something up either with CS or SER.
  • @Ozz Yes, there is some issue with either of the software for sure. Whatever it is, we gotta make sure that they get resolved soon.
  • You guys are awesome.   Thank you both very much for doing the testing.  and hope this issue gets resolved quickly. :)
  • SvenSven
    Im doing a profile on my end now. No mem leaks so far or any open ports/handles. 
  • I'm currently managing 7 VPS's/Dedi's  And I also notice this issue across the board on all server.  I have to restart GSA + CS  every 12-24 hours.
  • Also having this problem (that caused a number of tickets to powerup), don't really know what to do know, i've dropped threads to half, and still got this.

    I'm thinking maybe a batch file to kill and restart CS, or something like that.
  • @pisco Yes, After receiving tickets from you and few other GSA + CS users, I started to investigate the issue to find out why are all these random crashes happening, wanted to make sure nothing is wrong with the server and finally concluded that the issue was actually with the softwares and not with the servers! :)
  • AlexRAlexR Cape Town
    Me too. But on my side when I view the processes, it always shows CS as not responding while GSA still runs. 
  • I have been having this same issue for a while.

    I leave my task manager performance tab open constantly and close and reopen both programmes just before I go to bed and then again when I wake up.  It starts off as both progs using less then 500mb mem and just before I shut them down it can be up to > 1.90gb. (between 6 - 12 hrs).  Shutting them down and restarting always works but in the last few days I have had CS stop responding too.

    It gets all blacked out so you can't see it and then you have to kill the process.

    I am running about 40 projects but using the scheduler for 5 at a time, 20 min duration.  I have 10 private proxies and am running 30 threads.
  • @all - I am also looking into it and trying to isolate where in the stack this is coming from.
  • now that is what I call support :)
  • SvenSven
    @CaptchaSniper the only thing I changed when sending captchas to CS is that it now sends recaptcha as well. Maybe the problem is the function to solve unknown captchas?
  • No, I don't think that this is the issue as I've noticed this in CSX already IIRC.
  • i'm not a good at this technical issue but i really hope that Sven(GSA) and mike(CSX) can works together to solve this crashing issue.
  • SvenSven

    I had GSA running the whole night together with a "captcha-solving-app" (other than CS).

    No memory leaks on both sides. All running stable without any issues. So as CS was not involved here I can only assume that CS is the problem. Just a guess though.

    I can't run CS on my system as it keeps crashing almost immediately (tessact error). Maybe I should give it a try with that popup closing app that Ozz mentioned once.

  • OzzOzz
    edited November 2012
    I can confirm that the "other tool" works without memory issues on my machine in a steady flow and no significant memory in- or decreases at all. I had this running for up to 3 days in a row without any issues before I finally restarted it by hand.
  • Sven and Ozz - tag-team tantalizers ;)
  • poweruphostingpoweruphosting Los Angeles
    edited November 2012
    Found a temporary solution to the issue.

    You can Schedule a restart task for your VPS/Server inside Windows every 6-12 hours. This is a nice lil decent solution until the everything gets sorted out.
  • @Sven - you mean you're saying you cant even run CS at all without a tesseract pop-up?  So EVERY single captcha you send it results in a pop-up?  Please clarify.  I would hope have that you have a working version so that you are able to properly unit-test GSA with CS.
  • SvenSven

    Well I got this tesseract pop-up almost on every captcha that is analysed by CS. And that was from the start. Only solution for me was the exchange of the exe with a newer version. But even that was crashing sometimes. But you mentioned once that this is not a good idea as you tested CS only with that older one and so I didn't run CS anymore.

    A test with just exchanging CS with another captcha-breaking-executable was not showing any errors either crash or memory leaks as Ozz pointed out as well. And the way GSA-SER is sending the captchas is the same here.

  • lol @Sven - what are you trying to accomplish with the 'trying to be covert' but mentioning my upcoming tool comments?  yeah .. we all get it :) nudge nudge wink wink!

    Good news - we have beta testers currently testing a fixed version addressing the leaks.  Our intial tests indicate no more leaking :)
  • SvenSven

    @CaptchaSniper naw don't get me wrong, I only tried to see what the problem is. As I can't run CS for some odd reason, I was using another one and as this one communicate in a same way with SER than CS and everything was OK, I thought I would through it in here to get this sorted out.

    Anyway good you got it fixed on your end :)

  • I don't know if someone has noticed that but when GSA SER threads are lowering (several times during a blast), CS slows it down.

    GSA SER seems to wait for captcha answers, and even hangs up during a few seconds, resulting in threads blocking.

    I can tell that it's related to CS because I've done tests with 3rd captcha services only and this issue did not occur.
  • SvenSven

    @mozzer, thats right. The program will wait till it gets an answer from CS before sending a new captcha to analyse. Thats done to not cause any conflicts or hammering CS.

    This however is not slowing things down in the end as CS can only work on one captcha at a time and would queue things anyway (Im not sure if it does though). You might see threads hanging but thats due to the wait of CS to answer the captchas.

Sign In or Register to comment.