Skip to content

My PrivateProxies Gets Quickly Disabled And GSA SER Stops! Advice Needed

edited June 2013 in Need Help
Quick Question I have GSA Configured to only use privateproxies and that works well. However they get quickly disabled and GSA stops because I have both these settings enabled.

  1. Automatically disable private proxies when detected to be down on use >> in Submission Settings
  2. Stop Projects on no active proxies >> In Proxy List Options

Print Screens


I sort of have no room to mess up as explained in earlier post so how do I achieve the following.

I want to keep using private proxies only and they don't need to be checked if they work or not!  However If GSA somehow fails to keep posting with my private proxies I just want it to keep failing! The most important factor is that the IP of my VPS Is NEVER used! what should I disable or how do I accomplish this?


  • I suggest to make the timeout bigger. Like 15-20 sec.
  • Interesting I am gonna test that ASAP
  • Yes just to prevent SER to mark the proxies as dead... I know that this setting would make you run faster or have higher LPM or so but well, at the number of 20 proxies, if all the proxies are down then your projects'd stop and then you lose your time...
  • spunko2010spunko2010 Isle of Man
    "I suggest to make the timeout bigger. Like 15-20 sec." but according to the screenshot the timeout is 40s :-S  I am confused... Do you mean increase it by another 20s?
  • OzzOzz
    edited June 2013
    @spunko2010: the timeout for "proxy testing" not "search query time"...

    i don't know if the increased timeout help. for myself 5 seconds are more than enough because everything that goes beyond that is a sign of really crappy proxies imo. i even count >2 seconds as crappy when they are private. when you are on a home computer than decrease the threads to use for these as some routers are really bad at handling this test as this will use additional threads along with the one you are using for SERs main tasks (submissions, scraping, etc.).
    you may also change the test method from google to bing, whatsmyip or something else.

    what else you can do? 
    check "automatically search for new proxies every XX minutes" in the range of 20-60 minutes
    check "Only less than 20 proxies" in your case
    check "Test proxies" -> "All (good and bad)"

    then go to "List" -> "Add/Edit ProxySites" -> uncheck all sources
  • @Ozz I think setting 2-5 sec will be dangerous because if you uses a lot of threads and check the box of "automatically mark as down" for private proxies, if you couldn't connect to the proxies in 2-5 sec, it's automatically marked as down UNTIL you re-verify it when you notify suspiciously low number of proxies are available. I'm using a US VPS with 10Gbps line but I still have to set it 15sec, all the proxies I use for SER are private...
  • I'm experiencing the same issue. Are you using IP authenticated proxies too OP?
  • yes my proxies are ip authenticated
  • I've always used username/password proxies in the past with no issue.

    This being my first time using the IP style proxies, seems like there is a glitch as, there is no real option to add IP authenticated proxies. Can you look into this? @Sven
Sign In or Register to comment.