Skip to content

v6.18 has INSANE memory leak!



  • edited June 2013
    Right at the time I started, met the bug again, sent the bug report to you via the tool @Sven
  • SvenSven
    6.21 fixed another bug...actually it was a script that tried to recursively resolve a variable :(
  • I'm glad you found it xD...

    Errr... Have you discovered my niche @Sven loooololol
  • SvenSven
    @Alex used another project backup of someone else. Though I don't care on that at all. It's like Im blind on that and look just for the settings and stuff to reproduce the issue.
  • Thanks Sven for your support. Respected.

    I'm back to 200 threads and ~200 LPM without a glitch. Memory is around 752MB. No annoying out of memory popup, no crashed error message. Will monitor and report if I met the bug again.
  • Wow, 200 threads and 200 lpm...  I run 370 threads overnight and am around 5.5 lpm.  Clearly I'm doing something wrong.  Thanks Sven for the fix.
  • I have the 6.21 version, but all the day i have out of memory, even if i run ony 3 projects. When it will be fixed this bug?
  • edited June 2013
    I updated to 6.21, no crashes for me but the memory usage is higher than 1GB, in previous versions it was around 300-400MB.
  • thank god i didn't update, will update till i'm sure new version is stable..
  • SvenSven
    @sawa73 sorry to hear than. Feel free to send me your project backup to debug things.
  • Left it running over night, and woke up to the out of memory error message again. This is with the latest v6.21
  • I am not having any issues with v6.21.  It appears to be running just as smoothly for me as it did on v6.17
  • 6.22 isn't smooth too. I'm having problems. After running fine for few minutes at LPM of 40, all I'm getting now is this:

    That message continues to load up for a particular tier of a project. Needless to say, not submitting any links.

    With @Sven going on vacation, I think at least I'm going to have a tough time and will be missing him and his updates a lot, lol.
  • LeeGLeeG Eating your first bourne
    That's a keyword problem. Means ser cant find any more target sites and its pulling targets from the global sites list
  • No, it was working just fine a moment ago. It's not now doing anything, just LPM is decreasing, it was rocking at 40 LPM. The project is brand new as well, I've 100K keywords loaded. The update came with a trouble I believe.

    I'm plucking my hair literally.
  • if you only get that message then let it run. once SER collected all the urls for the project you will notice an increased LPM again.
  • @Ozz I stopped all the projects. It even took minutes to stop. I now started again and seems to run fine. But all was fine till 6.17, even if I was getting 20 LPM back then.

    Let's see how longer this will run for.
  • Woops, stuck again, not even 3 minutes...
  • OzzOzz
    edited June 2013
    i have a backup of 6.17. when you think you need it then just say a word.
  • Hey Ozz could you post the 6.17 backup here?  That would be awesome.
  • 6.17 - move it to your installation folder and execute it.
  • I actually rolled back to v6.21 and it seems to be doing fine currently (well at least since past one hour).

    Thanks @Ozz, shall be using it if needed!
  • @Ozz, this file is labeled 6.17 but actually opens 6.18 once installed.  I still do appreciate this but if you do locate 6.17 please post it here.  Thanks.
  • sorry, than i had backed up the wrong version.
    i have v6.11 then if that helps.
  • @sven is going on holiday... its last version stable?
  • I've been running the last version for over 24 hours and had no problems with it.
  • @HappyBear How come? The last version i.e. 6.22 was not released 24 hours ago, but like 16 hours ago or so roughly I believe.
  • sorry, you are right.  I was using v6.21 and forgot I upgraded again.  I had no problems with v6.21, and am still having no problems with v6.22 since upgrading several hours ago.
  • Btw, I'm stuck again. Gah, I won't update now before seeing a changelog and reading people's experiences first.
Sign In or Register to comment.