Skip to content

GSA Freeze after hours, multiple systems

Hello, the latest version (5.83) of GSA freezes after leaving it running for a few hours.

No search engines selected, no PR checking, only 1 project running per install... use global list only Submitted and Verified. Private proxies - 150 threads / 60 timeout (same settings) on two different systems. I imported a large list last night, and when I woke up GSA was frozen. Now, I just opened up another VPS and the program is frozen. Memory when the freezes occurs appears to be around 150mb.

It appears the interface is "functional"... in the sense that I can press "Stop", but as soon as I do the program freezes. Also the thread count remains frozen with the amount it was running at the time.



  • btw I am using #file_links macros to pull some content and other things..
  • SvenSven
    Do you use the scheduler?
  • edited May 2013
    I have just found the same problem. Woke up this morning and everything is frozen. Server time is 1.34am and if I look in CB it last solved at 7.14pm. Guess its been stuck for most of the night. I am using the scheduler..
  • edited May 2013
    I do not use scheduler
  • Same thing happened again just now... It appears the program was just finishing verifying some links and froze. I clicked "Stop" and it froze completely.
  • SvenSven
    edited May 2013
    Do you ever got a bugreport window after you have seen the gui freez for some minutes?
  • I rolled back to 5.81 and it is running fine again. I also noticed in 5.82 when I clicked stop on the scheduler it just says wait in the bottom right and never actually stops, just seems to be stuck trying to stop the threads.

    I got no bug report, but, when I tried to close it with the X in the top right, the main GSA screen went completely black.
  • No bug report window appears... GSA just freezes and eventually I am forced to kill the process
  • edited May 2013
    Another thing is the submitted number is going really high with a low # of verified... Then if I stop the project and manually verify, the submitted # drops down dramatically (without verifying the submitted links, starts at 100% already).  The submitted # was 15k+, but when I stopped and manually verified, the submitted # dropped down to 900 instantly.

    Also, it seems something is wrong with the email settings... I have it delete the emails, yet right now its still scanning 2440 emails. Using cpanel email addresses.

    Wasn't sure if I should post his here, but being the freeze seems to happen during verification I thought it might be related.
  • edited May 2013
    I am having same problem with .84 version on one of the win7 x64 systems - it just stops responding after running for a few minutes. It is xeon 2.5Ghz, 4 cores and 8 gig ram. Changing thread amount does not seem to help.

    There is no error message - it just stops responding. Checked everything - ram, hdd, all is fine..

    Any chance there is a public repository to roll back to .81-82? 
  • Same issue with 5.84 / Windows Server 2008 R2.
  • LeeGLeeG Eating your first bourne
    I was hit over night with the same thing
  • edited May 2013
    I have been running 5.81 since my comment above (30 hours or so) with no problems at all. Something must have happened when 5,82 arrived.
  • the same for me with 5.82. I have only 1 project doing Diretory submission and freeze after few hours. I
  • yes the same with 5.84, updated to 5.85
  • ronron

    I am flying with 5.84 since yesterday. I did have a couple of freezes with 5.83 this past week.

    The good news with freezes (not that freezes are good) is if you auto-verify the contextual tiers every 1440, those links will be found in your projects files and totals. SER seems to quickly verify the smaller contextual tiers as links are built, so they are not lost. At least not for me.

    And regardless if you disable verification like I do on the junk tiers, those links were still made. You may have no record of them due to disabled verification or 5000 minute verification, but they were still built.

    Just pointing out that all is not lost.

    Everybody reading this, if you haven't already figured it out, should be saving every update of SER in a folder. If you are not, then that is just plain dumb.

  • Same thing happens to me! SER get stucked after 5 minutes of running. I'm at 5.85 and last day I was with 5.84 and saw that SER was frozen. Any update on this?

    @ron - How do you recommend to save every update in different folders?
  • Mine keeps freezing too. Have to kill it in task manager. Just going to stop and wait for an update.
  • LeeGLeeG Eating your first bourne
    Mine have hung twice on todays release with the verifying links.... as the last thing shown
  • edited May 2013
    i still got this crash problem with 5.85

    i'm using scheduler
  • ronron

    Maybe you guys need to try different scheduler variations, html timeouts and wait times. I would try less projects for sure (less than 10), while dialing in different html times like 120 vs 140 vs 160, and I always use 5 seconds.

    Just give it a shot. I'm less than 10 on the project setting and averaging between 50% - 80% CPU, and ram is next to nothing (1.3 Gb), and getting solid LPM.

    I'm convinced that certain versions of SER behave differently, and it is important to vary the core settings to offset those differences.

  • I only had 1 project running per machine... I do not think that is relevant to this bug.
  • Changed some settings like ron recommended. Still freezing... I think this is a bad day for me.

    First GSA freezes, second my ATX power source is burned out! LOL
  • same here. i saw the warning you did not select any verification warnings and no submission what so ever. and millions of urls waiting to be processed.
  • 5.84 froze overnight on both machines w2008 ... re-booted and running 5.85 fingers crossed.
  • @ron

    "Everybody reading this, if you haven't already figured it out, should be saving every update of SER in a folder. If you are not, then that is just plain dumb."

    can you please tell me how to do this or any thread related to save current version SER?


  • same for me 5.85 freeze after hours win xp pro, only 1 project, directory submission, 60 threads
  • so now we have to babysit GSA in case it crashed ... not automatic anymore :(
  • Today I logged into one of the VPS and had a Memory error box. The program did not crash however, it appeared to be working in the background & the Memory error box asked if I wanted to stop the project.

    1 project running, contextual platforms only.
  • 5.85 same deal for me... one machine freeze completely. Back to 5.83 for me : (
Sign In or Register to comment.