GSA works fine, but eventually gets very slow and never recovers

124

Comments

  • LeeGLeeG Eating your first bourne

    I know another member tried what I did last night and noticed a big increase in LpM

    Im still waiting to find out if it was a short burst or if it continued to be a steady increase

  • Twas a short burst and happened again... so I followed your ideas again LeeG and it went like a bullet for a while and then bogged down again... weird.
  • LeeGLeeG Eating your first bourne
    edited February 2013

    I got hit again.

    It looks like its a cache related problem

    Clear the target url cache and all works well for a day

    270LpM all day

    The next day, if you dont clear it. The problem returns

    140LpM and lock ups

  • Active (P) seems to be a problem on my rig. I started with 7 Tier1 projects.. 4 went into (P) after some time.. the rest 3 were hardly submitting anything then.. after i clicked "inactive" on the 4 (P) projects the 3 active ones came back to live and started submitting..
  • LeeG are you really referring to deleting the target url cache in each project, or the target history? cause the target url cache should not be large if search engines are used, how could this pose a problem?
  • LeeGLeeG Eating your first bourne
    edited February 2013

    Even with clearing the target URLs cache I had a lock up again at 5am

    When its submitting it flies

    Similar point each time

    Loading x sites from site list

    Verifying links....

    And then it just goes siesta time

    Restart it again and it works hapily for the rest of the day

  • what abt your other versions that you have simulatneously running.. all same issue?
  • LeeGLeeG Eating your first bourne

    I dont run simultaneous versions

    On any screen shots you see, is pinned links to older versions on the task bar and only one version being run

    Nothing sinister, just pinned short cuts, because Im lazy with opening this and that to start a file

    Right click and pin. Easy as that to do

  • ronron SERLists.com
    edited February 2013

    @squirrelhunter - That's funny. I do the exact same things as you. Every day around noon I change all the projects with Active(P) to Inactive, and SER build links at a much higher LPM.

    I don't think this is a coincidence. 

  • edited February 2013
    I am experiencing some of the same issues myself.  I notice that some of the projects will slow down and eventually even come to a complete halt. Even when I right click to switch them to "inactive" to delete the URL cache, they will hang and show "stopping" forever unless I "Stop" all projects.  Even then they will still hang with no resolve.  If I try to close out GSA to restart it asks, "Projects still running. Quit anyway?"

    Last time this happened I waited it out to see if they would eventually stop so I could check the log files.  They did eventually stop (17 mins later) and the log files showed that they failed to login to the POP3 server for email.  When I tested the emails in the edit options, they tested successfully, but im thinking that the issue with the slow down or stop might have something to do with GSA verifying or trying to login to access emails...either with or without proxies.

    Anyway, I turned off using proxies for email, deleted URL cache, and refreshed each project.  Now everything seems to be running as normal again.  Hopefully it will stay that way,
  • I've been a bit quiet here because while doing the regular delete url history, i deleted also the accounts (never tried doing that, so gave it go), and that wasnt a smart move because in most places you really can't use the email to register again.

    So that gave me a chance to change all emails (that took a while), but sadly the problem remains.Did anyone overcome this situation yet ? I actually very rarely have an application lockup, but sometimes due to the cpu usage it's really hard to press the "stop" button (since it doesnt always refresh).
  • yes my lpm also dropped to below 1

    trying to solve this problem :D
  • @ron - yeah you remember sven recently changed the (p) behaviour, once they go into (p) theres heavy verificaton going on and scraping for new targets think. Unfortunately there is no option to fully stop activity on (p) projects
  • You guys got bad days and good days.. mostly it cannot be pinpointed exactly. Check the program tomorrow, different time and it will run like hell
  • ronron SERLists.com
    I have great days and mediocre days without changing anything. I just think you run into sections of keywords where there are few results, and other days it goes off the hook. I just take whatever it gives me. Micro analyzing is distracting me from making new websites and more money, so I stopped doing it.
  • edited February 2013
    Good that you reminded me.. its time for my 5 minute log window STARING
    @-)
  • edited February 2013
    Having the same issue, started at around 150 lpm in my new VPS, after 20-30 mins its at 5LMP and it stays there... 

    I'm using 100k keyword list, about 5-6 projects, almost no verification on them.. 

    This is frustrating. 

    @Sven, did you fix this stuff a couple of versions ago?

  • OzzOzz
    edited February 2013
    what about your proxies? do you get any search results or just 000/000. monitor your log please.
  • @ozz I checked my log, and I just found that it's using site lists almost all the time, it uses 1 thread for search engines every minute or something (no banned). 

    But its trying to post to lists all the time. 

    I'll try disabling the site lists
  • Ok, after disabling site lists... it uses search engines, but I'm getting already parsed and no engine match... a lot!

    I tried deleting url cache and url history (without deleting accounts). 

    Still getting those already parsed, 

    I'm using google us, gb, mx  msn us, ask us, for search engines. 
    and they are throwing results. (not banned)
  • @Ozz what does 000/000 mean for search results? I am assuming this means GSA is finding nothing at all?
  • LeeGLeeG Eating your first bourne

    Either finding nothing, or your proxies are banned from that engine

  • edited February 2013
    @Sven is this true? >>



    - yeah you remember sven recently changed the (p) behaviour, once they
    go into (p) theres heavy verificaton going on and scraping for new
    targets think. Unfortunately there is no option to fully stop activity
    on (p) projects

  • SvenSven www.GSA-Online.de
    If a project goes to pause it is indeed verifying links only and maybe searching for new tagets to have a nice going again when getting out of pause.
  • I am getting the same problem. Anyone manage to get it solve?
  • @mind which problem?
  • @Kreist The same problem that is mentioned in the OP. After a few hours, the thread count decreases drastically.
  • same to me but doesn't take a few hours just about ~30min or less doh
  • Hmmm, wow. I actually had this problem, but over the past couple of weeks. Did you guys try deleting the url cache? That worked for me really well.
  • SvenSven www.GSA-Online.de
    hope the next version fixes this.
Sign In or Register to comment.