Skip to content

Private Proxies Not Working detected upon use

edited March 2013 in Need Help
Not working detected upon use is the error message when I go in and check the poxies. I have been using private proxies. I notices I was down to 10/25 working on the bottom of GSA where it says P:10  So I open Options>Proxies and test them and they all work! If they fail once then GSA will not test them again? or how does this work?


  • OzzOzz
    edited March 2013
    they won't get used (until manual retest) if you've "disable bad proxies on use" activated.

    if you like to retest them every XX minutes than you need to save your proxies to file and activate parse from file. i wrote a small workaround for re-testing proxies some days ago in another thread. in theroy that method should work, but i'm not 100% sure, so you need to be carefull with that.
  • AlexRAlexR Cape Town
    @Ozz - just testing the method out again. What you need to do is actually add a proxy and then assign it to parse the file. I had 0 selected and so it wasn't parsing the file. 

    Will see tomorrow if it works as expected. :)
  • edited March 2013
    another method is to set the proxy option like shown in the picture:


    important is to set the option "only on less than" 1 "active proxies" and "test proxies all(good/bad)
    and select no source file so if all your proxys die, SER is not harvesting public ones.
    in the example above the proxys will be tested every 15 minutes.

  • OzzOzz
    edited March 2013
    hmm, very nice workaround indeed, but the number for active proxies must been equal/higher than the proxies in use or not?

    in my understanding your settings will only force a test if the active proxy number falls below 1.

    in other words, if you have 10 proxies than the number of active proxies has to be 10, too. if one proxy dies than it will test them from now on until you got 10 working proxies again.

    however, if this is working as expected than i like this more than "my" solution.
  • edited March 2013
    no, its testing every x minutes your proxys but not harvesting new ones. don't know if this is a bug or a feature;-)
    i use it this way for several months and it works!
  • edited March 2013
    you can test it very easily. just disable one of your proxys manualy and set the time to 1 minute. you will see, the proxy is activated again
  • as long as its working i wouldn't care :)
    nice work.
  • AlexRAlexR Cape Town
    @d3ad - have you added a custom proxy site if using the parse from file option? If you haven't them it won't harvest new ones from the file. That's why you might find it's not harvesting new ones. I had this issue and now it's solved. 

  • @AlexR i unchek all the source lists/files, because i just want SER to test my proxys every 15 minutes and not to harvest public proxys. the method i explained is just for re-testing the proxys, no custom proxy site/file needed.
  • AlexRAlexR Cape Town
    @d3ad - you don't need the "when below 1" enabled for it to work as well. I have same setup as you, (i removed the source list parse file), and I also don't use when below 1, and it works wonders. I set it to check every 30 mins. 

    What I love about this way, is you can check if your proxies are dying off/banned, since you see the proxy count drop. Then you know you need to edit the SE interval. Allows for some fine tuning. I'm at 3s and no proxies are getting banned, so might try lower it to 2s. We'll see. :-)
  • OzzOzz
    edited March 2013
    i have timeout set to 1s. private proxies should be faster than 1s if their location is near your VPS.
  • i think for private proxies the timeout does not really matter if you dont have a large amount of them. i just want to avoid getting proxies dissabled because of some lag or other things, thats why i set it to 3 sec.
    i think what AlexR mean is, that he reduced the time between search engine queries to 3 sec.
  • AlexRAlexR Cape Town
    Correct. SE query interval is at 3s. Going to try 2s next and see how it goes. 
Sign In or Register to comment.