Skip to content

GSA freezes my interent connection after 10 to 20 mins

edited March 2013 in Bugs
Hi guys ,wondering if anyone has experienced an issue whereby I run GSA and approx after 10 to 20 mins my interent conenction disappears , no browser or pages can be opened there after and i have to shut everything down and do a restart to get anything (incl GSA) to work again
This started after a version update around 1 week ago. I update everytime there is a new update and I run GSA on my own pc.
Is there anyway to roll back the updates cause it was working perfectly before 5.24 or 25( roughly ) . I didnt make any setting changes , this just starting occuring after an update .
Any help is much appreciated
Thanks in advance


  • SvenSven
    latest versions use more threads. Maybe your router can not handle that. In that case lower the thread numbers or get a better router. There was a discussion about bad / good routers here somewhere as well.
  • yes.. lower threads. older/cheep routers will go down.
  • thank guys will try lower threads and report back. I use 100 curently and my router is a wirless ASUS DSL-N12U 300M


  • This same thing used to happen all the time when I used SER on my home comp a long time ago. after I looked all over the place and read a lot.  the cause of it was some settings I had in my Router.   I had to change a few things in there and it handles everything just fine now.
  • LeeGLeeG Eating your first bourne

    One thing I have noticed is the blog comment verifications have dropped right off with the recent releases

    The only verified I seem to be getting now are ones found in emails

    An older version I was running earlier, was popping verified blog comments all day long

  • edited March 2013
    @Sven - " latest versions use more threads. "

    Sven ... is this the same threads we have access too in Options?

    Will dialing the threads down help with memory issues and functionality people are experiencing?
  • Hunar , any idea what those settings are or were ? I dialed threads way back to 30 and it still happens. reseting the router doesnt fix it i have to restart the comp everytime as nothing else seems to get the internet connection back. I thought captcha sniper rmaybe causing issues so i turned it off and went for DBC but still the same
  • SvenSven
    yes, but next version should run better.
  • thanks sven, hopefully you are right, i will report back once update has been trialled at 100 threads
  • I can report that 5.33 does run better and my internet connection isnt lost as frequently as previous versions( requiring a full restart) . Im running 100 threads and the software will now run for around 3 hours before i lose connectivity whereas previously i could only get 10 to 20 mins out of it.

    This is still not perfect but its much better. I am considering a vps and will read the other threads about the option on this and the best prices etc. Thanks guys

  • SvenSven
    Loosing the Internet connection is not an issue in our program. That sounds more like a problem of your router which is unable to handle a high amount of open ports.
  • ronron

    I find this comment by @sven highly interesting.

    If anybody understands how to pick a router that can handle multi threading properly, please chime in.

    I tried doing some initial research and really couldn't find anything. I was probably not searching for the right terms.

  • fritz!box used here. 1000 threads wont kill it
  • yeah, FritzBox for the win.
  • ronron
    edited March 2013
    Thanks guys. Checking it out now. I see the FritzBox 7390.
  • So in that case how is it that i have been able to successfully use GSA since december 24/7 and not once has my internet connection froze ?? It only started at the exact time i made an update around 5.24 or 5.25

    I have always been able to get 100 threads and LPM of around 7 to 9 but even LPM is now 2.5 if im lucky with the exact same settings .......very very strange guys !!!

    BTW internet connection froze again 4 times yesterday and reseting router doesnt get connection back have to restart the comp completely


  • this could be caused by different thread management in SER since that version. SER is hammering more threads through your connection which your router can't handle anymore.
  • Even if i lower threads to 10 the issue is still present so not sure .....


  • we in germany use the fritz! for DSL. but youcan connect them to a cable modem to to use as a router.
  • ronron
    It is one expensive router. But it has like the highest rating of all of them.
  • we get them for free on our DSL contracts.
  • if you lowered the threads to 10 then it sounds like your net/pc/router is on the blink.

  • I can run scrapebox with 100 threads (while GSA is not open) and no issues at all. it will run all day long

    when the internet connection freezes rebooting the modem makes no difference. The pc itself needs a restart. You would think if the modem was the cause scrapebox wouldnt work either on multi threading but it does plus you would also think that rebooting the modem would restore connection but it doesnt.

    I totally luv GSA its the best link building tool period so i guess im left with going for a vps .

    Does anyone have a kick ass vps setup they can recommend to me ?



Sign In or Register to comment.