Skip to content

Download Failed Sock error: connection reset by peer (many similar errors)

Hello everyone,

I'm having issues with SER. Getting a lot of these SOCK errors. The proxies seem to be working fine other then with SER.
VPM is extremely low, nothing is working. Using 13.92

I am having serious trouble here. I am using @Loopline auto approve lists, 10 dedicated proxies from stormproxies (they just gave me new ones and tested them) wired connection 100mbps straight into router, windows 10, 16gb ram, 4 core i5, no server. In the past few days, the amount of links i got was wild. 

I searched for threads on google and they all seem to have no solution. Lets fix it for good.
-recently, my ISP went out in my area for a day, browsing seems to be fine now. 

I have emailed Sven and he says it may not be SER, but I need help fixing this problem.

In these screenshots below, the proxies would work when tested with bing and say "successful" but when tested in GSA with google.

-tried restarting computer
-tried restoring gsa settings
- when i restarted project, i saw the same link in the beginning a few times *******
- ->List is supposed to autoupdate with fresh links (and has been, not sure if its an error on my link list providers end)


  • looplineloopline
    Whitelist SER in all your security software.  That connection reset by peer is when something is messing with the connection, likely outside of SER its self. 

    the timeout could be a slow site, slow proxy, denied connection by the proxy, weak DNS, the site server is slow, the list goes on.... 

    So make sure your DNS is good, I would try google DNS, its free.  Then also make sure your not using more connections then your proxies allow, as most proxies have a max simultaneous connections. 

    The host not found, try some of those urls in your browser, do they work? or post  few here.  Because that could be all sorts of things too. 

  • Thank you @loopline . I have contacted you back via email and am awaiting a reply. I have uninstalled my security software temporarily. I'm not sure what you mean by the DNS - can you elaborate on where exactly? Is it changing the DNS settings on my machine according to this link?

    10 dedicated proxies at 100 threads.

    UPDATE: yesterday i checked "allow reposting" option and then it started working again, so I'm not sure if that tells you anything. Today, i unchecked that option, and while I am still getting a lot of SOCK errors, It is working at around 30VPM (lower than before). 

    Does this tell you anything else?

  • looplineloopline
    Ive sent you many emails but you keep mailing saying you want a response, are you not getting my mails?  Can you look in your spam folder and maybe whitelist my mail address please.

  • looplineloopline
    I forwarded you mails to both of the email addresses you sent. again if you don't get them let me know and I can try sending them from a Gmail or something. 

  • Hi there @loopline I haven’t been getting emails from you at all. Yesterday I couldn’t post here either due to a token error on a different computer. Please try 
    from a different email. Thank you again.
  • looplineloopline
    I sent mails to the gmail yesterday and you had responded once, haven't been back on that, dealing with paypal at the moment. Hopefully you got them.

  • Yes @loopline got it. Thanks. Please let me know when PayPal has been resolved. Great services and support that you provide.
  • Ive had a lot of this problems aswell, maybe it would be possible to provide additional information by SER @sven is that possible? I dont know what kind of error do SER receive after showing this in the debug log?
  • I am going through this now how did u guys resolve this issue??????
  • edited October 2019
    it's the list you are using. The websites don't work. Get a new list supplier. @skyking

  • Musicdude said:
    it's the list you are using. The websites don't work. Get a new list supplier. @skyking

    No it is not, serpowerlists you saying?  >_<
Sign In or Register to comment.