Make spinfile or file_links work for authority links

edited April 2 in Feature Requests
Hey,

I am trying to have GSA automatically insert a few authority links into my post. The thing is, I have a file of authority links, for the reason that it makes it easier to check if they're dead, or 404s etc. (I have dozens of projects pulling from this same file -- and replacing the URLs in every project takes forever. Pulling them from an external file makes it 1000x faster because I just replace the URLs in that file and all projects are updated).

When I try to use spinfile or file_links in the "custom authority link" section, with more than 1 authority link, it repeats the same URL over and over again. Is it possible to pull multiple authority links from an external file? If not, could you consider adding this ability?

Thanks

Comments

  • SvenSven www.GSA-Online.de
    should work better in next update
  • edited May 6
    @sven it does indeed work now, but it does some weird capitalization on the URLs... the authority links end up like..

    Www.Domain.edu/page-here

    Is there anyway you can make the URLs just be lowercase as they should be? I don't see any reason why they should have this weird capitalization, as it could possibly break some of the URLs.
  • SvenSven www.GSA-Online.de
    isn't that the option to use variations of anchor texts?
  • @sven nope, i have all of that unchecked / not used. the authority links are all posted in this format:

    Www.Domain.edu/subpage

    they should be all lowercase
  • SvenSven www.GSA-Online.de
    can you send the project backup in private message?
  • edited May 7
    Sven said:
    can you send the project backup in private message?
    I sent you a backup of a high memory usage project, but you can test this yourself by simply adding this macro into the "authority links" with your own URLs. Just grab a couple URLs from a news site and throw them into a file.

    #file_links[C:\Program Files (x86)\GSA Search Engine Ranker\auth-urls.dat,1,]

    The code itself does work now, which is great, but the formatting is just messed up. (Read the edit below -- it's not the macro causing the bug, the bug exists even if you insert authority links directly into the project).

    - - - - - - - -

    Edit:

    Surprisingly, this happens on all authority link URLs, even if you put them directly into the section. I just ran a quick preview test with this URL of the forum thread... and the URL was linked like this:

    https://www.forum.gsa-Online.de/discussion/25901/
    https://Docs.Google.com/spreadsheets/

    Notice how it randomly capitalized "Online" for no reason. It seems to do this randomly, not every time. But if you just add a few authority links and do a preview a few times, you'll see what I mean.


  • SvenSven www.GSA-Online.de
    edited May 7
    well if you put just the urls in and not follow format as described here SER ends up with just the URL, it will not know what anchor to use and so it takes the URL or domain from it and applies some variation.

    It only applies modifications to protocol and domain as this is automatically converted to lowercase by all browsers and would not matter anyway!?
  • SvenSven www.GSA-Online.de
    next update will not automatically apply this behavior
  • edited May 7
    @sven I am not using generic URL. I’m using authority links that I scraped myself...

    All I’m doing is having SER link them to a random word, using default settings.

    Shouldn’t have to insert any anchor for the authority links, as SER is intelligent enough to link a random word (*crucial* that this function remains as it has for the past many years, its incredibly useful).

    The links do seem to work, I just don’t understand why SER would be capitalizing random parts of the *authority link* URLs.
  • SvenSven www.GSA-Online.de
    please update and check if it suits you needs now.
  • edited May 8
    @sven, you did indeed fix the issue... however there is one more slight bug.

    the "\n" issue where when a project is saved, it makes a space and breaks the macro URL, in the article section, this is fine (as SER understands that \n still signifies a file path)... however... do this

    1) open custom authority links

    2) use custom macro #file_links[C:\Program Files (x86)\GSA Search Engine Ranker\nettest\auth-urls.dat,1,]

    3) Save

    4) Re-open authority links. Note that the "line break" for "\n" has now been created. Re-save with the line break being active.

    5) Test a preview article.

    6) SER cannot determine (like it is able to in the article section) that the \n signifies a file path. The authority link now becomes <a href="ettest\auth-urls.dat,1,]">

    Any way you can make the authority links section understand this "\n" issue like you did in the article section?

    Thanks a lot for the update!
  • SvenSven www.GSA-Online.de
    fixed in latest 13.52 ... if you updated already, try again and it should no longer thi this linefeed.
  • edited May 9
    @sven, sadly, it's not fixed.

    authority links section still cannot understand that \n signifies a file path

    It will either use the line before the \n line break, or the one after it as the authority link.

    Note that after saving, once the line break is in place, this is how it looks in the authority links dialog:

    Original:
    #file_links[C:\Program Files (x86)\GSA Search Engine Ranker\nettest\auth-urls.dat,1,]


    After saving:
    #file_links[C:\Program Files (x86)\GSA Search Engine Ranker
    ettest\auth-urls.dat,1,]

    It thinks this is 2 lines instead of understand that it's 1 macro "chopped" in half by a \n line break. The article section understands this properly, but the authority links section does not.

    NOTE:
    If you save "once" it will still understand that it's all one line. However, if you re-open the authority links, then press "okay" when it's in 2 lines, it loses the ability to understand that it is all one macro.

    Hopefully that makes sense.... if you save the macro, it will work, but if you re-open the dialog again and re-save it while it's now in 2 lines... it will break the code.



  • SvenSven www.GSA-Online.de
    how about 13.53 ?
  • @sven 13.53 did not fix the issue, I've tested it. Also tested completely saving the project then re-opening, instead of just saving the authority links then preview. Both ways result in the authority links section not understanding that \n is a file path.

    Note 1: The article section still understands this and works properly, it's only the authority links section that doesn't.

    Note 2: I rarely will be touching the macro after it's properly entered the first time. If you save it in the proper format, then don't touch it, it will work fine. It's only if you open it after the \n line break has been "processed" then re-save with the line break that it "loses" the ability to understand that the line break is a file path. So as long as I make sure the format is correct the first time, I should be okay. But if I accidentally re-save it with the line break active, the authority links macro will break.

    In a way it makes sense, because SER thinks it's just 2x URLs as the line break has forced the macro to be broken into 2 parts. Again, if you save it and don't touch it -- it works, it's only when you re-open it after the line break has been processed, then re-save.
  • SvenSven www.GSA-Online.de
    Accepted Answer
    well i have exchanged this behavior now completely even though it was working for me  also in last version. please report back on next update.
  • Oh wow, very very nice on this recent update. Looks great. Thanks a lot man!
Sign In or Register to comment.