Increase Recaptcha2/hard captcha solving time

0
Lord_AlfredLord_Alfred world
edited January 11 in Feature Requests
If use services or captcha solver programs always need to increase solving time min up to 500 seconds. 
GSA SER need to configure this option by the user. And configure max requests for give results.

Comments

  • 0
    Why?
    Because in log I see:
    11:51:01: [-] 18/18 ReCaptcha v2 solving failed - captcha was not solved in time

  • 0
    SvenSven www.GSA-Online.de
    Accepted Answer
    I increase timeout on next update
  • 0
    @Sven, thanks! I test it in the evening. How much seconds SER wait a captcha solution in current (updated) version?
  • 0
    SvenSven www.GSA-Online.de
    Accepted Answer
    500 as suggested
  • 0
    It seems that SER is really slower since this update. I don't want to use "skip hard to solve captchas" option because I don't want to skip recaptcha v1.

    So would it be possible to configure timeout ourselves ?
    Thanked by 1Lord_Alfred
  • 0
    I agree. I would sometimes like to increase the limit even more.

  • 0
    SvenSven www.GSA-Online.de
    a global timeout in captcha setup is something i can add on next update.
  • 0
    Without separating to easy & hard captchas? It's right way for future (I dont known)?
  • 0
    SvenSven www.GSA-Online.de
    i wouldnt want to change the easy captcha timeout...the hard one is the one i changed right now to 500 sec.
  • 0
    DeeeeeeeeDeeeeeeee the Americas
    edited January 14
    I used to get re-do's of G recap, etc. on my cell phone with apps requiring this for login.

    After reading about time factor, I've slowed my manual responses down, and now it's OK. :) Responses now accepted.

    They were right even before! I guess just too fast a response?
  • 0
    @Sven, new option "Timout to captcha requests to solve" exactly works?
    I buyed new soft for recognition recaptcha v2, start 1 project and I see many errors in log:
    23:33:13: [-] 026/694 ReCaptcha v2 solving failed - captcha was not solved in time

    But timout not ended (project runned < that timout, in other words: project runned in 23:20, recaptcha timeout is 1500 seconds, but in 23:30 SER put in log errors).

    And second reason: in gsa ser I see "Threads: 28", but in recaptcha v2 soft in queue 630 waiting for solve threads.

    Can I help you to test this? Maybe record a video and send log?
  • 0
    SvenSven www.GSA-Online.de
    what protocol does that software use?
  • 0
    2Captcha
  • 0
    SvenSven www.GSA-Online.de
    I made a mistake here, the timeout was calculated wrong and multiplied by 60 instead of 1000. I will release an update in a minute.
  • 0
    @Sven, thanks! Don't worry, I'll wait. Better test it again just in case.

  • 0
    @Sven, big thanks for fast hotfix! It seems like now everything works as it should.
  • 0
    This timout not block closing of SER? Because, I set projects to "Inactive", wait some time to "Stopping" status and click on close button - after this program not closing.
  • 0
    SvenSven www.GSA-Online.de
    hmm some threads may take longer to close...I try to optimize that though.
Sign In or Register to comment.