Url needed for RankCipher integration

0
Hello everybody,

I have bought RankCipher software and I am trying to integrate CB into it. It is asking for API key|Host URL.

I do not know what I have to put here as 127.0.0.1 is not working. Can you help me?


Comments

  • 0
    SvenSven www.GSA-Online.de
    can you make a screenshot of that captcha setup dialog?
  • 0
    SvenSven www.GSA-Online.de
    1. make sure Captcha Breaker runs with "webserver enabled" as option
    2. make sure it runs on 127.0.0.1 as interface and port 80
    3. in that captcha options make sure you also use 127.0.0.1 as HOST and it should work fine.

  • 0
    If you are using the web based version of rank cipher, then use the ip address of the server (where captcha breaker is installed) as the api key/url.  I've set it up this way and it works perfectly. Make sure to put http:// at the beginning.

    For example: http://191.152.132.62

    Also in CB, change the 127.0.0.1 to your server ip address.


  • 0
    Hi,

    Thank you for your answers, guys, but I still have problem with port 80.

    I have tried with and without  http://, https://, with 127.0.0.1, with my computer IP and it does not work.

    In the cmd console I can see that any of the programs is using port 80.

    I have totally disabled Windows Firewall, it does not help. 

    I do not use skype, I have disbled IIS services, I have uninstalled Xampp, Emet, IP hiders, DUC, VOIP dialer, avereything I could. Nothing helps.

    I have tried to start CB in rescue mode: the same.

    I have uninstalled CB, I made a deep registry and files clean up using CCleaner and Advanced System Care: the same.

    I always start CB as Admin.


    Any other ideas?
  • 0
    SvenSven www.GSA-Online.de
    Sorry I can not really help you as this seems to be a problem on this RankCipher. Is that even a program or just a webinterface?
  • 0
    They offer both desktop software and a web based version.

    The web based version needs an api key to access captcha breaker. I have my CB on a vps, so when using the vps ip address as the api key, it works great. But trying to send the captchas to my home pc shows the error messages of port 80 being busy with skype or the other services.

    If using the desktop version, then it works fine as long as CB is on the same machine as the software. No settings need to be changed in either tool.


  • 0
    SvenSven www.GSA-Online.de
    I guess that "desktop" version needs port 80 as well. So you might want to use a different port in CB (e.g. 81) and use that port along with the IP in that other software like 127.0.0.1:81
  • 0
    No, it is not. 

    My CB does not want to run as webserver: http://www.averias.site/Captcha_Breaker.pdf.

    I have this problem when I star CB, even before opening the other software.

    Just when I check "Run as Webserver" option, it denies the connection.
  • 0
    edited April 2017
    If you are using the desktop version of rankcipher, then keep everything as default: https://www.screencast.com/t/RVG2HRuMZuW I've managed to get that set up working fine.

    The web version however, I've only managed to get it to communicate with CB on my vps, when listening on my vps ip. It doesn't communicate with my home pc using 127.0.0.1:80.
    I also tried http://127.0.0.1:81 and CB tests fine as working https://www.screencast.com/t/JMrNBThPoV6q but rank cipher fails to communicate with CB.

    So it may be a bug within rankcipher that needs fixing. It has plenty of other bugs already that I've reported to them. Just use the desktop version instead.
  • 0
    Accepted Answer
    Brrrrrr....

    Solved.

    To whom may have the same problem: 

    In order to make Captcha Breaker run on my computer I had to open port 80 in my router as TCP/UDP to the computer ip (for example: 192.168.1.39.

    Now I can run Captcha Breaker as Webserver listening on 127.0.0.1.


    Regarding Rank Cipher: 

    If I run it as a desktop application, if I put http://127.0.0.1/ it is working well.

    In the web based version I am not able to make it work: neither on 127.0.0.1, neither with my computer IP, neither with my real router IP as sickseo suggests.

    So I will be forced to use destop application.

    Thank you, gentlemen _)

    .


  • 0
    agus0185agus0185 indonesia
    Heloo
    
    greetings
    
    Do you also use indexer in rank cipher by using GSA SEO Indexer ?? How to make it work ??

  • 0
    wow seems many people useing it.... i even didn;t care to use...

    is that really good ?  dont think its defined as ser 
  • 0
    Cosmetak 

    nope thats sucks. its a shiny product from warrior dk heads
  • 0
    Use the ip address of the server (where captcha breaker is installed) as the api key/url.
    192.168.1.1 router login
  • 0
    Miguel5 offtopic.  - Do they really update the tool (web2.0s etc) and worth to try ? I can see their sales page broken.
  • 0
    Very informative post thanks for sharing.
Sign In or Register to comment.