Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Indexer has VPN CPU running at 100% within 30 seconds of starting it

I've tried changing everything I can think of. Have run it in quick mode, also with using only 80 sites. Also have bumped # of threads down to 40 and it still does the same thing. Anything else I can do? I used to be able to run it no problem in quick mode with 300 threads. I am not using proxies.

Answers

  • Maybe I should move this to the need help section. Not sure how to do that though. Can someone help me out here?
  • Nothing? It takes 4 days to index 2 weeks worth of links no matter what I do.
  • SvenSven www.GSA-Online.de
    OK well please explain what your problem here is, a too high CPU usage, a too slow operation or ? Because I don't understand what your issue is.
  • Use an indexing service like Incredible Indexer, their API can be added to SER and it can take 100k URLs per day and costs $25pm. It doesn't slow your machine down and is very good at indexing links.
  • edited March 2014
    I do use an external indexer (indexification) but it honestly doesn't seem to have the same results as GSA indexer does, which is why I am now using both. The issue is that it takes a week to index 20k links on the VPN due to the processor becoming overloaded once a minute. This is a new occurrence, happening within the past month or two. I can't run it at the same time as SER due to issues with overload, so I will run it about once every week. When I run the indexer alone, it still is extremely slow. It says it's doing 539 LPM but it's only running through 3k or so of my links a day. I used to be able to run through 20k in a day with the settings I'm using now. I don't know if the VPN changed something or if the indexer did. If other people aren't having this same problem, I guess I'll look into another VPN or upgrading my service. This is what my task manager looks like when only the indexer is running: http://i.imgur.com/TTGSeT4.jpg
  • SvenSven www.GSA-Online.de

    OK so the reason why it takes longer now is simple...you just have way more sites in it now and it takes longer to use all of the sites for one entered URL. You can lower this and have a lower number , maybe set it to 2000 and it might get your links indexed as well but surely not that good as in full indexing mode.

    About the CPU usage: I run a full test this morning and my CPU usage never ever got to 1%...so I wonder what this might be. Do you use any anti virus program or firewall? I can only imagine that those are intercepting the calls.

  • I've tried with the firewall on and off. Makes no difference. It's interesting because svchost.exe is the process taking up all the CPU when this is running. After I shut down GSA indexer the svchost CPU load goes back to 00. Maybe I'll try running this on my home PC at night, which is a lot more powerful than the VPS, and see what the load is like.
  • I will say though that I do not agree with your assessment as to why it's taking longer. It's taking longer because it will hang for 2 minutes on one site while the CPU load is at 100%. Once it goes down, it starts submitting again.
  • SvenSven www.GSA-Online.de

    Try disabling this Microsoft Virus scanner (forgot the name). People reported it takes a lot cpu usage and slowed down SER a lot.

    Also do you use the option to create reports for each submission? If so, uncheck it please, should improve the speed a lot.

  • SvenSven www.GSA-Online.de
    Ok made some changed to the new version which should work speedy even if you create a report for each submission.
  • Microsoft security essentials I think is what it's called. It's not running on this server. I will try the new version. I didn't try running the indexer on my home PC last night but I will tonight.
Sign In or Register to comment.