Skip to content

Serious Performance Problems!

Hello, I got a very powerful VPS, and I am running about 15 projects and my CPU is always at 99%, I recently upgraded and maxed out my VPS, but I am still having this 99% and contacted my hoster. They said it could be my software and got some coding errors.. It's really frustrating because sometimes GSA SER is crashing... Please help me Sven


  • Ok, seems like I'm not alone with this issue and it could indeed be related to the CPU load.

    @orangensaft, are you seeing this error window?
  • Dude, I've got a 32GB RAM 8core dedi and mine runs at 99%. Lower your threads, check your settings, proxies, filters everything to see if you can adjust and tweak it to run at peak performance without tipping over the edge.
  • @johnmiller I had the same error message too. I have checked everthing, threads, proxies, settings.. and still sometimes crashing and dropping LPM
  • edited February 2014
    I've also recently had performance issues. I don't know why, but all of a sudden since 4-5 days ago, ser would almost never use the amount of threads I specified in options. It's usually only using a few hundred out of a thousand threads. Also it's at 99% cpu almost all the time (in resource monitor), it used to just be 30-40% while ser was using 1000 threads. It is very crippling and I can't figure out why this happend all of a sudden.

    Edit: Just wanted to add that SER is very often giving me the message "(Not responding)" in the title of the window. It really has never acted like this before and it's not running near the amount of threads it used to.
  • yep I am noticing high CPU usage recently too.
  • @fakenickahl 1000 threads is alot!!! I am using just 100 threads with 15 active projects and my VPS should handle it without using 99% CPU! It used to be 40% for me too, but since february it crashes sometimes
  • edited February 2014
    I used to run 1500 threads without much trouble, but that sadly changed after some updates and until a recent memory update I was not able to run more than 700-900 threads stable, after the memory update I was able to get back to 1200 threads. I'm using a quite powerful dedicated server, which SER only used a maximum of 50% cpu when running 1500 threads. But since a few days ago I have not been able to get anywhere near this amount of threads.

    Btw. I just tried disabling the log in my ser and it immediately became "not responding" though I saw in the resource monitor that I was using all 900 threads I allowed it to. Seems very strange. If it could help you out in any way @Sven, I'd like to give you access to my dedicated server to try out whatever you feel like.

    Edit: Damn, I write way too many words when I'm trying to explain myself, so I'll try keeping this short. SER is finally using 900 threads after I recovered from the crash described in the paragraph above this. I think disabling my global verified list on all my 11 projects was what did the trick though I changed quite a few things around and first saw the results after re-opening SER. Still at 100% cpu all the time (resource monitor, SER always shows 99% no matter what the resource monitor says), but I'm happy as hell now :) Oh, and SER is not becoming unresponsive anymore so far.
  • edited February 2014
    I have completely different problem. I have a 12 gb octa core vps and I can't get ser to constantly use above 10% cpu even though it is using 1.5 gb of ram. Is there a reason why this could be happening. On my vps ser is always using 0 -5 % of the cpu.
  • Update your SER. I remember there being a problem with an earlier version where SER was not placing an equal load on each CPU core.
  • Hey I have updated to the latest version and now my CPU is only at 20-40% thanks Sven. :)
Sign In or Register to comment.