Skip to content

Secondary anchor text doesn't work in any way...

I spent hours today trying to use secondary anchor text, texting, trying different ways and testing again.... uff, it doesn't work in any way.


What I need to do

For my tier1 I usually use this formula for the anchor texts:

  • primary keyword: 20%
  • secondary keywords (Long Tail Kws): 30%
  • generic anchors: 40%
  • Url anchor: 10%

I can see that GSA has 2 options to insert secondary kws.

The first option

I inserted the data by: Edit > Add URL and Anchor Text + Secondary Anchor

Later I edited the field to insert a total of 3 secondary anchors and another url of an inner page.

So in the end the data were:

http:// www.moneysite .com#Keyword1#{Sec-Keyword1|Sec-Keyword2|Sec-Keyword3}
http:// www.moneysite .com/secondpage#Keyword1#{Sec-Keyword4|Sec-Keyword5|Sec-Keyword6}

I tested it (with fake urls) but in the results I didn't find any secondary keywords. No one in the excel report and no one in the real urls online just created.

I also tried with only one target url, with the same primary and secondary keywords, but again there weren't any secondary keywords.

So I tried the second option of GSA.

I now wrote only one url in the URL field, with only one primary keyword:

http:/ /www.moneysite .com#Keyword1

Later I writed the secondary keywords in the field Secondary anchor text, with a % of 30%.

I was thinking to start 2 project in this way, each one with one target url, because it seems impossible to write 2 urls with different primary and secondary keywords in the same project.

Anyway, also this second method didn't work, I didn't find any secondary keywords on the new anchor texts.

So.... how is it possible to insert secondary keywords as anchor text? I couldn't find any way.

Thanks for the help


  • SvenSven
    What engines do you use with it? Was it working in TEST/Preview?
  • I use all the english search engine (167).
    I was using Blog Comment, Image Comment, Guestbook, Social Bookmark, Wiki (not directories because directories doesn't use anchors).

    Was not in test/preview, I submitted and verified real urls (but fake website, like www. moneysite. com and anchors1, anchors2 etc).

    Until now I only used GSA for tier 2 and 3,  so anchors were not so important, but now I'm trying to build some tier1 for less important website, that's why I need good anchor text.

  • I can confirm it got messed up in last update. When using http:// www.moneysite .com#Keyword1#{Sec-Keyword1|Sec-Keyword2|Sec-Keyword3} http:// www.moneysite .com/secondpage#Keyword1#{Sec-Keyword4|Sec-Keyword5|Sec-Keyword6} you get an error when pressing OK for the project. It still seem to work under testing though
  • No @supermanded, i didn't go any error message, everythin go on but when it finish if I check the verified urls, the secondary anchors are missing all
  • SvenSven
    @supermanden what error message is that?
  • I am actually trying to enter a new campaign and I can not even enter any text at all or even past content/data into Partial match, secondary, branding etc fields. Can you help with this? 
  • Peter, how many verified URLS did you do the test on?

    I have always assumed that the anchor % only work at the submitted stage so you need to keep an eye on the verified % to make sure they stack up.  I am pretty sure that is how SER works but maybe Sven can confirm.

    That may be part of your problem, especially if you only tested a small sample size. 
  • webproplus.  Might be a silly question but have you checked the box adjacent to the area you enter your anchors?  You can only enter anchors when the boxes are checked.
  • SvenSven
    Yes it works for me. I get many links with the other anchor definitions. So please send me a project backup and I have a closer look.
  • Hello @Sven,
    yesterday I started a new project for to check again this problem. It's again a "fake" project, with fake urls and fake keywords, but a "live" project because the backlinks are real. Here the report :-)

    The first test-project (the one I talked when I started this topic) was with only 30 verified links, anyway no one of the verified links had one SECONDARY anchor text.

    Yesterday I started another one, new and different project, and I stopped it after exactly 100 verified links.

    My settings were:

    URLS and ANCHORS (submitted by Edit > Import > From File > file.txt{key4|key5|key6}{key7|key8}#key9

    Other settings
    Generic anchor text    30%
    Domain as anchor text   10%

    This time the generic and domain anchors worked well, I got a % very similar to my settings.
    I got also ALL the primary anchor text (Key1, Key3, Key7 and Key8) but, again, NO ONE of the SECONDARIES anchor text (Key2, Key4, Key5, Key6 and Key9).

    Later I started another project for a REAL website with REAL urls, but it's a website where I have many pages (42), so I just set 1 anchor for every page in the same way of before (imported txt file), and it worked well. But here there wasn't any secondary anchor.

    So i think there is a problem for setting secondary anchor text.

    If my description is not enough, tell me and I'll send you the backup of that project.

    Thanks for the help :-)

  • SvenSven
    please send a project backup to me for review and debug.
  • Ok Sven, on my next message.

    Today I was thinking that I can solve this problem just "tricking" the system, putting the secondary anchors together with the primary, in the follow way.

    When I want 20% primary keyword, 30% secondaries keywords, 40% generic and 10% domain urls, I can set:
    - ht tp://www .pippo. com#{key1|key1|key2|key3|key4}
    (where key1 is my first keyword/anchor and key2, key3 and key4 are the secondaries anchors)

    and select:

    - Generic anchor text  40%
    - Domain as anchor text   10%

    IN this way it works. The only thing that (I think) is not working are the secondaries anchors settings.

    Now I prepare the backup
  • Ok, I just sent to @Sven the backup of the project-test.

    Waiting any change, I keep using my last method (previous message), that is working well
  • SvenSven
    ok thanks will debug once im in office again.
  • Yes I checked the boxes. I was waiting to see if one of he updates corrected the problem, but I am still having the problem basically when I start new campaign, 

    I can not enter anything into the fields concerning 
    partial match 
    secondary anchor text 

    I check the box, but can not type anything in those boxes... 

    I am using windows 8.1, that may be the problem.. 
  • SvenSven

    @WebProPlus this might be a problem of your DPI settings. I guess you have a warning when starting the program about big fonts?

    By the way, the problem in OP was, that the box to use secondary links was disabled. However it has to be enabled as you need to enter the percentage. Else the secondrary anchors in URL are ignored.

  • Ok @Sven, I tested the same project again with the solution you gave me by private message (tick the box of secondary anchors) and now that anchors worked pretty well! (On the first test of before, no one anchor was present in the results).

    I think the first time the problem was the error message that appair if I tick the box of secondary anchors without filling the next field. As I writed my secondary anchors up in the url section, there was not need to write the secondary anchors another time in the field next to that box, but the error message "Not content entered for "Secondary Anchor Text" made me not activate that function. Simply it's possible to "ignore" the message and everything works (even not very intuitive at beginning).

    Here my results for 104 verified urls per total 3 website's url submitted. The final numbers are not perfect, but I think that with bigger quantity f verified urls, the problem will minimize and will coincide to the setting options.

    Primary Anchor Text
    • My settings: 20% per Url
    • Results: from 20% to 35% per Url
    Secondary Anchor Text
    • My settings: 30% per Url
    • Results: from 9% to 16% per Url
    Generic Anchor Text
    • My settings: 40% per Url
    • Results: from 24% to 32% per Url
    Domain Anchor Text
    • My settings: 10% per Url
    • Results: from 3% to 19% per Url
    SO the problem for me has been solved, thank you for the help!
  • Sven,

    I have been wanting to come back and re-use this again and start learning GSA again as I used it heavy and then kinda stopped for a period of time.

    I wanted to say thank you. I was only at medium but for some reason that was causing an issue with typing into those fields... Thanks
  • SvenSven
    @WebProPlus glad it's sorted thanks for feedback.
  • ronron
    I use this field on all projects, and it works fine. I think this was an isolated issue.
  • HI Sven,

    I had the same problem as Webproplus on one of my installs but not on the other... both had used the medium monitor settings, one worked the other still doesnt.. so today I changed it after reading this thread... It now works on either the small AND THE LARGE settings.. but still wont work on the medium.. very weird...

    I cannot replicate it on another machine because it is only happening on this one install...  not sure if this feedback helps you to avoid this problem with DPI in the future...

    just glad I can now use the partial anchor box again...

Sign In or Register to comment.