VPS CPU load issue

I have recently bought a hexa core VPS from Solid SEO VPS (the most expensive SSD windows VPS) and i installed GSA on it. I am running GSA with 50 threads and CPU is at 100%. 

I contacted the support and i got immediate responses. After they further investigated here's what they said.

"
Thank you for holding, We are running your vps on 800 Thread on the same cpu, so if the vps is the problem, raising it up from 50 to 800 would have made the software to crash or non responsive, however its ready.. I would suggest you contact Sven from GSA regarding this, since we believe this issue is not caused by the vps. Could be a bug with GSA SER that would be address in the next release.
"


Did anybody encounter this issue?
@sven - Could this be a bug in GSA? The vps is running windows server 2008 with all the updates
Tagged:

Comments

  • SvenSven www.GSA-Online.de
    Accepted Answer
    not really a bug in SER I think. It could be that microsoft security program that caused a lot trouble recently. Try to disable it if it's running.
  • Thanks for your help @sven but i really don't know which program you are talking about.


  • SvenSven www.GSA-Online.de
    Accepted Answer
      microsoft security essentials
  • I have my gsa running on 99% also all the time, doesn't matter if I have 40, 80 or 120 threads. I have 2gb ram and 2 cores vps. I don't have "microsoft security essentials" running under proccesses.
  • Trevor_BanduraTrevor_Bandura 267,647 NEW GSA SER Verified List
    @comancsm Not sure that I really understand the reply you got from solid?

    Are they saying that, according to them, they see SER running at 800 thread when you have it set to 50?

    or

    They ran SER on 800 threads on your vps?
  • Trevor_Bandura  They ran it up to 800 on the VPS but didn't crash. It doesn't crash but the cpu is at 100% with any number of threads above 50 and it laggs awful.


  • Trevor_BanduraTrevor_Bandura 267,647 NEW GSA SER Verified List
    Ok thanks @comancsm ;
  • solidseovpssolidseovps solidseovps.com
    comancsm our staff are checking this for you
  • Having the same issue, disabled microsoft security essentials with the biggest SSD by solidseovps it's freezing and lagging with just 100 threads on an imported list of 500k URLs.

    Did anybody manage to get a better performance somehow or could recommend anything that helped? Proxys can't be the problem as I'm using 70 proxies from buy proxies. The only thing I could think of is CB running along with SER but then again, it's 'just' 100 threads for such a powerful CPU (security essentials disabled).
  • How are you guys determining how much CPU ser uses? In the bottom of ser, mine always says 99% and never changes. But I've also always got resource monitor open and that tells me the average cpu usage of ser for the last couple of days only have been 20%. It's normally bouncing around < 20% but sometimes goes to 60%. I don't know how ser determines CPU usage however I usually tend to trust the windows resource monitor more. I'm running 1k threads btw.

    Also do you have any problems with running ser on many threads or are you just trying to figure out why it always says 99% cpu usage?
  • I had the same issue with solidseovps - switched back to my old vps provider --> everything runs smooth. I installed a backup of my solidseovps Ser installation and now I can let Ser run with 900 threads with a cpu usage from 60-80% max.
  • What is your old VPS provider?
  • edited January 2014
    The 500k list is your problem. Split it using Text Wedge or Scrapebox into 50k chunks and load the lists in. See my and gooner's posts regarding out of memory errors. It's most likely the settings/filters/lists being the problem not the server or SER.

    I loaded a 2mil list in and my very fast dedicated server struggled. Now it's down to 800k and it's much faster. Spread the list over a few sites/projects and you will even have less of a problem.
  • @JudderMan thanks but it's not out of memory errors.  It's just the CPU load is heavy even running just 40threads. 

    However I'm going to give it a shot with a 50k list only and see if that makes any difference and report back, thanks for the tip might try it out.
  • Just tried it with a 50k list imported, deleted a lot of older projects, cleaned up the identified/submitted/verified/failed folder and running with 100 threads still with the same issue unfortunately.

    One thing I noticed: the problem occurs when running projects with multiple (including KS like comments / guestbooks) enabled only when running from a raw scrape. Starting a project from my verified list on articles only for example the CPU usage goes much lower, maybe Sven or others could comment if processing a lot of raw URLs combined with many engines enables (due to workload identifying the platforms across several footprints) could be the issue.
  • Those facing same problems, for me, unchecking 'skip for identification' at options solved the high load issue. Talked to another forum member he's experiencing same, so probably a bug @sven .

    Seems like it's right now if it's going without a proxy for identification it takes more CPU than with a proxy.
  • SvenSven www.GSA-Online.de

    so with proxies for identification its less cpu than without or the other way around?

    Though this is just a 2 lines of code...It can not have such effect.

  • edited January 2014
    @Sven but it seems to have. Maybe it's somehow related to CB (running CB along) but I tested it and another guy (maybe he'll jump in) tested too, so it's definitely having some influence. 

    Also if there's a bug with proxies (possibly somewhere else related to proxies too?), it affects every single submission we do which would explain the high usage, wouldn't it ?
  • SvenSven www.GSA-Online.de

    sorry I can't see any issue here. Just checked and a 

    (proxy_flags && skip_for_identify > 0) is taking almost zero CPU time

  • Very strange, thanks for looking into it, I'll just keep it unchecked since it's working better for me :)
  • @comancsm: I'm using hostamus - 2GB RAM - $35.-/month
  • @theseo1 THANK YOU!

    I was experiencing the same issue and nothing seemed to fix it. But unchecking "skip for identification" completely fixed it.


Sign In or Register to comment.