Skip to content

"Automatically search for new proxies every ____ minutes" feature isn't working properly

I have mine set for every 60 minutes on less than 300 proxies.  I did a manual search for proxies about 12 hours ago an it found a lot but I noticed that the option to schedule this isn't working.  I'm now down to 16 proxies and according to the log, it hasn't done another search since the last manual search was done 12 hours ago.  Odd!  Again, just so I'm clear, SER isn't doing the proxy search and testing when it's scheduled but it does if you stop the software, shut it down (or wait until all processes are done), re open it and manually search and test.  Sven, please look into this and let me know if there's a fix for it.  Thanks


  • SvenSven
    the proxy searcher works fine over here. can you make a screenshot of the settings?
  • Here it is.  It seems the scheduler works initially then stops working after a several hours.  If I do a manual search and test, SER will usually find a lot of proxies but not when the scheduler has done its initial first few hours and then it'll stop searching and testing.  I hope this is written in a way you can understand what I meanimageimage
  • Not sure why the image didn't show, but here's the link below.
  • I noticed the following:

    identify+sort-in without proxies, "automatically search for new proxies every XX minutes" unchecked --> it searches for new proxies --> possible bug ?
  • SvenSven
    @CecilDee you set it to test all (good/bad). And since you have a massive list of none working proxies, it also takes very long to test this all. So it means no new proxies are searched for until the last test is finished.
  • edited December 2013
    I have exactly the same thing and I noticed after days wondering. After the 7.09 update: new: improved proxy checkers - The checking threads just hangs between 1-4 threads. To solve this, I would need to restart the entire software. Need to mention that I use 100 threads to check proxies.
  • Yeah I did set it to check all (good/bad) b/c sometimes proxies register bad after testing and the same exact proxies can register good after testing them again.  Not sure why but it happens often enough, so I test them all.  I'm sure the function is working well initially, (this is just a guess) but it could be that when SER is switching from running one set of projects to the next, something is messing up the proxy count during the switch.  Not sure but it seems like something gets lost during the switch.

     (e.g. "Number of projects to run at the same time  __ ; Switch to next project after ____ minutes")
  • SvenSven
    @CecilDee if you just check good proxies, you have the other option to retest previously working once. I would simply use that one + remove all proxies who are older than 1 day.
  • I guess try changing the URL for checking if anonymous. Also as @Sven says; I've set to check only newly and re-test previously working.. Also remove bad proxies older than 20 mins. This works for me.
  • Thanks guys, I've actually started using private proxies so the issue is now resolved due to my upgrade.  On another note SER version 7.23 seems to be "Out of Memory" a lot.  I was running 7.22 for over 24 hours straight before I got the "Out of Memory" popup.  @Sven, do you know about this?
  • SvenSven
    hmm sorry no, this out of memory should not appear more often than in older versions.
Sign In or Register to comment.