Which Article for which URL in Article Menager - Problem, need your help

grax1grax1 Professional SEO, UK | White Label SEO Provider
edited November 2013 in GSA Search Engine Ranker

Hi guys. I need your help. I have a website and there are 3 pages there that I want to rank. Each page is from related category, but it's still about different topic - so for each page I created different spinned article that I want to use for T1. I added every article into Article Menager. In each article there is macro in the text: "<a href="http://www.mysite.com/page1">%anchor_text%</a>" for 1st page, "<a href="http://www.mysite.com/page2">%anchor_text%</a>" for second page and the same for 3rd page.  There is no "<a href="%url%">%anchor_text%</a>" - %url% is already filled in every article with url from related page.

In URL Form I added 3 URLS (3 pages that I wanna rank) like this:

image

And here is the problem: SER chooses all randomly. I tested both options: "<a href="%url%">%anchor_text%</a>" in every article, and "<a href="http://www.mysite.com/page1">%anchor_text%</a>" (http://www.mysite.com/page1 for article 1, /page2 for article 2 and so on) and SER takes article 1 and insert a link from page 2

even if there is already this macro in article 1: "<a href="http://www.mysite.com/page1">%anchor_text%</a>"

SER still can insert in article 1 http://www.mysite.com/page2 even if I selected "No link"(screen below) in Menager options and the only link in Article 1 is for /page1 !

I have no idea what to do and I really need to fix it.

I asked @Sven, and he told me to add "<a href="http://www.mysite.com/page1,2,3">%anchor_text%</a>" instead of  "<a href="%url%">%anchor_text%</a>" and select option below, but it still doesn't work :(

image

 

Generally, let's say my site is about fitness: page1 - fitness diet, page2 - fitness workout, page 3 - fitness stars. So as you can see - it's all same big category - fitness - but every page is different, so that's why I want SER to choose certain articles for certain urls... but don't know how.

 

I can't create separate project for each page because I'm using global lists and when I have 3 separate projects than I get backlinks from the same domains 3x.

Comments

  • grax1grax1 Professional SEO, UK | White Label SEO Provider

    really, nobody knows ? I thought some of you guys already faced this problem, @ron and @s4nt0s maybe you can somehow help ?

  • SvenSven www.GSA-Online.de
    next version should fix it for your special case.
  • grax1grax1 Professional SEO, UK | White Label SEO Provider
    edited December 2013

    first of all, thank you @Sven ;for trying to fix my problem so quickly :-* ! But, it looks like it still doesn't work correctly.

     

    SER always chooses the right anchor for certain URL, so this is ok. I inserted 3x different URL for each of 3 pages - so instead of  "<a href="%url%">%anchor_text%</a>" , there is "<a href="http://www.mysite.com/page1">%anchor_text%</a>" in first Article, /page 2 in 2nd and so on...

     

    SER always keep these URL, so when I test there is always "<a href="http://www.mysite.com/page1">%anchor_text%</a>" in Article 1, and never /page1 in Article 2 or 3 and so on. So this is also ok. The problem is, it sometimes foes like this:

     "<a href="http://www.mysite.com/page1">%anchor_text%</a>" and "anchor1" as anchor(always right anchor for right URL, but it takes article for Page 2 or 3 and not for 1, so at the end it looks like this: when I test:

    http://www.mysite.com/page1">%anchor_text% -above in the URL

    anchor1 - in Anchor Text form

    and then there is Article - sometimes it's article 1 which is correctly, but it also takes article 2 and 3 for page 1 and it inserts "anchor1" - which is ok anchor for URL /page1 but article is for /page2 or 3 and there is also URL for page 2 or 3 even when SER shows URL 1 and the Test.

     
  • SvenSven www.GSA-Online.de
    Sorry I got lost with all the articleX and anchors...hard to understand.
  • @sven

    this is exactly the same situation as WE had (in regard to my site / article manager) a few weeks back.

    the article manager had NO anchor text field to clearly define the precise subtopic of each article
    that missing field is a pain n my SEO heart !! :)

    @grax1 made a difference that may be less ideal

    I have same main topic = all about "kriya yoga, God and Love"
    = a huge topic (with earlier some 40'000 pages on my full site until 2012)

    hence I split it up into 3 projects, each one T1 and T2
    on top of all T2 I have ONE T3

    even by splitting up @grax (or my) main topic,
    and adding new articles
    each article is relevant to the main topic AND optimized to the subtopic,
    yet TOTALLY different = needing precise individual keywords=anchors for its linking
    OR
    as we had recently instead of an individual anchor / keyword for each article = to have / use the %meta_title%
    here again we would need a field to enter the macro %meta_title% for each article


  • 2Take22Take2 UK
    edited December 2013
    Hi @grax1,

    I understand why you would want to use macros to make things easier, but it seems to me that in this case they are just making your life difficult.

    Would it not be easier to just insert the urls and anchors into the articles in html format manually?



  • grax1grax1 Professional SEO, UK | White Label SEO Provider
    edited December 2013

    Thanks you guys for your replies. First of all sorry that I made it all so complicated - I thought it's not so hard to understand but when you don't really know what's my problem then it indeed might be chaos. You probably were like:" what the hell he wants ?". Next time I will read my posts 3x to make sure it's all easy to encompass. I should show you it all with screens as an example right at the beginning, below are screens I took on example to show you what's my problem - I hope this time you will all know what's wrong in my opinion.

     

    image

    These are 3 articles that I inserted in Article Menager - exactly like on the screens(links to make it visually clear):

    Article Menager settings:

    Data:

    And here is the problem:

     

    image

     

    Of course, sometimes it goes in a right way as you can see here:

    But then it's again wrong:

    I hope it's all clear now, so @Sven can you tell me whether it's some bug or just me doing something wrong ?

  • grax1grax1 Professional SEO, UK | White Label SEO Provider
    edited December 2013
    @2Take2 - "Would it not be easier to just insert the urls and anchors into the articles in html format manually?" - I can insert URLs, but I can't insert all anchors because I also want to use SER default generic anchors
  • SvenSven www.GSA-Online.de
    Accepted Answer
    hmm wait, thats just an issue in the preview/test. On submission this should work just fine.
  • grax1, I love you!! for the fact that the problem outlined! thanks!
Sign In or Register to comment.