Skip to content

Getting lots of DoFollow and Very Few NoFollow Links

edited November 2013 in Need Help
Recently I have been getting loads of dofollow links and very few nofollow links. One of my latest projects had about 5K dofollow links and only 300 nofollow links. The site ranked high on Google for few days and then dropped to 10th page. I am not saying that very few nofollow links might be the reason but it can be as well. My settings are good and I havent checked the option that allows you to create only dofollow links. I am using SER engines and checking almost all boxes on where to submit.



  • It would be good to choose a % of df and nf links. I get around 80% DF and that's not really natural.
  • edited November 2013
    where do we choose the percentage?

    Edit - Sorry. I thought the option is already available.
  • The problem is you can't know 100% whether a submitted link will be approved, and then if it will be dofollow or nofollow. Therefore theres no exact way to set percentages.
    There are engines that provide nofollow links by default eg. Jcow, so you can target those engines if you are wanting to up your nofollows.
  • I just checked and there is an option to right click and select "uncheck engines with no-follow" but there is no option to to check only nofollow or uncheck all dofollow. I think adding this option will help people who just want dofollow links.
  • If you just want nofollow link engines:
    Check All > Uncheck engines with no-follow links > Toggle

    If you just want dofollow link engines
    Check All > Uncheck engines with no-follow links
  • Recently, GSA has been again creating lots of dofollow links even when I select Check All > Uncheck engines with no-follow links > Toggle. Is there any solution to this?
  • SvenSven

    there is a project option to skip nofollow links. If you click on the label the option will be "skip dofollow links". Maybe that helps as well.

    The engines building dofollow links for you now are propably those doing both (do/nofollow).

Sign In or Register to comment.