Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

New Engine not Logging In after Succesful registration...

So, I wrote this engine to target a very specific set of sites... There are only 30 targets total, that I just import into the project at the register page. It creates a blog on these sites. My problem is that it will register fine and I get emails to my inbox, but it wont verifying registration or move on to the login steps and then to the actual posting... Everything just stays at awaiting verification.

Am I doing something wrong here? Here is the .INI


;---------------------------------------------------------------------------
[setup]
;---------------------------------------------------------------------------
enabled=1
default checked=0

engine type=Blog
description=Tries to create blog entries
dofollow=1
anchor text=1
creates own page=1
uses pages=0


page must have1=Powered By

add keyword to search=0
use blog search=0
extract keywords=0
;extract from email=activate_url
posted domain check=1

[URL]
type=url
allow html=0
must be filled=1

[Anchor_Text]
type=text
allow html=0
must be filled=1
hint=Use the keyword that you would like your page getting ranked for. Also use spin syntax here for more than one anchor text.
alternate data=%spinfile-generic_anchor_text.dat%

[Article_Title]
type=text
allow html=0
must be filled=1
hint=The title for your article.
capitalize words=1

[Article]
type=memo
allow html=1
must be filled=1
hint=The full article comes here.
auto modify=0
html to custom link format=1
custom link format=[%url% %anchor_text%]


[Login]
type=login
must be filled=1
hint=The login for websites that need an account. Use numbers and letters only.
min length=15
static=1

[Password]
type=password
must be filled=1
hint=A password used for websites that need an account. Use numbers and letters only.
static=1

[your_email]
type=email
must be filled=1
static=1


;[activate_url]
;type=extract
;find url=*/register/confirm/*
;static=1
;default=%targethost%/login/

;---------------------------------------------------------------------------
[REGISTER_STEP1]
;---------------------------------------------------------------------------

submit success=Your account has been created successfully
submit failed=Please correct the indicated invalid fields in the form below


verify submission=1
verify interval=10
verify timeout=30
verify by=email
first verify=0
verify on unknown status=1

set unknown variable=%leave%

form id=hubForm
form url=*/register/*

userlogin=%login%
email=%your_email%
email2=%your_email%
password=%password%
password2=%password%
orgtype=%random_option%
org=%random_option%
orgtext=Purdue
name[first]=%spinfile-names.dat%
name[last]=%spinfile-lnames.dat%
imgCatchaTxt=%captcha%
captcha_answer=%captcha%
usageAgreement=1
corigin_usyes=yes
corigin=us
cresident=us
cresident_usyes=yes
sex=female
reason=%random_option%
disabilityno=no
disability=no
hispanicrefused=refused
institution-other=Other
birth-month=%random_option%
birth-year=1983
birth-city=%columnspinfile-address_data.dat-3%
security-question=%random_option%
security-answer=Other

;---------------------------------------------------------------------------
[LOGIN_STEP1]
;---------------------------------------------------------------------------
find link=Login
find url=*login*
alternative url=./login/

submit success=Logout|My Account
submit failed=Username and password do not match or you do not have an account yet

verify on unknown status=1

set unknown variable=%leave%

form url=*login*
form id=login_form

username=%login%
password=%password%
passwd=%password%
remember=yes

;---------------------------------------------------------------------------
[STEP1]
;---------------------------------------------------------------------------
find link=*Blog*
find url=*/blog

just download=1
;---------------------------------------------------------------------------
[STEP2]
;---------------------------------------------------------------------------
find link=*New Entry*
find url=*/blog/new

link type=Article

submit success=Comments on this entry

verify submission=1
verify by=url

formid=hubForm

entry[title]=%article_title%
entrycontent=%article%
entry[state]=1

Answers

  • SvenSven www.GSA-Online.de
    Hmm you removed the nice parts "powered by ...." guess you don't want to share the site. Anyway, how does the email link look like? Maybe thats not seen by the program.
  • @Sven... I just put "powered by" there because I know all the sites work. I suppose it doesn't need to be there at all, since I am just feeding SER manually with these targets...  With only 30 targets, it's not really useful to add to everyone's stock setup anyhow...

    the email looks like this:

    https://www.site.com/register/confirm/288505008

    Initially, I had the "extract from email=activate_url" and this corresponding section: I then used the modify url to go the URL extracted in the login section, but it didnt work...

    ;[activate_url]
    ;type=extract
    ;find url=*/register/confirm/*
    ;static=1
    ;default=%targethost%/login/

    The one thing I noticed is that the URLs are https not http... could it be that SER doesn't recognize https links in the email?

  • SvenSven www.GSA-Online.de
    Than I don't know...https is working that can't be the issue.
Sign In or Register to comment.