Skip to content

Configuration of Xevil on another server

Hello everyone!

I'm trying to set up Xevil on another server to solve ReCatchas v2 and v3, but I can't seem to link it.

I have 2 dedicated servers on AWS with ports open, 80,443 and others that I have been testing.

Server 1, I have GSA SER and GSA contact Form running perfectly.
16GB of Ram

Server 2. Xevil running.
32GB of Ram.

In server 2 I put the ip of the server and I try to access changing the ports, I have disabled Firewall, I have also added rules so that they can connect, but I can't get it.

If someone can help me with the configuration I will be extremely grateful.



  • Didn't know, that it's possible to run Xevil on another server. Notice me please, if problem would be solved
  • rastarrrastarr Thailand
    You will need to use Xevil's webserver running on a port, such as 8000. That port needs to be accessible to the outside world.
    Then configure your GSA SER Captcha service addon to access that server:port
    I used to do that when I was using Xevil
    Thanked by 1finolaina
  • SvenSven
    Also make sure that Xevil runs on Interface or your external IP.
    Thanked by 1finolaina
  • sickseosickseo London,UK
    I've got a few of these set up. All I've done on the xevil server is set the ip:port. The ip value is the same as the server ip. I always use 2captcha as well, but the others should work fine too.

    Press the +hosts to update the hosts file.

    Then on your server 1 you just enter the ip:port value from above into any software where you need captchas solved.
    Thanked by 1finolaina
  • You must allow xevil to use external port in windows group policy settings
    Thanked by 1finolaina
  • Hi guys, sorry for not replying sooner, but I did not receive the emails, first of all, I want to thank you, I hope this will be useful to many people.

    I am sending you a screenshot with the fake IPs but in this format is how I have it set, so you can tell me what I am doing wrong, I put the GSA contact form configuration, and also the server configuration. Maybe you can help me with something I'm doing wrong.

    Thanks and greetings!


    as you can see, I have also added an exception to the firewall, I have tried with multiple ports, an error appears that I don't know how to correct...

    Thanks a lot!!

    @Sven @Jetm @sickseo @rastarr @Erni_bro

  • sickseosickseo London,UK

    In your XEvil folder you will see a file called "XEvil Open Port80". Click on it and run it - it should resolve the current conflict. I believe that's happenning because you have both xevil and gsa captcha breaker using the same port, which isn't possible. 

  • I am trying to solve the registration issue, on the server I only installed Chorme and XEvil, maybe I need another platform other than AWS and try another system.

    I can't get it to work, I don't know what could be wrong.
  • sickseosickseo London,UK
    Just a thought, have you restarted the server since updating the registry?

    Also, try to run the set up with just XEvil and don't run GSA captcha breaker, see if that works as that will eliminate the conflict of 2 software using the same ip:port.

    Also are you running these tools as adminstrator? 

    All my vps and dedi servers are set up with hetzner. But really I see no reason for it not to work on your current machine.
  • Partner! Thank you very much but I can't get it to work, I know you will have a lot of work too. If you sell your services and want to help me with this, I'll pay you hehe. 

    What I have in mind if it doesn't work will be to put it on the same server.

    Thank you very much for everything, really.
  • sickseosickseo London,UK
    I don't mind taking a look at it for you. I just need access to the server, so please send me the login details via PM.
  • iamsrilankaniamsrilankan srilanka
    edited March 2023
    check this video 

    you need to add server ip(that xevil run)  in the host file (in the pc such as gsa or any software running) 

  • Thanks @iamsrilankan

    I have tried that too, but I think there is no way. It is an AWS security problem that I don't know how to solve.

    This weekend I will try with hetzner servers as @sickseo says. 

    Thank you very much for so much help. What a great community.

Sign In or Register to comment.