Skip to content

Indexer not getting links from SER

Normally I run SEO Indexer as administrator, otherwise its web server won't start (I use that for submitting links to it from other apps)

Recently, when SEO Indexer runs as administrator, and it go to SER and 

Options -> Indexing -> TEST

The links don't get over to SEO Indexer. However, if I restart SEO Indexer as regular user, it works. But then the webserver won't start.

How to fix?


  • SvenSven
    try strarting both apps as admin.
  • Still experiencing inconsistencies with getting links sent to SEO Indexer on a second system. Both SER and SEO-Indexer are running as admin.

    GSA SER on "System1" should send links for indexing to GSA SEO Indexer on "System2". Currently RankerX on an a different system (same network) can submit links to SEO Indexer using the emulated API successfully, but SER cannot.

    SEO Indexer is running its webserver on port 80, I can access it from the system SER is running on, and my hosts file is pointing various indexing services all to the IP of the SEO Indexer PC:

    <div>C:\Windows\System32\drivers\etc>ping<br><br>Pinging [] with 32 bytes of data:<br>Reply from bytes=32 time<1ms TTL=128<br>Reply from bytes=32 time<1ms TTL=128</div>

    C:\Windows\System32\drivers\etc>curl -I<br>HTTP/1.1 200 OK<br>Date: Wed, 12 Apr 2023 00:14:04 +0000<br>Server: GSA SEO Indexer<br>Content-length: 33<br>Connection: Close<br>Content-Type: urlencode

    I've tried removing the API key entirely, changing the API key, not requiring an API key, etc - I think GSA SER is contacting Lindexed directly and bypassing the hosts file because there's no indication on the SEO Indexer system that it received a request.

    Any thoughts on how to get this working?

  • SvenSven
    You need to uncheck the option in "captcha" tab called "Bypass host file and use real IP's of captcha services " as this one is also used for the indexing services.
  • SvenSven
    next update will offer an option for captcha OR indexing service
  • Ok, fantastic, thank you sven. Now it's working with the latest update!
Sign In or Register to comment.