Skip to content

Extremely Slow MetaData Collection.

I'm trying to use a rotating backconnect proxy service I use successfully with other seo tools. I use this same proxy service to scrape with scrapebox and other software without any issues. However when I use it with GSA it takes around 20 minutes gather metadata for just one keyword. Which at that point I might as well do the keyword research by hand.

I'm thinking that I must have not put the settings correctly. The rotating proxy is just 1 ip and connects with a different ip every connection. Is there anything special I should do with the setting to configure backconnect proxies?

Are there other options I could omit to make the process go faster. All I really need is the SEO score.

Here are some of my screenshots from the settings:


  • SvenSven
    The program doesn't know that this is a backconnect proxy. It's assuming to wait between search queries same as when using no proxy. What meta data are you scraping? Can you send a screenshot of the options you have chosen to collect?
  • SvenSven
    I will change this behavior on next update. You can define a custom delay in global settings
  • Thank you for looking into this matter for me. I have tried to change some of my options around, and things are a tiny bit faster. But honestly it still takes forever. How long should I expect for 10k keywords to be check? Now it takes around an hour for 25 keywords to be checked.

    My proxies rotate every request to another ip. I only use one 1 proxy ip, and that should work for every request, as every request it will tunnel through a new ip on every request. I think the issue maybe that I am using 1 ip to connect to and the program doesn't want to over use it.

    I have 40 threads with the proxy service and thus can use the one ip with 40 threads without using the same address.

    Does this make sense, its kind of hard for me to explain.

    I connect through one ip:port, but need to use this for 40 threads, as it tunnels out to an unique ip every request.

    Here are my updated settings:

  • SvenSven
    It should not take that long at all. Can you maybe share your proxy in private message to debug this better?
  • Sven said:
    It should not take that long at all. Can you maybe share your proxy in private message to debug this better?

    I have sent you a private message with those details.
  • SvenSven
    latest update will fix it
  • works great thanks!
Sign In or Register to comment.