Skip to content

GSA Captcha Breaker, 2Captcha

Hi 
I'm using GSA CB as my first service and then I have integrated 2Captcha in GSA CB only as a second service for the failed ones. But in the GSA log, it's showing no ReCaptcha V2 solving is configured. 

Then I read somewhere it's better to integrate 2Captcha directly in GSA SER. I tried that but in that 2Captcha is not working properly it's having a massive failure rate like 4 solved and 600 failed.  

So then I switched back to previous settings and now I'm using 2Captcha inside GSA CB. But my ReCaptcha V2 is getting solved but all my credits are getting used. 
 
Someone please help me out with it

@Sven
Tagged:

Comments

  • SvenSven www.GSA-Online.de
    Please add it directly to SER and not in CB, because SER will not even send recaptcha requests to CB as it knows it can not solve it.
    That you see a high failer rate might have to do with CB emulating 2captcha. Make sure you have the webserver turned off in CB.
  • Thanks, @Sven I've done that. 
    And now it's working. 

    One more thing suddenly my CPU usage is shooting up to 90%, 100% just at 100 threads. Earlier I was running at 300 with my CPU usage at 15-20%. 

    I just imported some URLs to my project and the CPU usage is shooting up to 90%, but I've added URLs before also it's happening this time only. 

    Please help me with it and let me know what I can do to lower my CPU usage. 
  • SvenSven www.GSA-Online.de
    Hard to say what that might be sorry. Is that only when importing URLs? How many are there in ->right click->show urls->remaining target urls
  • Okay, there are around 5 lakhs URLs but it's always changing as I continuously keep scraping and adding URLs in GSA to build links for my projects. 

    I restarted my PC but then also sometimes it's shooting up to 100% CPU usage but it's a little better now. 

    One more thing when I was going through the anchor text report on semrush it's showing anchor text as <<Link>> and empty also.

    But I haven't added any anchor text like this in the project. And this is not the case with one project but I'm seeing this almost in every project.      

    @sven can you please tell me why it's happening? 
  • SvenSven www.GSA-Online.de
    I guess << LINK >> stands for a naked link (maybe someone can confirm as I don't use SemRush)?
  • Okay 
    @Sven

    I've just started xevil with GSA my other captchas are getting solved but ReCaptcha is not getting solved

    I'm getting this error in the log. 
    Recaptcha solving failed - Xevil: sorry but captcha could not be solved (too busy)

    I had chosen rucaptcha in Xevil and have added Xevil in GSA. 

    I'm not using any proxy in xevil ReCaptcha settings. Can you tell me how I can configure xevil so it also solves ReCaptcha

    Here are the screenshots of my captcha settings

























    This is the log in xevil's setting

    Mem in MB: 8054
    "BlockIOFunctions" option is DISABLED! If where made changes in Lua - check if they don't have malware code, please.

    11-09-2022 15:53:06: #OK x64
    11-09-2022 15:53:06: #RUN!
    11-09-2022 15:53:06: Lua loaded
    11-09-2022 15:53:06: API: RuCaptcha 127.0.0.1:80
    11-09-2022 15:53:07: API: RuCaptcha 127.0.0.1:443
    11-09-2022 15:53:07: Client connected: 112366032FBBDBCFAC5155E53B1FB072
    11-09-2022 15:53:44: POST /in.php
    11-09-2022 15:53:44: googlekey = 6LeR21wUAAAAAK9N0k2iXhtft65zMe60vGWKoW5R
    11-09-2022 15:53:44: pageurl = http%3A%2F%2Fmagnifiedads.com%2Foc-panel%2Fauth%2Fregister
    11-09-2022 15:53:44: ReCaptcha was rejected: wait for full authorisation of RCModule, please! Open "ReCaptcha" window by click "ReCaptcha" button in top menu.
    11-09-2022 15:53:45: POST /in.php
    11-09-2022 15:53:45: googlekey = 6LeR21wUAAAAAK9N0k2iXhtft65zMe60vGWKoW5R
    11-09-2022 15:53:45: pageurl = http%3A%2F%2Fmagnifiedads.com%2Foc-panel%2Fauth%2Fregister
    11-09-2022 15:53:45: ReCaptcha was rejected: wait for full authorisation of RCModule, please! Open "ReCaptcha" window by click "ReCaptcha" button in top menu.
    11-09-2022 15:53:45: POST /in.php
    11-09-2022 15:53:45: googlekey = 6LeR21wUAAAAAK9N0k2iXhtft65zMe60vGWKoW5R
    11-09-2022 15:53:45: pageurl = http%3A%2F%2Fmagnifiedads.com%2Foc-panel%2Fauth%2Fregister
    11-09-2022 15:53:45: ReCaptcha was rejected: wait for full authorisation of RCModule, please! Open "ReCaptcha" window by click "ReCaptcha" button in top menu.
    11-09-2022 15:53:45: LocalCore start: "C:\Program Files (x86)\Botmaster Labs\XEvil 5\rc5\core64\xevilrcore.exe"
    11-09-2022 15:53:45: POST /in.php
    11-09-2022 15:53:45: GET /res.php?key=081adc2773b0aec9a20fe562d607de52&action=get&id=4
    11-09-2022 15:53:45: id = 4
    11-09-2022 15:53:45: text = zxg4
    11-09-2022 15:53:45: POST /in.php
    11-09-2022 15:53:45: GET /res.php?key=081adc2773b0aec9a20fe562d607de52&action=get&id=5
    11-09-2022 15:53:45: id = 5
    11-09-2022 15:53:45: text = p467be
    11-09-2022 15:53:46: POST /in.php
    11-09-2022 15:53:46: googlekey = 6LcnCgwTAAAAACWhcKKxoINElVUp-DGCTJElqENf
    11-09-2022 15:53:46: pageurl = http%3A%2F%2Fwww.kidzsearch.com%2Fquestions%2Fregister%3Fto%3Darts-%252526-crafts%252Fpictures-and-drawings
    11-09-2022 15:53:46: VisualLog temporarily DISABLED for optimization!






    I hope this helps do let me know if you need any other information from me. 

  • Botmaster have made some network changes since yesterday. You need to patch your existing XEvil installation or install the updated version from their website.
  • Hi @organiccastle

    Yes, I've updated Xevil's recent version, but I'm still getting the same error. Xevil is not able to solve Recaptcha. 
  • Still getting the same error "wait for full authorisation of RCModule"?

    My installation is working fine after I installed the rc5 patch provided yesterday.
  • Thanks @organiccastle

    I've done that and I'm still getting the same error

    Here is the error log

    Mem in MB: 8054
    "BlockIOFunctions" option is DISABLED! If where made changes in Lua - check if they don't have malware code, please.

    12-09-2022 14:46:28: #OK x64
    12-09-2022 14:46:28: #RUN!
    12-09-2022 14:46:28: Lua loaded
    12-09-2022 14:46:28: API: RuCaptcha 127.0.0.1:80
    12-09-2022 14:46:28: API: RuCaptcha 127.0.0.1:443
    12-09-2022 14:46:59: Client connected: 112366032FBBDBCFAC5155E53B1FB072
    12-09-2022 14:47:26: GET /res.php?key=GSA&action=getbalance
    12-09-2022 14:47:26: GET /
    12-09-2022 14:47:33: POST /in.php
    12-09-2022 14:47:33: googlekey = 6Le-wvkSAAAAAPBMRTvw0Q4Muexq9bi0DJwx_mJ-
    12-09-2022 14:47:33: pageurl = http%3A%2F%2Fwww.google.com%2Frecaptcha%2Fapi2%2Fdemo
    12-09-2022 14:47:33: ReCaptcha was rejected: wait for full authorisation of RCModule, please! Open "ReCaptcha" window by click "ReCaptcha" button in top menu.
    12-09-2022 14:47:33: LocalCore start: "C:\Program Files (x86)\Botmaster Labs\XEvil 5\rc5\core64\xevilrcore.exe"


    Are you using Xevil with GSA? 
    Is it working fine with GSA? 

    I'm using it with GSA. 

    Maybe @Svencan you help me, do you have any idea why is it happening? 

    @organiccastle do let me know if there is anything else I can try to solve this error.

    Thanks!


  • Yes, I am using Xevil with GSA SER.

    I realized this error yesterday morning. A Google search brought me to "network error" so I contacted both Botmaster and the proxy provider. GSA SER was working fine through capmonster as backup for Xevil, Xevil proxies were up as well. Botmaster replied to my support request with the link I provided.

    Steps I performed:
    1) Stop Xevil
    2) Apply patch
    3) Reboot VPS
    4) Launch Xrumer
    5) Launch Xevil

    Working perfectly fine again.
    Thanked by 1shreyagarwal
  • Thanks @organiccastle

    Yes, it's working now and solving Recaptcha. 

    Well but I'm getting proxies banned. Can you suggest which proxy to use for Xevil? 

  • Thanks @organiccastle

    Yes, it's working now and solving Recaptcha. 

    Well but I'm getting proxies banned. Can you suggest which proxy to use for Xevil? 

    I'm using reproxy.network. Never had any issue with it.
  • Yes, I am using Xevil with GSA SER.

    I realized this error yesterday morning. A Google search brought me to "network error" so I contacted both Botmaster and the proxy provider. GSA SER was working fine through capmonster as backup for Xevil, Xevil proxies were up as well. Botmaster replied to my support request with the link I provided.

    Steps I performed:
    1) Stop Xevil
    2) Apply patch
    3) Reboot VPS
    4) Launch Xrumer
    5) Launch Xevil

    Working perfectly fine again.
    Thank you so much @organiccastle . For some reason mine is still not working. Says on Xevil's website "Go inside this patch, drag'n'drop "rc5" folder into your XEvil's folder, with full replace" but when I do this, restart my PC then run XEvil, it says I'm missing a file. Probably the "processor" folder which is not included on the new rc5 folder. Any idea? Thank you so much in advance. 
  • Thank you so much @organiccastle . For some reason mine is still not working. Says on Xevil's website "Go inside this patch, drag'n'drop "rc5" folder into your XEvil's folder, with full replace" but when I do this, restart my PC then run XEvil, it says I'm missing a file. Probably the "processor" folder which is not included on the new rc5 folder. Any idea? Thank you so much in advance. 
    Reads like you have deleted the original rc5 folder rather than just copy/replace the new files included in the patch.
  • edited September 15
    I'm getting a very high rate of bad sitekey for captchas in Xevil. 

    Can you tell @sven why is it happening? 

    Do anyone else is also having the same issue?

    I have around 6000+ bad sitekey and 6000 good. 

    But previously it used to be around 800 bad sitekey and 6000-8000 solved. 

    I'm using reproxy is it happening because of proxy? 
  • SvenSven www.GSA-Online.de
    give me a sample URL where this happens.
Sign In or Register to comment.