Skip to content

GSA Website Contact Submitter not saving registration

I had the demo version installed previously. I'm seeing "Demo version expired" on the startup screen. 

I just purchased, downloaded and installed 4.63. Entered Name + copied/pasted serial number. I press OK, then a message appears to "Please restart the program now." I click OK, then OK again to close the app. When I relaunch, it's still asking for the registration.

I've tried 3 times to uninstall/reinstall and the same thing happens.

How can I get this software working?


  • SvenSven
    You need to copy/paste Serial AND Name. It's all case sensitive as written in the mail you got when buying.
  • I DID copy and paste both name and serial. Still same result. I've even uninstalled the app with Revo, so everything should be cleaned out of the Registry, and all file remnants removed.

    I couldn't get it to install in the VPS instance I was running, I had to create a whole new instance. It's working now, but there is definitely a bug in your software, or your security code is too stringent.

    I realize software theft is a thing, but there has to be a better way...
  • SvenSven
    hmm I wish you would not have done this new VPS setup to further debug this thing. Anyway nothing I can do now to find the issue if there ever was one.
  • Thanks for the reply, but I really needed to get the software working. Perhaps you have an error log you can examine?
  • If it helps troubleshoot, I originally installed the software several months ago, and tested it for the short trial. Then I got busy with other projects and forgot about it.

    Perhaps you can create a CLEANER app that will completely eliminate anything that gets installed by your installer, including Windows Registry entries, files, etc. Then you could send that to PAID customers when they have this problem - it appears to be a common thread over the years with your software, as evidenced by the questions in the forum.

    You could assign the CLEANER software to only run on the customer's specific IP address, and make it expire after 24 hours or less to keep it from being shared and abused. You could also have the software gather information from the user's Windows system to report back to you to investigate why it wouldn't run. I suspect it's a combination of Windows firewall or file security and your expiration code in the app.

    Adobe used to have a.similar app that did this for their Creative Suite software that experienced similar issues (and still does occasionally).

    Thanks again for the reply.
  • SvenSven
    Since I know what our software does, I can tell you that there is no harm done to your system and there is no reason why a full version would not register at all. Im sorry, but your claim that our software needs a CLEANER is totally absurd. Though I guess I can not convince you anyway.
    You need any further help getting the software registered, if so, please send an email directly to me as I am not discussing license issues publicly.
  • Thanks for your help. If I have any further issues registering I'll contact you.
  • Hello, I'm Back. I just purchased a new laptop and attempted to install the GSA website contact submitter on the laptop. I installed the software from your website, copied and pasted username and password, and the same thing is happening as before.

    I'll be happy to share a screen capture video with you demonstrating the issue, if that helps. I want to emphasize that I carefully copied and pasted the username and password from the credentials email, made sure there were no extra spaces, etc. 

    I just tried to launch the version of contact submitter software running on my VPS (I haven't launched it for a couple of weeks) AND IT'S DOING THE SAME THING! What do I have to do to get this software running reliably? Do I have to request new credentials every time I install it or launch it?

    How can I get this resolved?
  • SvenSven
    I have replied by email as this is a license issue we better not discuss on a public forum.
This discussion has been closed.