SER stops suddenly

edited September 2012 in Bugs
Am I the only one who experience sudden stops of SER? The interface is working great but it hangs and doesn't continues... (I can see this with the timestamps of the logs). When I click on stop, it stops now really nice. What could be the problem for this? What information can I provide to fix this? I've had this error since the last few updates. Is it possible that it has something to do with CS?

I've only two projects running on 50 private proxies and if I stop and start it again it works again without any problems till the next unexpected stop.
Tagged:
«1

Comments

  • Is there anything specific triggering the hanging and how often does it happen?

    I'd suggest creating a minimal project that reproduces the problem and send it to Sven; providing he can create the same setup as you.
  • You ask the right questions, but I don't see any clear dependcy to a specific situation. This happens now really often - before the alst updates I didn't have this problem. When my latest site list is identified I'll try to reduce the thread count and try to use it without CS to see if it happens again. When this doesn't work, then I think only Sven can help me.

    I just wanted to ask if anybody else has this problems too.
  • SvenSven www.GSA-Online.de
    Usually this happens if your memory usage by your projects is to high. Though in the latest version the memory usage has been lower than in any previous version. I can't think of why this happens on your end really. Especially as you say it worked before.
  • This is happening to me too - the same projects always stop but still say active. Could it be anything to do with running out of keywords?
  • this is happening to me too..from the morning iam running the gsa..after the update,it the SER is very low

    here is my today status

    image


  • edited September 2012
    RAM couldn't be the problem at my side, I've got 16 GB and only 2.1 GB is used. And yes, projects stay active...

    @hungrym: I don't think so, I'm using 170k.
  • SvenSven www.GSA-Online.de
    2.1GB is the maximum RAM a 32bit program can use. So you are facing this situation.
  • edited September 2012
    Perhaps I wasn't clear enough. The total usage of the system is 2.1 GB. But I think this could be the problem. In the past threading was only used for specific stuff on a larger thread count. This took as it looks not as much memory like the "normal" threading like now. I've reduced to 200 and atm it's stable. I think this is the problem. Memory usage for SER is about 600 MB.

    But as you read you improoved memory usage and threading again @Sven?
  • Hmmmm it can't be the fault, I've got now the problem again (with 600MB Ram usage and 200 thread count).
  • SvenSven www.GSA-Online.de
    found something that might cause this. How many search engines do you use?
  • Aha! I'm only using 1 on the projects which are stopping. Google.com I think.
  • SvenSven www.GSA-Online.de
    Yes thats the problem. New update is online in a minute. Let me know if thats fixing things.
  • Great - thanks Sven.
  • I'm using 66 SE's. I've updated now to the latest version (thanks for the fast correction) and let you know how well it performs.
  • Looking good so far
  • @Sven: Has it something to do about the "[Count] search threads are started"? Should we increase the delay between search requests because of the high thread count to prevent blocking?

    Till now the error didn't came back.
  • SvenSven www.GSA-Online.de
    If you use a lot search engines from different companies (e.g. bing, google, aol...) you get a lot better results now as the program can do queries at the same time to all. Though it will keep track of the tiem between two search queries to not get blocked. So nothing has changed on the blocking-risk part, it just got faster ;)
  • Thanks for clarification. I'm sorry but I've to tell you that the problem occured again at my side. It worked for 2-3 hours but in the last 20 min it stucked again and doesn't continue.. To find the problem: What did you changesince the last version, where do you saw the possible problem with SE?
  • SvenSven www.GSA-Online.de
    What in detail do you mean with "it stucked"? Is the project really stopping or you just think it does nothing?
  • For example now I see the last timestamp at 21:28 (it's now 00:28). Both projects have the status "active" and I've reduced the thread count to 200.
  • I came on the forums to report the exact same thing, suddenly after recent updates (not sure which one) GSA stops randomly and doesn't do anything.   I'll let it sit for hours and nothing happens, as soon as I click the stop button or make a thread inactive suddenly you can see it finish what it was doing, then I can restart it and it'll work fine for awhile and then does the exact same thing, it'll just randomly start and I have to stop /restart to get it to do anything again. 
  • I've been using this since 2.10 I believe and have never had this problem before by the way, only after recent updates this has started to happen. 
  • I have screenshots of this now, I hope this helps (Not sure if I know how to post them in this forum though)

    http://www.gameassembly.com/gsa1.jpg

    The first screenshot shows you what happens, after 30 minutes GSA hasn't posted, searched, verified or anything it's hung up on something.

    When i hit the stop button on GSA suddenly all this pops up in the status box, this just started happening after recent updates:

    http://www.gameassembly.com/gsa2.jpg

    If i hit start after I stop it'll run for another couple of minutes and then will do the same thing.


  • Yes, I experinences the same bug myself, but only at 1 of my installations. I uninstalled the programs installed again, and this "stuck" behavior happpened again. Waiting for a soluton.

    Strange thing is that other installations are running smoothly.
  • edited September 2012
    Please recheck if the bug really only occurs on one installation or if it takes more time. After the last update it worked a few hours without problems, but then it happend a lot more often. It's exact that what you've described.
  • SvenSven www.GSA-Online.de
    Accepted Answer
    found the problem :) Its the competitor analysis. Please turnt hat off till next update (might take some more hours as I am optimizing the search engines again).
  • Thanks for this possible solution Sven. I've turned it off and let it run again without it. Will reply if it works now.
  • I can confirm that doing what Sven said and taking of competitor analysis has fixed the problem for me, it seems to be running faster but only have had it going for about 30 minutes like this. 
  • Same at my side. It's running faster than ever before and it looks stable till now.
  • SvenSven www.GSA-Online.de
    the new version is out that is fixing this. I will still work to improve things further now (was not finished but felt this bug should get fixed asap).
Sign In or Register to comment.