Skip to content


The GSA SER began to use 3 GB of RAM, and give an error how to make it use only 700 MB of RAM, a tick in the global settings does not help with this.


  • SvenSven
    well, hard to say what uses much memory, what is the memory usage after a clean restart of SER, without starting any projects?
  • about 500 mb, the question can be configured that it automatically regulates itself and does not consume more than 1 gigabyte of memory?
  • SvenSven
    well something eats up alot memory even on startup. Maybe your proxy search has a lot of proxies listed, projects are that big or other things. You need to find out what exactly eats up that much memory first.
  • how to find the reason? and how to reduce memory consumption automatically so that the GSA itself does it?
  • SvenSven
    you need to check the given points (proxy setup, project size...). I can do little without being remotely on your pc.
  • I send screenshots of settings, and statistics at the moment
  • SvenSven
    It seems to be the proxy setup. You have many many dead proxies in that list. Try to delete them and see if that fixes things.
  • SvenSven
    you also use the option to test all proxies again and again (good and bad)...thats not a good idea. If a found proxy is dead on first test, you should leave it alone and not test again later on.
  • how to remove dead proxies?
    how to make it so that problematic, dead proxies are no longer tested?
  • this issue came from a previous update which was about 2 days ago
  • make an update, it became impossible to work, it reaches 2 GB of operative memory, everything was fine before your update, I have not changed anything for 2 weeks.
  • SvenSven
    start the previous version then from start menu and im sure it will still show the amount of memory used than the new version.
    Beside that fact, it shows that your proxy setup is all wrong. You should fix that no matter if it was a bug in recent update or not.
  • how to set up a proxy correctly? Why does the checkbox for automatically decreasing threads when the specified threshold of RAM is exceeded does not work?
  • SvenSven
    Again, delete all the proxies being down, change settings of testing and see if that makes a change. Also that option surly works, if you start the project, you will most likely see threads being on 1 other than 99.
  • give a link or write how to remove broken proxies? but the checkbox "RAM" "for automatic ..." still doesn't work
  • SvenSven
    Well how hard can that be? Click Delete button on the proxy configuration screen and choose the entry for "Unchecked/Not Working".
  • give a screen, and do not humiliate me that I do not understand something, this is your program, you should know it perfectly and not me, especially since it is paid, it is not very beautiful from your side. Be kind to people, and don't try to be smart, underestimate the mental abilities of other people. And fix your bug. Good luck.
  • SvenSven
    Ohhh now the tone is getting more rough...I was expecting that though.
    However, I don't swallow that's not like we have no tutorials or that I gave no instructions. And I really don't have to sit here explaining simple things that you could have figured out easily yourself. Everyone seems to get along nowadays only with a video or screenshots. Whats wrong with good old reading and following that.

    Anyway, just for you the super easy instructions below:

  • Sven, you are great
Sign In or Register to comment.