Empty Reply when Fetching Content From Google

Hello,

I am just trying to get started with GSA Content Creator (GSA in general really).  And I ran into a problem trying to get it to scrape content from Google.

I've enabled only the Google article content source (Not the link source or image source or anything.)

Disabled anything else that might be deemed as 'extra'.  No spinning, no inserting of links or images or videos or anything.  I even set the project to just grab the entire article.  So no messing with it.

I've added and tested 50 proxies which all check out ok.

But when I Run+Scrape for the test campaign to just see if I can get content from Google or not I get this error:

[14:49:36] Search returned: empty reply (107.172.170.119:12345)

When I edit the Google content source, I see that the URL it should be trying to scrape from is set to:

http://www.google.com/search?q=%search%&tbs=lr:lang_1en&lr=lang_en&hl=en

Does anyone have an idea of what might be happening to me here?

Comments

  • SvenSven www.GSA-Online.de
    Accepted Answer
    that proxy might be the issue.
  • lorddevilorddevi My Desk
    I disabled the proxies entirely and it did start to attempt to scrape!  So that was it.  I am using proxies from buyproxies.org.  What proxies should I buy to work with GSA if buyproxies's proxies don't work?

    They DID test fine inside of GSA's proxy checker though.
  • lorddevilorddevi My Desk
    Yeah now I have a blocked IP.  So the proxies are definitely needed.  But they don't seem to function inside GSA Content Generator.
  • SvenSven www.GSA-Online.de
    Accepted Answer
    Indeed, even with private proxies you often have blocked proxies by google. Try to exchange them on your proxy provider.
  • lorddevilorddevi My Desk
    oh thank you very much Sven!  I shall give that a try, makes total sense.
Sign In or Register to comment.