GSA SER and Capmonster

edited October 2019 in Need Help
Hi

I am trying to figure out the best settings for GSA SER and Capmonster for solving Recaptcha. I am using Capmonster to emulate Rucaptcha, I've added RuCaptcha with IP and made all the proper settings.

Now, when I test the Recaptcha (from google api) I get "Server seems down", even though CapMonster receives the captcha and obtains the token.

On Captcha Stats in GSA SER, all threads are unsuccessful. I guess Capmonster doesn't return the sitekey to GSA?

What can I do?
Tagged:

Comments

  • SvenSven www.GSA-Online.de
    you can add it directly with CapMonster ... no need to emulate it.
  • I am trying to use the HttpRequest method, which is faster and seems to work better with proxies. So, I have to emulate a service.
    I still don't understand why GSA says "Server seems down".
  • SvenSven www.GSA-Online.de
    HttpRequest = ?
  • It's an additional method for solving recaptcha faster (and in my case, it works better than the Chrome or Firefox methods). Unfortunately, I can't give you more info.

    However, it's strange that GSA sends the test recaptcha to Capmonster (running as a service), Capmonster process it, but in the meantime GSA send backs "Server seems down". Do you have any idea why this happens?
  • SvenSven www.GSA-Online.de
    could be a timeout?
  • edited October 2019
    Most likely, but they are running on the same machine, the setup is correct on both and Capmonster receives the test Recaptcha. Somewhere in the process of solving, GSA returns "Server seems down".

    Should I change some values on GSA? If "yes", where?
  • SvenSven www.GSA-Online.de
    not in GSA itself, but the ini file of the captcha service you use...there you have timeout values ... change them to something higher and restart SER.
  • edited October 2019
    there are so many .ini files... can you please tell me the name or where I can find it?
    I do not have a captcha_services subfolder under Programs>GSA Ser

    Only Engines and Email_Engines

  • SvenSven www.GSA-Online.de
    Accepted Answer
    captcha_services folder is correct, but it's located in...
    c:\users\<login>\appdata\roaming\gsa search engine ranker
  • I've played around with some values, but no matter what I put there (2captcha API with IP - recognized as Capmonster):

    [recaptcha_solve loop]
    url=
    encoding=urlencode
    delay=999
    timeout=9999

    GSA says, after exactly one minute, "Server seems down", while Capmonster is actively solving recaptchas.

    Did I modify the right values? Are they in seconds, milliseconds?

  • SvenSven www.GSA-Online.de
    hard to say really. Can you maybe provide access to that server?
  • I will gladly give you access. I've sent you a PM.
  • Hi there!

    I test CapMonster in GSA SER and get "missing data for next-url (error)".
    What does it mean? 
    Firstly, it was written "empty answer" (or smth like this), but after changing some settings in GSA and CapMonster it shows "missing data for next-url (error)" mssg.

    Do you any tutorial how to correctly instal CapMonster on GSA?
    Cause I think I do smth wrong..

    Thanks!
  • SvenSven www.GSA-Online.de
    empty reply is usually a timeout
    no next url error is usually an timeout as above or some error message I didn't cover in the captcha-service-script.
  • Ok, thanks

    Don't you have a manual on how to connect CapMonster with GSA SER?
  • edited December 2019
    I used to get this message. Be sure to setup your proxies the right way.

    I only have 5 threads, usually solving 2-3-4 Recaptchas at the same time. For this, you'll need 30-50 quality proxies. Maybe semi-dedicated or dedicated proxies. No public proxies.

    In Capmonster, if you have proxies with username/password, don't use them in this way.

    Strip to only proxy:port and authenticate by IP. It was the only way I could use Capmonster with internal proxies - it works best this way. Set it to ignore proxies coming from external programs (like GSA).

    Don't emulate any services in Capmonster. Use it as it is. Remember to enter the correct ip:port in GSA when you configure it.

    Also, use Capmonster with the default settings - it is better this way.

    My solving ratio is around 90% or even higher if the Recaptcha is updated on the site, otherwise you'll get timeouts (Bad Ip). It's not you, it's the site you're trying to post to - it did not update the Recaptcha code.

    Overall success is around 70% with a mix of good/bad sites.

    I used to run in on a VPN, but try not to, it will give you a lot of errors from both GSA and Capmonster.

  • Also, be sure to balance GSA threads with Capmonster threads.
    Set GSA to 10 threads maximum if you have only 5 Capmonster threads. It is slower but much safer.
  • Thanks so much for your answer!

    Actually, I did just as same as you told me and it starts to work, but my capmonster doesn't want to resolve ReCaptcha..
  • did you purchase the addon? Recaptcha sitekey addon, it is $10/month

Sign In or Register to comment.