Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

No engines matches when importing accounts

andrzejekandrzejek Polska
edited July 2019 in Bugs
Importing accounts to this engine shows "no engine matches" for all urls.

[setup]
enabled=1
default checked=0
engine type=Article
description=
dofollow=1
anchor text=1
creates own page=1
uses pages=0
multiple posts per account=1


;;; API MAIN VARIABLES
[api_url]
type=extract
static=1

[api_link_id]
type=extract
front="link_id":
back=}
static=1

[api_target_url]
type=extract
default=%targethost%
static=1

;;; API REQUIRED VARIABLES
[api_engine_name]
type=extract
default=test
static=1

;;; NORMAL VARIABLES
[URL]
type=url

[Anchor_Text]
type=text
alternate data=%spinfile-generic_anchor_text.dat%


[Article]
type=memo
allow html=1
must be filled=1
hint=The full article comes here.
auto modify=0
auto add anchor url=2
auto add anchor url content=%file-auto_anchor-article.dat%
custom mode=1

[Login]
type=login
must be filled=1
hint=The login for websites that need an account. Use numbers and letters only.
min length=10
upcase=0
static=1

[Password]
type=password
must be filled=1
hint=A password used for websites that need an account. Use numbers and letters only.
static=1

[Your E-Mail]
type=email
static=1

-----
[STEP1]
link type=Article
just download=1

submit success="success":true
submit failed="success":false
submit failed retry=XXXXXXXXXXXXXXXXXXXXXXXX
captcha failed=XXXXXXXXXXXXXXXXXXXXXXXX

verify submission=1
verify by=url
verify url=%api_url%/api/link/verify_redirect/%api_link_id%
verify interval=10
verify timeout=99999999999999999999
first verify=5
verify on unknown status=0

[STEP2]
modify url=%api_target_url%
just download=1

[STEP3]
modify url=%api_url%/api/link/create/%api_engine_name%
post data=engine_name=%api_engine_name%&target_url=%api_target_url%&url=%url%
form request with=XMLHttpRequest
encode post data=3
just download=1

Best Answer

  • SvenSven www.GSA-Online.de
    Accepted Answer
    yes, without login steps its a none account-requiring engine for SER.

Answers

  • adding url must have=* fixes it

    but while posting (not importing accounts) engine matches normally.
  • andrzejekandrzejek Polska
    edited July 2019
    strange behaviour but theres workaround
  • I guess no login steps may cause the issue.
Sign In or Register to comment.