Skip to content

No translation languages work besides DE

edited July 2019 in Bugs
Hey @sven,

I'm not sure if I'm going crazy or what, but no other translation macro languages work besides DE.

</code>#trans_en_de Your privacy is important to us. #notrans

Ihre Privatsphäre ist uns wichtig.
</pre><pre class="CodeBlock">#trans_en_nl Your privacy is important to us. #notrans

Your privacy is important to us.
</pre><pre class="CodeBlock"><code>#trans_en_es Your privacy is important to us. #notrans

Your privacy is important to us.
#trans_en_pl Your privacy is important to us. #notrans

Your privacy is important to us.

I have tested 10+ languages, all fail except German. Is this a bug or am I doing something wrong here? I also tried without the "en" in the middle, they still all fail.

Please confirm you can re-create this bug.



  • SvenSven
    its a bug :( I fixed it for next update.
  • edited July 2019
    Thanks @sven for the fix, there is still one small bug, the characters...

    "200b200b" appear in several articles when translating.

    I can't find any correlation for words that causes it to happen.

    I haven't seen any other weird characters besides this one. Different words output the character in different languages, in PL, I was translating a privacy policy and this section caused it.

    Use this code to see the bug:

    #trans_en_pl Transfer the materials to another person or 'mirror' the materials on any other server. #notrans
    Przenieś materiały do <b>200b200b</b>innej osoby lub „lustrzanie” materiałów na dowolnym innym serwerze.

    In NL, translating the same privacy policy, it appeared in this section:

    #trans_en_nl Because some jurisdictions do not allow limitations on implied warranties, or limitations of liability for consequential or incidental damages, these limitations may not apply to you. #notrans
    Omdat sommige rechtsgebieden geen beperkingen toestaan <b>200b200b</b>op impliciete garanties of beperkingen van aansprakelijkheid voor gevolgschade of incidentele schade, zijn deze beperkingen mogelijk niet op u van toepassing.

  • SvenSven
    fixed in next update.
  • edited July 2019
    Another pretty large bug with translation, @sven...

    Anything you translate after a "!" will not translate. It doesn't even get sent for translation.

    #trans_en_pl Hello! I hope you have a great day. #notrans
    #trans_en_hr Yeah! We're going to see a movie #notrans

    I just got done with several hours of translation... now I have no idea what parts of my content weren't translated -_-;

    It may not even only be after "!". It seems on some translations, random "last sentences" of a paragraph are removed. But the same bug can be triggered 100% of the time by using a short word as a sentence.

    Also, not even sentence after "!" is removed, but again it triggers every time when using a short sentence with a "!".


    Another bug I caught while doing some translations is that anytime there as a character such as:


    SER will not translate any sentence that includes those symbols. Not too big of a deal as I removed them from my content before translating, but, just letting you know.
  • SvenSven
    arg ok, will debug on this tomorrow...still weekend and Im not in office to check closely.
  • Thanks, note... correction above. this should read:

    Also, not *every* sentence after "!" is removed, but again it triggers every time when using a “short sentence” with a "!" at the beginning of a paragraph.
  • SvenSven
    I hope I now found and fixed all issues. Im sorry for this but there structure seems to change and it's hard to parse this without a docu.
  • edited July 2019
    Everything seems to be working better now @sven, but there is this last really, really awkward bug.

    If you translate a single word, the translation often makes mega long, and adds "noun" or "verb" to it.

    Take this for example:

    #trans_en_sk Summary #notrans
    zhrnutiepodstatné menovýťahzhrnutieresuméprídavné menokrátkyskrátenýstručnýprehľadnýokamžitýchvatnýrýchlysúčtovýsúhrnnýzhrňujúcihromadný
    Read that 'meaning'... what in the world is happening there? Some adult words, really awkward.

    #trans_en_fi Summary #notrans
    Not even a real word, but what it actually is, is the word "Yhteenveto" with extra crap attached to it...

    Peliautomaatit," but again it adds a million characters on the end.#trans_en_fi Slot machines #notrans
    The proper output is "

    Note: This only happens when translating single words, it doesn't seem to happen in sentences. It also doesn't happen if I use the translate manually or the API. Only translating through SER.

    Note #2: The reason I'm using SER for this specific set of translations, is because of the brilliant way you've implemented the #trans #notrans macros. I'm actually translating entire pieces of content while inside a PHP file (replacing < and > with &lt; and &gt; so the outputs are proper)... saving me many, many hours.

    Update: The sporadic behavior / adding adult words etc is only happening in 13.79. The issue with adding "adjective" "noun" on the end of single words still occurs in 13.78, but the wild behavior with adding adult words doesn't.

    Here are the outputs from 13.78.

    #trans_en_sk Summary #notrans
    zhrnutieprídavné meno
    summary adjective
    Notice how it's still adding "summary adjective". It adds what type of word it is on the end.
    But it doesn't add all of the crazy adult language.<b>v13.78</b>

    #trans_en_fi Summary #notrans
    Summary Adjective
    Still incorrect, but not as long as the one above. The reason it's incorrect is because
    it's adding "adjective" on the end of the words.
    The proper translation is "Yhteenveto". SER outputs "Yhteenveto" + "adjektiivi". Again, still
    not as bad as it is in 13.79.<b>v13.78

    Correct translation in 13.78.<b>v13.78</b>
    #trans_en_fi Slot machines #notrans

    Any idea what would be causing this extremely weird issue?

    I sent a donation your way, hopefully it will pay for a little bit of time debugging this.

    Thanks again man.

  • SvenSven
    thanks for the new findings and donation...I will try to figure out what this might be and update.
  • SvenSven
    should be fixed in latest update
  • edited July 2019
    @sven Sometimes SER is only translating the first sentence of a paragraph on many outputs... Restart SER so the cache clears sometimes helps, but even so, I'm seeing this bug with 100% g-translate passed proxies.

    Edit: This also happens in 13.79. Let me see if it's something in my article causing it... I've only seen it when using #trans_en_no and #trans_en_pt.

    Odd, the issue can only be replicated on Norwegian and Portuguese translations. Could possibly be more, but I tested some and they all worked.

    #trans_en_no There are many different ways of playing. Let's take a look at these two examples: #notrans
    Det er mange forskjellige måter å spille på.
    #trans_en_pt There are many different ways of playing. Let's take a look at these two examples: #notrans
    Existem muitas maneiras de jogar.

    Seems to be something weird with Norwegian and Portuguese only... at least far as I can tell.

    I can use a ghetto technique of putting #notrans #trans_en_no after every sentence, but otherwise, in most cases only 1 sentence gets translated.

    One correlation I've found is that it happens on longer sentences, but only on NO/PT. On other languages, the full sentence is translated, so I know it's nothing to do with the sentence length.
  • edited July 2019
    Very odd, it cuts off sentences half way through, only on NO/PT.

    It seems to be related to sentence length. However, the length is not an issue in the other languages, as I can take the exact same sentence, switch the language, and it translates properly.

    Testing some things now. Seems random, from what I can tell, definitely something to do with sentence length, but the exact same sentences translate properly in other languages with the same proxies.

    I've tested many different hypothesis here.

    1) Sentence length. NO/PT cut off after exactly 264 (English) characters. NO/PT also only translates the first sentence in many outputs.
    Status: failed.
    Other languages can handle sentences well over this length without a problem. Other languages also always translate all sentences.

    2) Output length. NO/PT cut off the output after X characters, or only translate 1 sentence.
    Status: failed.
    Other languages output paragraphs / sentences that are much longer without any issue.

    3) Special character or something.
    Status: failed.
    Scanned for every special character. None are present.

    4) Proxies.
    Status: failed?
    Tried with only a few proxies checked, and proxies completely disabled. Same result. However being that I occasionally get a proper output, it could be related. Still doesn't explain why the issue only occurs on NO/PT.

    5) Google messing with me?
    Status: Not sure?
    It would seem that if other languages translate 100% properly, that it isn't related to G. Although, it's impossible to prove it either way.

    6) Cache
    Status: ... Half-Passed?
    Removing cache from Chrome and clearing using CCleaner resulted in a proper output in both NO and PT. However, it seems random. Doing the same thing again resulted in wrong outputs. It seems random, but it only occurs on NO/PT. No other languages from what I can tell.
  • Sorry to bug you about this man, I know many people probably don't use it. I'm almost finished with my translations, then will only be using it for links instead of translating content.

    But, other than this issue with NO/PT... everything else is working perfectly. Someone who competes in these markets wouldn't eventually notice their link-article sentences were being cut off and not translating.

    If you can just figure out this last issue, everything will be working fantastically.
  • SvenSven
    I have now rewritten the whole engine and it now should cover everything, let me know if it suits you after the next update.
  • edited July 2019
    Wow, @sven not only did you fix it with this re-write, but it translates content much faster than before. I will watch for any bugs but I'm pretty sure you've fixed it completely.

    Jeez... testing more now, it's literally 10x faster now, excellent work Sven thank you so much as always.

    Sending another donation your way.
  • SvenSven
    thanks for the donation, glad it finally works as expected :)
Sign In or Register to comment.