Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Xevil Not working since last update

anniemicanniemic Arizona
edited October 2018 in GSA Website Contact
Since the last update 2.18 XEvil will not work with the soft...anyone else having this problem?

GSA performed a captcha update. For 2captcha emulation, choosing the settings on xevil as the default IP. I go to setting on gsa and add the captcha service. I choose the last one 2captcha API with IP and up the Xevil IP as the "ho=st"/. 

Something has changed since the update. I was told 2captcha API was not changed from the end of 2017.
Also told: "I need to use something else other than because thats the port that CB is running on? so I should change the CB's port or the one on XEvil.

 Xevil told me to change the port which I did, and still did not work.

The end result of all this trying different things amounts to the same outcome when I go to Test the captcha is working: "Empty Reply".

GSA says: it seems xevil doesnt know what to do with the API calls that he is sending. The same setup is working for other people he says, so he thinks the issue is with XEvil ? The balance test worked for him, but the real solving does not.. He thinks Xevil is not understanding the data thats being sent to it and how to deal with the data to reply? Maybe it is expecting in the http header?

I have tried antigate emulation and still the same "empty reply"

Best Answers

  • looplineloopline
    Accepted Answer
    I think I answered you on a different forum.  I sent some debugger stuff to GSA as the same happens to me, although my setup is different.  I can't even get gsa captcha breaker to solve captchas from the v2.18 update of website contact.  That worked fine before and xevil also works fine. 

    I rolled back to my prior version, which happens to be 2.16 and both xevil and captcha breaker are working fine.  So Im not sure what I don't understand about how the new update works, but I cant get website contact to work with captcah breaker or xevil. 
  • SvenSven
    Accepted Answer
    1. 2captcha,.com is simulated by GSA Captcha Breaker and you need to turn that off in it's settings. OR you can as well disable the webserver option completely. If you still need the webserver option, then please change the port Xevil runs on to something else then 80.

    2. In GSA Website Contact you delete as service and add " API with IP" where you are able to input the ip:port just as you did in xevil.
  • edited October 2018 Accepted Answer
    I have Xevil, but when GSA PR Emulator runs it works not, is there a way to made it run with Captcha Breaker and PR Emulator. ? Which port is to configure, any advise?

    I am desperately looking for a way that these tools could work together,i would pay for it @sven. That would be a big leap if GSA worked in this combination of tools.

  • SvenSven
    Accepted Answer
    pr emulator needs port 80
    captcha breaker doesn't need to run at all on a webserver
    change port of xevil to anything other than port 80 (e.g. 81)+ use a captcha service in SER with IP (e.g. 2captcha API with IP". There you can also use e.g.
  • edited October 2018 Accepted Answer
    I dont use captcha breaker as webserver, i add in captcha breaker an new service 2captcha. In the API window i paste any number combination. In Xevil i configure like that, select 2captcha and paste under port and click +host for host file. But my Xevil is not run, in the window its say right connected? All is running on Windows Server 2012

  • Accepted Answer
    update: Xevil works again on decaptcha Api with IP
  • matzedoonmatzedoon germany
    Accepted Answer
    don't use those, better stick with RuCaptcha. I don't know why but im using another tool to create scripts and someone on the forum explained why some fail and why rucaptcha will always work with ports and localhost.. i forgot why exactly, but stick with rucaptcha and you will never have this issue again with new updates.
  • Accepted Answer
    For me, unfortunately, it is not with the rucaptcha I tried, no API KEY with IP window. Only with host file configuration in Xevil it never ran, and rucaptcha.

  • SvenSven
    edited October 2018 Accepted Answer
    rucaptcha is the same as 2captcha but with a different host/ can as well use "2captcha api with ip".
  • Accepted Answer
    2captcha api with ip i did not find that unfortunately not under captcha in GSA, did I overlook that?
  • SvenSven
    Accepted Answer
    Ahh yes of course sorry, that is still using the old captcha-system which will be updated soon as well. SER should work fine then, just make sure you are not emulating that service within Captcha fact you need to make sure not to have captcha breaker use the webserver here or at least run it on a fixed port other than 80.
  • Accepted Answer
    Captcha Breaker does not run as a webserver, I did it in SER under captchas add service. Yes, and there is still the old entry only 2captcha, but without api and ip as an option selectable. Thanks for the next update that makes this option synonymous in GSA Ser selectable.

  • SvenSven
    Accepted Answer
    But then it should work fine right now anyway if you emulate 2captcha with xevil + have no webserver option enabled in CB.
  • Accepted Answer
    Unfortunately, the Xevil stops every few thousand captcha, then stops. It only helps a manual restart of the program. Maybe the other integration with 2catchas API will work better with IP. I look forward to a soon update in GSA SER.

  • SvenSven
    Accepted Answer
    I don't think it's a problem in our tools if they still work but xevil not!? You better redirect that to the developer of xevil.
  • Accepted Answer
    Maybe, I always get these messages after a few thousand captcha
    12:54:58: [-] 854/889 DeCaptcha API with IP ERROR: undefined error message (probably down)

  • SvenSven
    Accepted Answer
    decaptcha is not offering any recaptcha solving, using that with xevil is not a good idea.
  • edited October 2018 Accepted Answer
    I would also change on your advice with 2captcha API with IP, but currently I do not have the option in GSA SER under Options / Captcha / Add Service to select there is only the 2catcha in it and not the version with API and IP.

    If there is no recaptcha service at decaptcha this probably explains why the xevil stops.

  • SvenSven
    Accepted Answer
    right now you can only use normal 2captcha with ser. when not emulating it in cb and running xevil on port 80 and clicking in xevil to modify the host file after cb is reasy, it should work fine. make sure cb does not erun the webservef or at lest runs on a fixed port other than 80.


  • I tried this with 2captcha, it does not work at all, maybe because the PR emulator is running too, I need it for SEORank. I always get the message Error unable to get balance. In Xevil, I entered and pressed + host.

    As a password, I entered a number combination into the field 2captcha KEY in GSA SER. CB does not run as a web server. Configuration GSA SER - PR Emulator -Captcha Breaker + Xevil.

  • SvenSven
    ok with pr emulator it will not work. in that case try to use antigate api with ip which lets you set ip and port. xevil should support antigate aswell.
  • Unfortunately I seem unlucky, thanks for the hint. Last night I switched to antigate immediately. Unfortunately with the fact that the Xevil stops again after a few thousand. I have meanwhile written in the botmaster forum. Other users have the same problem it should be an error API key the service. A user has recommended ricaptcha it runs at it without stopping. Problem is but ricaptcha has no IP window what I need in my configuration, since the PR emulator must continue to run.

    Too bad that it is not as easy as the import of captcha sniper in the captcha breaker.
  • SvenSven
    i had a quick look on the xevil scripts to emulate the services....all 3 mentioned services (2captch ripcaptcha and angigste) share the same it is equal which of thec3 you choose...all will give the same problem. though still a xevil issue afterall if you ask me.
  • royalmiceroyalmice WEBSITE: ---> | SKYPE:---> asiavirtualsolutions
    edited November 2018
    Emulate RuCaptcha  -- it is the Russian version of 2captcha

    When you set Rucaptcha in Xevil - you can sent both 2captcha and rucaptcha and it will be able to work with both


    Alternatively if you dont want to emulate via host file then use Anticate Old API with IP   -- add anything as key and ip is ip where u run xevil  should be ip:80
  • edited November 2018
    @royalmice i use antigate old API with ip and works fine with Xevil Standard captcha, I have now installed the beta version 4.0.0, unfortunately the window of the ReCaptcha2 remains empty. If you use Xrumer it works, only with GSA are no Recaptcha v2? Do you have any idea what goes wrong, and what proxies are good for the ReCaptcha2?

  • iwebseoiwebseo The Internets
    @puntoGT do you use proxies with XEvil?
  • yes i use proxies when i start it with xrumer all goas normal, Recaptchas shows up in the modul window
  • I tested new, works on 2captcha solve RecaptchaV2 but not on antigate new with ip?
  • royalmiceroyalmice WEBSITE: ---> | SKYPE:---> asiavirtualsolutions

    Sorry for the delayed response.

    In GSA ser  -- set to use Antigate old with api ---- make sure you set the ip port of where your Exevil is running like : (use your ip )

    You can also use RUCaptcha in GSA SER but then you need to ensure to add the host file like further below on both gsa machine and xevil machine. If xevil and gsa is on the same machine then just use the hostfile as below.

    In Xevil select RU Captcha, and make sure to update the ip to your vps ip, same as what u set in GSA SER  (this should be the actual ip of your VPS)
    The easiest is to just select RUCaptcha  then add the ip+port and then click +host button

    RU Captcha in GSA can solve both antigate and ru captcha, so i manually edit the host file like below - 

    # ~~~ "XEvil.exe" block start ~~~

    # ~~~ "XEvil.exe" block end ~~~ 

    please replace   with your ip

    If you have have exvil and gsa ser on the same machine then you can use the localhost ip instead of the external ip

  • I have tried the setup you describe above but I am still having issues.  When I use ANTIgate with old API and set my IP there, GSA keeps giving me errors saying "no recaptcha v2 solution".  If i set rucaptcha in GSA then it stops saying no recaptcha v2 solution" but then it is only solving a fraction of the recaptcha's in xevil, it keeps skipping recaptcha v2's from tumblr and a few other sites.  Any idea why its doing this?
Sign In or Register to comment.