Skip to content

What does GSA-SER actually mean when it tells me that my private proxies no longer work?

DeeeeeeeeDeeeeeeee the Americas
edited September 2017 in Need Help
Hey, ppl...

I thought that the proxies that were public were placed in the bad list during testing because they either were no longer in place and had been removed, leaked the user's IP, or were otherwise broken in some way, and the SOCK5 or other protocol was not showing an "acknowedge" connection.

My private proxies are now all on the Unckecked/Not Working list in the GSA-SER Proxy module!!! =(

How do private proxies end up bad? Are they broken? I'm a little confused.

I thought the worst that could happen is they get blocked on some systems, potentially, with anti-sapm measures in place.

Why are they all now considered not working?  Also, if I killed them, how might I have done so?

My kindest thanks to anyone reading and responding!  I am very unclear in this area.


  • s4nt0ss4nt0s Houston, Texas
    edited September 2017
    @Deeeeeeee - Well, it depends on the settings you're using and how you're testing them, but you can just select them again and retest them to see if they pass. Sometimes private/shared proxies will get temporarily blocked from Google if you're scraping. They might be "down" now (not passing Google) but in an hour they could be working again. 

    You might have to use more strict settings if you're letting SER scrape sites for you and you're scraping from Google. (increase time between search engine queries)

    You might have the "automatically disable private proxies when detected to be down" checked in proxy options as well.
  • DeeeeeeeeDeeeeeeee the Americas
    edited September 2017
    Thanks for the reply, s4nt0s!

    I had it set in the Options-->Submissions menu page so that the public proxies were used for search engines (scraping) and PR checking, and the private for posting only.  So my private proxies were only ever used to post and verify.

    Does GSA-SER automatically import the proxies as private because each entry also has  a username and PW, in addition to IP and port?

    I *did* have "disable private proxies when detected to be down" checkbox checked. Is this an issue?

  • s4nt0ss4nt0s Houston, Texas
    Having the user/pass might mark them as private, but if you look at the column called "Priv" in the proxy window, you can see if they're marked as private. You can also right click to bring up more options in case you need to toggle proxies as public/private.

    I personally never have "disable private proxies when detected to be checked" and that seems to work fine for me. 
  • DeeeeeeeeDeeeeeeee the Americas
    OK. It's all good now!! =)=)=)

    I deleted all the checked and unchecked proxies, public and private.

    Then I added the private proxies via clipboard (IP:Port:Username:PW) and checked them all against anonymous test URL, 28 out of 30 are still good.

    I guess sometimes the private proxies go down and back up again at times?

    BTW, I checked, and the GSA-SER DOES automatically categorize proxies with those extra PW and USER fields into the private stack of proxies. Very cool! =)

    As I've only used public proxies up until this week,  I never really saw this happen before:

    Checked 28|0
    Unchecked 2

    When I first got GSA-SER a few months ago, I played with most of the features and settings, and I had set proxies to private manually, and that moved them into that first column and also displayed the pipe (|) and a second column.

    So should I leave the program set to "disable private proxies when not working?"

    I would rather know if the proxies are down, for any reason, and not try using them at those times, I would think.  Just run other non-posting jobs that can use the public proxies available at those times?

    I think now that I recognize why I was having this issue it's OK. Any ideas???

  • s4nt0ss4nt0s Houston, Texas
    I don't enable that option and it works well for me, but if you prefer to enable it, that's up to you. Proxies go up and down so instead of them being automatically disabled, I leave that unchecked in case the proxy works when it tries it again the next time.  

    It's really up to you how you want to do it. 
  • DeeeeeeeeDeeeeeeee the Americas
    I'm not sure it wasn't just a one-time thing that the private proxies all went down simultaneously.  Who knows. lol

    I was wondering...

    What if I lost my Internet connection for any reason ? Would GSA-SER have sent the proxies to the bad pile, then, during a proxy test? Curious...

    I am still undecided as to how to set this.

    For now...I'm leaving it set to remove private proxies when down, and just re-load my full set of private proxies each day manually and re-test.

    If I don't do this, and I instead keep "remove down private proxies" checked and the proxies sometimes go down as you say, I'll eventually be using only a small percentage of my (actually) available private proxies! lol

    So I can either leave it unchecked and not be hassled, or do it the way I said, it seems.
  • s4nt0ss4nt0s Houston, Texas
    @Deeeeeeee - Good question, I'm not sure how that would work. I don't think it would be able to properly test the proxies in the first place if your internet goes out since it won't be able to check them against google or anonymous test URL.  

    Probably a better question for @Sven to answer.
  • SvenSven
    if your internet connection does down, you will see the proxies being tested against nothing and they get tagged as down. However as you will have them stay in the list as unchecked for a longer time than the test interval, it will test them again later on (default test settings). So you will get them re-enabled after a while if they are not really down.
  • DeeeeeeeeDeeeeeeee the Americas
    OK, Sven, thanks for the info. :) It makes sense...
Sign In or Register to comment.