Skip to content

unable to bind web server to

I don't have any of the program mentioned in the error tab running. I searched everywhere online. I'm clueless.


  • SvenSven
    replied by email, for all others, follow this guide:
  • It was much more complex than that but I managed to solve it using a French tutorial.

    everything work now. GSA PR Emulator & GSA Captcha Breaker
  • SvenSven
    what made the difference?
  • i could understand lol
  • I'm having the same issue, see both screen shots. been trying to sort this out for the last three hours. 

    so far i have unticked the un-ticked run as wed-server 
    i have downloaded curr-ports

  • SvenSven
    Port 8128 is de-captcha or dbc (I don't remember exactly). So if you uncheck that that to be simulated, it will be fine. Also do you really need the webserver option at all?

  • how do i deselect that port?
  • if this is waht you mean, still nothing 

    run as web server is un-checked and still not working 

  • SvenSven
    well "not working" is what? You should at least not get that "bind error" when starting CB.
  • Correct, no more bind errors 
    but captxha breaker isn't working still 
    the program just doesn't start 

    what do I do now? 
  • SvenSven
    the program doesn't start? I have a hard time believing this as you made the screenshots? Why would it not start after you changed the options?
  • edited July 2017
    I have an issue with PR emulator and GSA captcha breaker. They both listen on port 80....
    How can I run both on the same computer? Is there another port to run the captcha breaker? I tried a few but it doesn't work. Can we change PR emulator port? It's strange that I can't run both on the same PC... 

    GSA PR Emulator v1.21

    Sorry, but here runs GSA PR Emulator v1.21, no other resources are handled here.

  • SvenSven
    PR Emulator needs port 80, nothing else will work as it has to simulate webservices/websites.
    CB however doesn't need to run as webserver if you use it with SER alone. If you use it with another software, you need to use some service where you can specify the port, else you have to decide what to use PREmu or CB, sorry.
  • I just purchased GSA PR Emulator and am experiencing the same problem.  :(
    But I am on Windows 10 and have no clue on how to solve this.
  • SvenSven
    edited August 2017

    You have to find out what program is listening on that port.

    This can be very complicated and hard to figure out. The error message shows you some typical programs that might block the program from working as a web server. If you find them, stop or “kill” them with the task manager. You can also try to use netstat. You can do that when typing this netstat -b in the console (press start → Run → cmd [Enter]).

    You can use CurrPorts, a windows program by NirSoft that will list all used ports and the program using it. It should be very easy to see what is running on the IP/Port using this tool.

  • I will then be forced to ask for a refund since I cannot get it to work (already tried several things). Unfortunate though, was looking forward to using the PR Emulator :(
  • SvenSven
    well I can try fixing that for you if you leave your login details in pm. It's not a program issue really but something on your PC blocking port 80.
  • I can understand that it is not a program issue but that doesn't make it work.  :)
    What login details do you mean? I the gsa on my local computer.
  • SvenSven
    yes something to connect to your pc like, remote desktop or alike.
  • nycdudenycdude Mazatán
    Sorry to bring this thread back to life, but I'd like to see if I could get something resolved. I too use another captcha solver to catch everything Captcha Breaker misses. However, it's on port 80 also and there doesn't seem to be any other way to use it with the PR Emulator too.

    Is there some sort of workaround I haven't heard of yet? Being able to use two conflicting applications on port 80?
  • SvenSven
    You can safely disable the webserver option within CB as all GSA tools run without that.
    But PR Emulator needs port 80 same as the other captcha tools I guess. Maybe they offer a different port to be setup. Then you can use anything else than 80 there and use that port in SER when using services like "Antigate with IP/Port".
    Thanked by 1nycdude
  • nycdudenycdude Mazatán
    I have the server disabled on CB, yes we're good there. And I can change the port on my other captcha app, but support for them isn't very helpful. Can you suggest what ports I should try, please?
  • SvenSven
    well change to anything you like and then use some service inside of SER where you can specify ip/port like decaptcha/deathbycaptcha/antigate.
    Thanked by 1nycdude
  • nycdudenycdude Mazatán
    How do I specify within SER to do that? I can't find the option.
  • SvenSven
    edited July 2018
    when adding a captcha service inside SER, make sure you add one that is supported by the other software and that that service supporets IP/Port to be specified. Thats is one of the mentioned services as:
    • Bolo API
    • ReverseProxies OCR
    • DeCaptcha API with IP
    • AntiGate Old-API with IP
    • AntiGate New-API with IP
    When you add them inside SER, you can specify the IP:Port which will be e.g.

    In that case you need to change the port where the other software listens on to 8123 as well.
  • @Sven Hello Sven,

    I'm getting the same "unable to bind web server to" error , I run GSA PR Emulator on windows 10 in conjunction with GSA Search Engine Ranker and XEvil 3.0.4

    I think the problem is XEvil is using port 80 and makes that port busy.  :'(

    Can think of any possible solution in this situation ?


  • SvenSven
    PR Emulator is also using that port.
    However, if you use CB only with SER, then you can disable the webserver option.
  • @Sven I know people are running XEvil on port 81 using Antigate old with IP

    Do you know how to configure that using that method ?

Sign In or Register to comment.