Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

504 Gateway Timeout unable to find suitable sub-proxy

Hi @Sven,

I just added some super fast private proxies to the Proxy Scanner, to use with gateway, and I keep getting this error:

504 Gateway Timeout

unable to find suitable sub-proxy

much less often than before, but i am still getting it.. Is there any way to auto retry and/or avoid this error.. Because I assume this will slow down GSA SER tremendously...

Answers

  • Also, setting an username/password still doesn't work. I tried simple characters, etc... As soon as I turn auth on it stops working...
  • SvenSven www.GSA-Online.de
    Well it tries actually 10 times to find a good proxy...until it finally gives up with that error 504.
    But what exactly do oyu use as login/pw (send in pm) and what other programs/protocol do you use?

  • even if I use "username" and "123456" it won't work.. no other proxy related programs, just other GSA SER softare on this server mostly..
  • SvenSven www.GSA-Online.de
    well I mean what protocol?
  • Sorry, you lost me. what protocol?
  • SvenSven www.GSA-Online.de
    so I guess you use the Proxy Scraper's internal proxy server inside SER...how did you add it? Did you add it as SOCKS, CONNECT, WEB ?
  • No I haven't added it yet to SER, I just tried the following:
    1) added private proxies to PS manually
    2) added private proxy gateway (that only allow 1 auth IP) to PS manually,

    And then pointed the browser on my mac to my VPS IP:port of the PS gateway..

    When browsing manually I get these errors. I would like to resolve them before I point GSA SER to the gateway...
  • SvenSven www.GSA-Online.de
    well that doesnt sound like a auth error at all !?
  • if it would be an auth error I would need to get it on all requests ?!

    I didn't mix private gateway with private proxies...
  • I now only use scraped proxies, and I keep getting the same problem. 

    Also, using username/password still wont work.

    I added it in my browser as HTTP proxy.
  • SvenSven www.GSA-Online.de
    why would you need the auth thing anyway? could you offer access to your pc to debug this? I can not get any issue here on my pc at all.
  • see PM
  • SvenSven www.GSA-Online.de
    your proxies dont seem to be good enough and often down...i retested them now and also added PS as proxy in firefox and it works fine.
  • doesn't PS re-test them continuously?
  • SvenSven www.GSA-Online.de
    it does by default, but you had that turned off
  • ah, ok thanks!
Sign In or Register to comment.