Skip to content

GSA is not resolving PR for url's

For some reason my GSA is not resolving the PR for the url's it grabs.  It is showing PR ? for practically ever engine except mediawiki and a few jcow sites.

I have "get PR for verified url's" ticked and use proxies for PR checking unticked

This is what i've tried so far:

Yandex thru GSA
Yandex thru PR emulator with private proxies
SEMRush thru PR emulator with private proxies
submitting with the home IP
submitting with stormproxies
submitting with private proxies

And it is still showing PR ? for nearly all of the engines it tries to post to.  Any idea what could be causing this?


  • SvenSven
    do you see the PR resolving in PR Emulator or Proxy Scraper?
  • I don't have proxy scraper but I do not see anything showing up in the logs with PR emulator at all
  • I have 2 campaigns I am testing this with currently, a campaign that creates only contextual dofollow links and one that creates contextual nofollow.  When I just run the contextual dofollow campaign it is showing the PR as normal but when I run the contextual nofollow not a single url is showing the PR, it just shows PR? for all of them.  I have let it run all night and I have a bunch of links for my CDF campaign but 0 submitted and 0 verified for the CNF campaign so, it seems to be engine related?
  • Also when I run the contextual dofollow campaign, the PR shows it is getting resolved in PR emulator but nothing shows for the contextual nofollow campaign.  Not really sure what to make of any of this.
  • Ok, so now it isn't resolving the PR on either of my projects, which is really confusing.  No matter if I use yandex thru GSA or semrush/yandex thru pr emulator it's still giving me only PR ? and nothing is showing in PR emulators logs.. I have my firewall turned off and no antivirus running, could there be anything else blocking it from resolving the PR?
  • SvenSven
    open c:\windows\system32\drivers\etc\host and see what domains PR Emulator set there.
  • This is what is there:

    # Asia Virtual Solutions Captcha Solving

    # -= GSA HostMod =-
    # -= GSA HostMod =-
  • SvenSven
    that looks PR Emulator should work fine and you should see something when opening this URL in browser:
  • When i open it I see a blank page with "Rank_1:1:0" on it.

    What else could be causing this??
  • edited December 2016
    Finally figured out a fix for the issue.  For some reason, my campaigns that I imported from my GSA from 2+ years ago are the ones that were not resolving the PR.  I created brand new campaigns for these projects, set them to run and now they are resolving the PR as they should.
Sign In or Register to comment.