Skip to content

GSA using too much CPU %

Hi there.

So in the past couple of days after the most recent GSA update it's been using too much CPU percentage. Even at 50 threads it's using 100% CPU. I'm not sure why because in the past I was using 300 threads and even then it wouldn't use 100% of the CPU even with my sitelists getting updated through dropbox.

@Sven can you please let me know why that might be happening. Or maybe you can just take a look directly at my VPS and see why that might be happening. 



  • 1linklist1linklist FREE TRIAL Linklists - VPM of 150+ -
    edited December 2016

    Whats your max-page size set at? If its cranked up to high (4-5 mbs-ish) and your lists have a lot of large, long, spammed out pages then that kills cpu. (As ser is downloading 200-300 big pages a second)

    I only ever really have this problem with Trackbacks (Type 2 specifically)
  • @1linklist

    Where do you check that? Is it under the Filter option?
  • GSA SER -> Options -> Filter -> "Maximum size of a website to load X MB"
  • Mine is at 50MB. Is that normal? Or is it high? Because just a couple of weeks ago I was using GSA with 50MB max website site and it was running just fine. 
  • 1234876675412348766754 Utrecht
    edited December 2016
    Well, mine is at 5mb... Could be a VPS problem though. 
  • Nope. Still having the same issue even after setting it to 5mb. 
  • SvenSven
    will have a look on this for next update
  • @Sven

    Anything I can do in the mean time to lower the CPU %? 
  • SvenSven
    update to latest update now ;)
  • @Sven

    Wow that was quick. Thanks for the quick update. Unfortunately GSA isn't even opening for me now. Not sure why but the previous version seems to be working just fine. 
  • @Sven

    Now it's working smooth. I'll still test it for a day or two and update you if I have any issues. Thanks for the help and the quick update. Appreciate it. 
  • My CPU and memory also shot up high all the time I hope to see a difference this update
Sign In or Register to comment.