Skip to content

Export in .sl format not possible / PI doesn't remember PR setting


I recently started a new GSA PI project, but for some reason the finished result cannot be exported in *.sl format (the sl export in the context menu is grayed out).


I used PS with PR emulator, but otherwise all the setting are the same. Also, I noticed that PI doesn't remember the PR setting after a restart/updated. (It's always reset to "0").

These are my project settings:


Any clues about this?


  • s4nt0ss4nt0s Houston, Texas
    edited June 2016
    Regarding the .SL, you have Pi set to save everything to a single file. .SL is to export in site list format where each recognized type is saved to its own .txt file by category. You have to have it set to save "per engine".

    For the PR problem, we should have fixed this in the last version. (1.62) I just tested on my end and its saving the PR fine.

    You are using the latest version of Pi, right? Also, which OS are you using?
  • Hi @s4nt0s,

    thanks, that's what I thought... I prefer the single text file output (it's easier to apply additional filters...).

    Will rerun the project with txt file by category :)

    Yes, always using the latest version - and my OS is windows 7 enterprise.

  • s4nt0ss4nt0s Houston, Texas
    The PR is saved the same way the other settings are saved so if they other settings are saving fine on your end, its weird PR isn't being saved. This was a problem in pre-1.62 versions, but it should be working fine now.

    Can you send me a screenshot of the main Pi window?

  • Hi @s4nt0s,

    I don't know if I've gone st00pid overnight... it's weird. I just tried quitting PI and restarting - PR just saved fine.

    Screenshot of the main window:


    I tried a couple of times before... PR just wouldn't save, same version.

    Maybe it has stg to do with the single file / per engine save option? (Just guessing into the blue here - but after you told me that *.sl export requires per-engine saving, I only changed that option... issue disappeared)

    Thanx for your super-quick reply! This is the 3rd time I've been facing a "serious" problem with your software ("serious" as in "couldn't fix it myself within 24hrs). And it's the 3rd time your guys solved my problem in less than 12hrs.

    And that goes for @Sven, too. Thanks for the amazing support.

  • s4nt0ss4nt0s Houston, Texas
    @jonseo - Haha, no problem. I'm just happy to hear its working for you now. I was really scratching my head because we couldn't replicate the issue on our side. Phew ;)

  • Works like a charme now :)
Sign In or Register to comment.