Skip to content

anchor cloud is messed up


Ive started using GSA sparingly but I've noticed that my anchor cloud on the projects it's running on start looking like that :

Keyword 1 30% Keyword 2 20% hxxp// 15% 


Keyword 1 30% Keyword 2 20% Keyword 3 15% Hxxp:// 10%


In other words; GSA is generating the anchor hxxp:// a lot more that I would like it too.

I've checked my articles and the domainname isn't over used in them. So, I believe that I have an option checked somewhere. I believe that could be the following :

Use Url Variation with 20% (default)

Use the root/main URL with 30% (default)

I've just checked them in the beginning, leaving the % default. Before I change that, could anyone tip if there is another check box somewhere that could mess things up ?

Sorry for the noob question and thank you :)


  • SvenSven
    I guess the url/domain anchor is used from engines where no anchor could be used at all!?
  • Yup, you nailed it. 2 engines Im using are generating 99% url/domain anchor.

    Thank you for the fast and precise answer.

Sign In or Register to comment.