Skip to content

GSA Url Metrics not working

I just bought GSA Proxy Scraper and Activate the feature of "Emulate Google PR"
In GSA SER proxies are already disabled for PR checking and projects are already filtered for PR1

Still I am not seeing any Log in GSA Proxy Scraper Url metrics tab.


  • As i know google "disable" this future few days ago, and not available at the moment. It is not GSA "problem", the same situation with scrapebox too.
  • I know about that but thats why I bought GSA ProxyScraper to EMulate Google PR with Majestic TF
  • SvenSven
    In latest version of SER you need to uncheck the YandexTIC replacment in options-.>advanced to make use of PR-Emuilation.
  • Yo @Sven,

    I'm not quite clear about the workflow of this PR emulation... 

    Does SER pass each target to the URL metrics scanner to check the emulated and use it for filtering?
    Or do I run text-lists manually through the scanner?

    If option 1 applies... is there any configuration necessary except unchecking the YandexTIC option and checking emulate google pr? And will targets passed over turn up in the log?

    Maybe I'm just fantasizing here - the tool is brilliant as it is with manually importing scraped lists. Wicked combination of free proxies and free metrics!
  • Wow... never mind. I got it.


    Works like a charm. Awesome.
  • SvenSven
    ok so I guess ou figured out that "option 1" is correct and no further manual work is required.
  • Yes I did. Respect, Sir.

    It took me half a day to figure out the setup - the initial problem was that I had CB configured to emulate a captcha service on

    I didn't get the PR emulation to work when I set PS to - the other way around worked fine. I guess this PS update needs some explaining... I have a gut feeling that most folks don't get the power of this new tool.

    The end of the PR era was a big hassle for a lot of people - you solved that. For a one-time payment. Wow. I'm stoked.
  • Please explain your solution further. I click the start button on the metric scanner and it just flashes getting data, but never does anything.

    CB is set to a different ip than, still not working.
  • edited July 2016
    @Sven I should mention, the start button never goes away, its like it turns right back off when I click it.
  • SvenSven
    when you run PR Emulator, it is not required to press start at all. It would open and emulate every google-api call that comes in. However indeed it must have access to open a webserver on as there is no other way to emulate things.

    That start button is for your urls you load manually and tag with new metric setting.
  • I thought this thread was about URL Metrics Scanner, sorry. @Sven Does the same concept apply to URL Metrics Scanner? And if so, is there a way to see the URLs it is processing? I see nothing at the log at the bottom?
  • SvenSven
    Yes sorry this is about GSA PRoxy Scraper and the URL Metric Scanner module in it. However I thought you where referring to the PR Emulator stand alone tool.
    But the concept is the same anyway. If a PR is resolved by the tool and delivered, you should see it in log. Else something is wrong.
  • bangabanga hanoi
    edited August 2016
    Hi @Sven
    Today, I move tool to a different server. But my URL metrics not working

    I do exactly like introduce :

    1 . Uncheck "PR checking" by proxy
    2. Uncheck "Yandex TIC"
    3. Choose my PR I want in option

    And not working.

    Can you help me please
  • SvenSven
    on the screenshot i see SER gets the metric data it maybe from cache?
  • @Sven

    I don't know what exactly wrong with me. In another server, it working well. GSA SER still gets the metric data but URL metrics working. When I move to this server, it not working :(

    I sent bug report to you with username is Hao Nguyen.
  • SvenSven
    can you get me access to that system? Another customer messaged me the other day and it was the VPS itself not following rules in the host file. So maybe thats thew case here as well.
  • Hi @Sven

    Thanks for your support. I fixed it. Exactly like you said, my VPS not following rules in the host file. I edit host file and it working .
  • SvenSven
    wait, you have edited that file manually and it worked?
  • Hi @sven

    yes I edited host file manually. 
  • tbennnnntbennnnn United States
    edited September 2016
    What exactly did you do @banga?

    I'm having this problem with my server right now. It's like Metric Scanner is completely ignoring GSA. I have everything on and configured correctly but Metric Scanner isn't intercepting any requests and GSA is only getting back 0 and ?
  • tbennnnntbennnnn United States
    @Sven, can I send you my server credentials? This is driving me nuts trying to make these 2 softwares work together...
  • tbennnnntbennnnn United States
    @Sven Actually it's just not working at all. I even tried it on my home PC and nothing. Scraper will not intercept the PR checks and GSA just receives an unknown PR. I can record a video for you. 
  • SvenSven
    @tbennnn can you give me access to that PC instead? Might be better to locate the problem
  • tbennnnntbennnnn United States
    @sven I messaged you my server details. Thank you!
  • tbennnnntbennnnn United States
    @Sven took a look at GSA and I guess it was a software bug.

    Sven, could you let us know how to fix it so I can do that on my other installations? None of them are working right now. Others might be having the same issue as well.

    Thank you!
  • SvenSven
    You should simply update. That should fix things. If it's still not working, try running it as admin.
  • tbennnnntbennnnn United States
    @Sven ok that makes sense. Everything was updated so I'm pretty sure I needed to run both as admin. 

    I remember having that same issue once with Captcha Breaker as well. When I closed down GSA and Captcha Breaker and then relaunched them as admin, it fixed the problem.

    Thanks for your help
Sign In or Register to comment.