Skip to content

gsa ser stops - have to start again - when auto disable private proxies detected ... is ticked

I have found multiple times lately gsa ser to be on stopped state 
I need to press the green start button to start it again

today I realized that working proxies were down to 0 and since all work is done with proxies (based on my setup)
the engine stopped 
I realized the "automatically disabled private proxies when detected to be down" was ticked 
but unticking it is not a real solution (correct me if I am wrong)

what would be ideal is to have a way for private proxies to be re-tested automatically even if down previously

on the same problem i had some proxies dying for a while and then coming back again but it was actually blocked from google search
why is "custom time to wait between search queries" limited to 180 max ?  can we allow it to be a bigger number ? 
I suspect that for my 10 proxies I need a bigger number to prevent being banned from google


  • SvenSven
    enable this auto-diable option only if your proxies are unstable. I would not enable this option if you can be sure they are fine.
    Also keep in mind that there is another optiont hat will disable proxies when being banned by search engines. This however should be enabled.
    I would enable the proxy search/test to perform a test every 15/30 minutes maybe and only test proxies. You could then disable all proxy providers in a way that no public proxy is added but just testing is done.
  • OK fair enough but 
    still think a seperation should be done on what is done on private vs public proxies in terms of testing newly as I think there is legitimate use cases for having both in the system 

    searching and email verification for public proxies (I think)
    and private for everything else 
Sign In or Register to comment.