Skip to content

Translate doesn't work

Hi, It seems the translate macros are no longer working. I've been using the same projects for months, but now it's not translating properly.



  • SvenSven
    It's not translating at all or does it translate with errors? Because I have not touched this function for a long time and since it's a G. API, it should be the same as always. If you don't get any reply at all, then G. might as well have blocked you.
  • edited December 2015
    Hi it doesn't translate at all... Just stays English during article preview.

    If I go to Google directly, on my same IP. It works properly.

    Does Google permanently block? Can I make the translation function use proxies?

    I'll check again today, but I've been using the same projects for months and it's worked until last night.
  • gsa8mycowsgsa8mycows
    edited December 2015
    Yeah, translate doesn't work.

    I've seen this some time ago, but thought it was something else entirely.

    I tried on a new blank project the following:
    "Hello, my name is Bob. I go to school every week."

    You click on translate and nothing happens.

    I filled in both German and Polish fields while Directories and Social networks were selected.

    And my server ip is not blocked from either and I can go there with a browser and it translates.

    It doesn't translate longer text either.

    I've pasted some paraghraps from this and it doesn't translate it.
  • Still completely broken for me. Seems it doesn't even try to translate, just instantly outputs the text in English.

    Something happened within the last few days, because I've been using these same projects for well over 6 months without any problems.

    Sven, can you please check into this?

  • Update: @sven

    I had 3 friends test their copies of GSA... seems translate function is broken for everyone, both old versions and new versions.
  • gsa8mycowsgsa8mycows
    edited December 2015
    Never mind.
  • It was working for me up until December 14th or so... Had been using translate for 6+ months no problems, until then.
  • SvenSven
    The translate api works fine for me. However I see that it might be better to give an exact error message next time. So next update should help locating this.
  • What could possibly be making it not work?

    I asked 3 other people to check, and it was broken for all of them as well.
  • SvenSven
    Hmm hard to tell really. I would guess that G. blocked you as I get a 403 error when I e.g. check with a banned proxy.
  • Does the API use proxies? If so, then how could I be blocked? (I've tested with and without proxies in GSA)

    Why would the other 3 people I asked to test it be blocked as well?

    Doesn't make sense to me...
  • SvenSven
    It uses proxies if you use proxies for search engines as google is usually seen as such and the translation goes to the same ip/domain.
  • gsa8mycowsgsa8mycows
    edited December 2015
    @Sven even if I disable proxies for search engines, on new test projects nothing happens in the Translate fields for Directories(Germand and Polish).
  • SvenSven
    Yes, no error message is displyed. Thats something I have fixed on next update.
  • Hi... Then it cannot be just me that's the problem.

    Again, 3 other people have tried, they don't even use translate at all normally, and now it's broken for them.

    I've tried with and without proxies, tried my private proxies and a list of public proxies.

    Something must have broke with the G API. There's no other explanation to why it works 6+ months then suddenly quits...

    Can you please notify us of the problem, @sven? Could you test the translation from a different PC? Or ask someone you know to test it?

    I'm going to get a few more friends to try tonight, but as far as I can tell. It has nothing to do with "being banned".
  • SvenSven
    I had a look on it in more detail. Seems like G. requires an extra parameter now called tk=...

    Thats however some kind of checksum for the whole text to translate. It is possible to reverse it and people done so already. However it might take some time for me to add it to my code. Please bare with me but before XMAS it will not be fixed.
  • gsa8mycowsgsa8mycows
    Thanks @Sven. Merry Christmas.
  • @Sven any update on this?

    Translation still doesn't work for me.
  • It seems it doesn't work when I pull in lines from another file... but it works just with a regular sentence... Can you make it work with pulling in lines of text?
  • SvenSven
    what you mean with "in lines from another file" ? This issue was however fixed several versions ago and translate should work again just fine.
  • Hi... I pull lines from a different file using


    Inside the file contains spun lines using a spinner.

    When GSA pulls the lines, they do not translate at all.

    Also, when adding a large block of spun-text, GSA will not translate it.

    I've been using this method for many, many years and it only stopped working when translate broke.
  • @sven Note; the lines pull, but they are not translated.
  • Example of code I'd use would be like

    #trans_de #file_links[lines.dat,1,S] #notrans

    Inside the lines.dat file is spun text.
  • SvenSven
    I just created an article the same way as yours and translation to German works fine. Could it be some proxy/ip ban from G. ?
  • Hey I sent you a message with a test line and the code I'm using.

Sign In or Register to comment.