Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

GSA not using proper titles when using mix articles

I'm using foreign articles with the title in the first line. I'm importing all articles and choose "get title from first line" and everything is looking good

But when I use Mix Articles to a new one it takes the titles from the file names, and not the first line

This results in english titles with foreign content, which I wanna avoid. Is this something you could change?

Thanks

Best Answer

  • SvenSven www.GSA-Online.de
    Accepted Answer
    just edit the file titlegen.dat or move that to a folder with your localized data, change it and choose that folder in the project options.

Answers

  • SvenSven www.GSA-Online.de
    the mix article function will create new titles as it does not know what of the article content would make up a good title. However if you use macros here, it might work better indeed. So next version will skip this title creation once SER sees you use macros as titles anyway.
  • Ok, but I do like that it forces a keyword in the title, can u make that possible aswell with macros?
  • SvenSven www.GSA-Online.de
    use %anchor_text% ?
  • edited September 2015
    Yes, but won't that use the anchor only as title? I want it in the title at a random position, as it is now
  • SvenSven www.GSA-Online.de
    well so what issue you have with the generated title then anyway?
  • its english only, and im using foreign content

    i have foreign titles attached, why not use them for titles?
  • Oh, didnt realize that it used that file

    However, editing it for another language is a lot of work. I have translated titles with my articles, why not use them, and make a way to force your keywords to random positions
  • SvenSven www.GSA-Online.de
    Because SER would generate a total unreadable title which would do more harm to your SEO than anything good. It could use any of the titles but then again no keyword from the article would be in. Please just accept that this is not possible to randomly take any article title from your added once and think it will fit.
  • Well, generated, spun and mixed content is unreadable

    So my options are then
    1) English titles with foreign keywords
    2) Foreign titles without keywords

    To be honest I think unreadable foreign content with foreign keywords would be a better choice


     
  • edited September 2015
    So I found another solution using
    and translate on top of that

    However I still need to be able to use my own titles while using the mix option
    Will try to use a custom titlegen.dat and see how it goes

    Edit:
    Yes, works, thanks
Sign In or Register to comment.