Skip to content

GSA SER getting White and not responding

I am having 2 liscenses of GSA SER and running them on 2 different vps. Both of them were running fine and each one was getting almost 150k+ Verified links daily. But after some of the recent updates ( I guess after 10.0 ) something weird is happening to both of them. What I daily do is create about 200-250 projects on each with 250-400 threads. Import lists via import target url lists. When I press start , it runs fine for some time and then I close the VPS. The next day I open the VPS, I always find GSA ser WHite and not responding. SO I have to end the process from taskmanager and then run gsa ser again and even them it takes around 10 minutes to open again.

@Sven Can you please look into this please


  • @Sven Can you please help me ?
  • SvenSven
    I guess its all about memory usage?
  • @sven I have almost the same problem for the last couple months. In my case SER is not unresponsive, it's still running but running so slow. I noticed that there are time gap / delay of SER actions in the log, 3-5 minutes. I also notice that SER use constant CPU usage while there is no thread (0 thread) currently run and every time I click Stop button, it will take more than 10-15 minutes before all project stopped. I can send you the logs if you want to take a look. I set my SER only focus to post, I buy list and import them to my projects so I don't scrape anything, unchecked all scraping options. 10 private proxies, using only 20 threads now, 4 projects max, 10 catchall emails, unchecked all unnecessary options like PR checking etc, reasonable delay in email checking (10-15 minutes), verifying, etc. I restart my VPS every day now but only help little, SER will start running so slow after few hours, sometime less in one hour. I have moved my SER two times to fresh install VPS but facing the same problem, I already optimized the fresh VPS too, disabling unnecessary Services like Automatic Update, Spool, etc. Only run SER + CB. I really have no idea why now after the update I cannot remember SER became CPU hogged. In my case it is definitely not RAM issue, but SER after running some time will hog the CPU usage, Xeon 2.5G. I don't want to revert to old version because I want to take advantage the latest updates. The really obvious thing is the time gap in log, there are time gap between SER log activities about at least 3-5 minutes and this happened a lot. SER will stall doing nothing, 0 thread but SER CPU usage is 90-100% constantly.There must be something here Sven. Please kindly check this?
  • SvenSven
    in case this happens again (high cpu usage, almost no threads or no threads) please click HELP -> Send Bugreport and make a notice to this thread maybe.
  • Hi @sven, I made a question thread before seeing your reply here. Sure I will do that. Thank you.
  • SvenSven
    @vic the bugreport I got was doing a save on the verified urls to a file. I guess that one is real big now and SER take more and more time adding /searching things in it.
  • @sven, I see. Thanks for the heads up, now I know what to do. I'm testing now. Thank you!
  • Hey guys- i am having this same problem right now- ive always thought it was my VPS being cheap or running a bunch of shit in the background, or having bad servers. But i am going with Greencloud hosting, so i think its probably not that. Whats weird is i dont have this same issue on any of my other three servers from them. 


    I have a tonne of projects though- seems to crash right after i start and all the threads attempt to connect. 
  • @sven

    you can login to my vps right now and test it- seems to be happening consistantly. 
  • edited October 2015
    This is exactly the same problem i have...

    But i have this problem not only in the latest version of GSA....

    I have sent Sven a lot of bug reports, screens and he has also connected to my server but the problem has not been solved :-(

    I have sent a new bug report, i hope this error gets fixed now.

    Only 85 threads, 8 active projects, etc.
  • SvenSven
    Im working on a new version right now with a lot changes internally. It will reduce memory usage a lot and also speed things up dramatically. However it makes no sense debugging on an older version now. Please wait one or two more days before this new version is out and let us all work on this then.
  • David.YammerDavid.Yammer Barcelona
    edited October 2015
    Thanks Sven, that would be awesome. I have the same problems explained in this thread. I have tried almost everything and it gets frozen after running it for some time. Thanks
  • Fantastic, @sven! I know he will fix issues once he spot ones. He's like Jurgen Klopp! World Class!! lol. I'm sure sven will tackle the issues which probably arise after / resulting from extended run of SER
  • Thats great @Sven, thank you!! :-)

    @vic, i have been with those white and not responding screens from July-August.
    Is the same for you? Maybe we have the same problem.
  • @pedro, My problem is resolved already now. in my case, It turned out that I forgot to do housekeeping/cleaning job when I decided to check one option (automatically import verified URLs to a file). As time passed by that particular file has grown to huge file, that was my only problem. Right now my SER run smooth as powerful as it should be.

    I think it's better for you also to help sven in identifying what's the real problem by giving him your observations of what's going on so he can narrow down his investigation. In my case, I noticed time gap between SER actions in the logs, then sven can identify what's the main culprit from the bug report I sent. I don't know if it the same in your case. The problem could be anything, so having a starting point can speed up the problem resolving.
  • @vic what have you done to fix that?

    I use "serverifiedtargets", synced with dropbox account (they update automatically).
    I dont know if i should clean something or not.

    Yes, i have been talking with sven for weeks, but the problem has not been solved yet.
    I hope we can solve it soon.

    Thank you.
  • @pedro, as I already said, the growing HUGE file was the problem, my SER spent unnecessary looong time accessing, updating it. sven pointed it out. and it makes sense to me, it explained why my SER consume constant high CPU with low RAM consumption and no thread or almost no threads.

    sven only told me about the huge file, so I dig into my options and settings to find what might cause it. and I found it.

    I told you it was the automatically export (not import like I said, my mistake) so I backup the file then emptied it. since I'm a forgetful person, then I just disable that option. Project => Edit => Option => How to submit / verify.

    I don't know what your situation is, but it seems you have no starting point, if the problem is too broad, it could be anything. so something freeze, then observe how, when, what typical conditions if there's any etc etc. I doubt it yours the same case with mine. but I'm sure sven will resolve it, but you got to help him help you
  • Hi @vic.

    Ok, thats not my problem i dont have that option checked.

    And yes, i have been with this problem 2 months. Hi have been talking with Sven for long time, but it seems that is not easy to see which is the problem... We have sent lots of messages each other and i have sent lots of screens, backups, logs, etc.

    I hope we can fix it! :-)

    Thank you.
  • My problem just went away sort of. Closed the browser on my vps and a couple other things freed up some space. 
Sign In or Register to comment.