Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

Make GSA not translate anchors?

Hey, when building links in foreign languages, it seems GSA auto-translates the anchors.. What does it base this on / how does it detect the language - and can you disable it? It's good for generic anchors, but now it's translating my keywords and I don't want it to.

Thanks!

Answers

  • SvenSven www.GSA-Online.de
    it's not auto-translating anything unless you use macros for that.
  • edited July 2015
    I use translation macros in the About us section and Article sections.. But I pre-translate the anchors that go into the anchor fields (i.e. partial, secondary, etc) -- (using another source)... For some reason - GSA auto-translates the anchor fields.. i.e. in German even though i want "mobile" to remain the same in the anchors, gsa translates to "mobilen"
  • SvenSven www.GSA-Online.de
    OK so you use #tranns %about_yourself% #notrans right? then you better stop the translation before the %Anchor_Text% macro!?
  • Huh? What do you mean stop the translation before the anchor text macro?

    The about us section uses #trans_de and then #notrans after it.

    Not sure what you mean...
  • I let GSA auto-insert the anchors into the article.

    About us section would just be %trans_de% some text here %notrans%

    I can't figure out why GSA is translating the anchors. Maybe there should be a check box to translate anchors or not (bc it's actually quite useful for the generic ones).

    Thanks!
  • edited July 2015
    Edit: Removing the #trans_de from the about section did not stop GSA from translating the anchors. It seems some translate and some do not.
  • SvenSven www.GSA-Online.de
    OK then I don'T get it. The About_Yourself content is a spinned content or also a macro? If it is just normal content that is maybe spinned, why don't you translate it into German in the project itself and not wast time on every submission translating it.
  • edited July 2015
    GSA is auto-translating the anchors after I have already translated them...

    For example in the "Partial anchor" field

    "found the best mobile phone online"

    Which I have Pre-translated and is

    "fand den besten mobile telefon online"

    ... When posting inside a contextual article GSA translates this to

    "fand den besten mobilen telefon online"

    It adds the 'n' on the end even though my anchor texts do not include it.

    It shouldn't have anything to do with the About section --- this is regarding anchor text inside contextual articles.
  • SvenSven www.GSA-Online.de
    OK let me explain. The anchor is inserted and then it is translating it. Of course it then finds "mobile" and that one is also an english word and it gets translated again. The problem can easily be solved if you simply stop using the trans macro and translate your content in the project itself. You right click on it -> Translate ->...
  • Unfortunately that's not possible as I pull in the content using #file_links macros. Perhaps in a future version you could make the anchor be inserted before the article is translated? Or have an option to not translate anchors?
  • SvenSven www.GSA-Online.de
    hmm ok, but can'T you translate the content in that file then? That would solve all your problems. And the problem is that the anchor is inserted and then translated again. So an option would be required for you to not translate it.
  • Well the problem with pre-translating the content is that it's a file of 100k+ lines, and would be pretty hard to translate all beforehand in every language that I need... -_-
  • SvenSven www.GSA-Online.de
    Ahhh OK so you use that file not only for trans_de ...OK I understand. However speed would increase a lot if you do.
  • Yep, I use the same file for all languages and just switch the #trans macro... Maybe in the future you will find a solution / make an option for this... Thanks!
Sign In or Register to comment.