Skip to content

Gsa Breaker 100% in SDK but fails in practice

Hi all,

I've downloaded the demo version and have been seeing how it works and how to teach it to decode some captchas. I have downloaded a sample set of 200 images and used the filter / masks and it able to complete all of them in the SDK (100%)

I decided to test it in practice and sent some images from a site (same captcha type), GSA recognises the captcha as the one I've created but then returns a completely wrong answer. I thought at first that it was just one that got through and needed to train further, so I added the new image that failed into sdk of the new captcha setting and just hit 'test' Gsa successfully solved it! I hadnt generated any new masks, just loaded and tested.

Ive tried with several other images and the same thing happens?

To send the image to Gsa, I have written a c# application which saves the image to the disk and then sends it to GSA. At first I thought it was the image I had saved using my program but as I used the exact same image to manually load into the SDK I dont think it can be.

Im at a complete loss of what to try and do, any suggestions or help appreciated.


My 2 pennies worth.
Although I'm only using the tool for my own self interest in captchas, I think GSA breaker is pretty amazing.
Has a small learning curve (More captcha training docs required).
Looks good and runs fast.


  • SvenSven
    The problem might be that you send the captcha in a different format to the program as defined in your captcha type. It's e.g. not working if you define to only accept PNG for this type but send them in your program in JPG ?
  • Hi Sven,

    That was quick. Forgot to mention that. I thought of that and set it to png and jpg in the sdk.

    Im more inclined to believe its something I'm doing in my application, but I cant think what. The case that if I add the very same image to the sdk and it passes has got me stumped.
    I use the deathbycapture api to access GSA.


  • SvenSven
    can you maybe share the definition and samples?
  • Im currently at work, but will try and get the information later tonight.

    Thanks again
  • Hi Sven,
    Sorry for the late reply. I decided to start from scratch as I was noticing some strange behaviours in the application.
    Deleted the captcha definition I had created and started from the begining. This seems to have resolved the issue and is working.

    So I guess I had done something wrong somewhere, but happy its fixed.

  • SvenSven
    ok, still would have been interesting to know what it was.
Sign In or Register to comment.