Skip to content

Extremely Slow Getting of URLs from Sitelists ?

I have a VPS which is scraping and identifying the urls. I have another server for GSA SER posting. The identified urls folder is shared through VPN connection. The connection between both servers is fast and opening manually a txt file through the VPN feels almost like local file is opened.

I have mapped the shared folder with identified as drive Z: and set GSA SER's identified list to Z:.


Now when I setup a new project and set it to get links only from identified something really weird is going on. First it is going VERY VERY slow and just shows:

Loaded 0/0 URLs from site lists

most of the time. There are very few times when it actually get's some URLs from the sitelists, but I can see it actually gets some urls from time to time. However when it wants to actually post to those few urls it writes some of these:

download failed (Return: - SockError: Connection refused)
download failed (Return: - SockError: Connection reset by peer)
download failed (Return: - SockError: Connection timed out)

Here's what is actually going on:

And it can stay like this forever.

On the contrary if I import the same list from the same location Z: to the same cloned project and start it, it's posting without any of the aforementioned issues.

@Sven can you please help me out on this one? It's really bugging me and I know many folks are using VPN to share their sitelists between servers with success. I've tried dropbox kind of services and it seems like a waste of resources to me sending requests back and forth between dropbox's server and VPN seems like a more logical solution to me. Please tell me if this is the reason for these issues?


  • I found the problem. Platform Identifier was set to save the lists as format name.txt as default and GSA SER was set as type-name.txt . Who would've thought.. :)

    Maybe you guys should work it out which will be the default format for both programs, because it's a simple thing, but hard to notice.
  • i know this is an old thread but i've been having this problem and it was driving me crazy. so glad you were able to find the problem and this also fixed the issue for me
  • Problem appeared to me last too days. Nothing changes i warked on vps with 250 threads without problem, and now even if i am try to 50 threads the same issue.

    Any suggestion will be appreciated.
  • Edit : proxies cause the problem, i delete all and re add the proxies. So far looks like the problem is solved.
Sign In or Register to comment.