Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Software thread problem

I use 60 semi private proxies and set the thread to 100 but why after run it for few hour, i saw the thread only run like 10-30 but the ram only use 300-500mb and cpu is always below 10%. I buy highline elite window vps from solid vps and i think the window vps is enough to handle gsa ser.

If gsa re-verify the link then the thread is went back to 100 but if searching or submitting then the thread went down to 10-30.

Any idea what happen?

Best Answer

  • Accepted Answer

    1) That is why I no longer check the option which says disable not working proxies and also remain uncheck the automatically disable not working public/private in proxy settings. There can be a variety of reasons that GSA SER marks a proxy to be not working and I can not comment more as I am not an expert in proxies and how SER handles them.

    2) SER will never automatically disable non working emails and you have to keep a close watch on your emails used. Enable the option that says to display important messages in Advanced settings. This will immediately display message when there is something working with your emails.


  • SvenSven
    maybe too less targets to post to.
  • But i am using around 100k keywords and also asia virtual solution 2 Tier – Churn & Burn GSA Ser Data Pack on gsa and i dont think it have less targets site to post
  • SvenSven
    It's the way you get targets. If it's just by search engines then you have to get more proxies.
  • Semi dedicated proxies - not only you use this proxies, so proxies can be banned in google so you wont be able to harvest with them. With milion kws list and uber data packs you wont be able to post without good list or good settings for harvesting and good proxies.
  • edited January 2015
    I also test all the 60 semi private proxies after few hour to made sure all is working and if there have no working proxies then i will replace it. So this is not the issue.

    After running gsa for 1 day but the thread still show 10-30 and not the 100 thread i set.

    So really dont know what is the actual problem?
  • Here is a list of what you can do to make it run at the specified no. of threads;

    1) Simply add more projects / tiered projects
    2) Add more search engines 5-10 are not enough ( I mostly have checked 130+)
    3) Select more engines to post to.
    4) In Settings reduce the time between 2 search queries. I have used as low as 3 seconds (you do your experiment to find the best spot).
    5) Do not use auto verify. Either set to verify after 12/24 hrs or verify manually once a day.

    Your no. of proxies is more than sufficient to run well over 100 threads but it also depends on how fast these proxies are performing. Less than 200ms response is good while response time of above 10 seconds will deliver poor performance.
  • edited January 2015
    Look like your guide is working and the thread have been increase.

    Like to know did you select re-verified again all the links in custom time or not need to use it because first verifies is enough?
  • Re-verification is the check that your link is still live and not deleted/removed. This option is very useful if you have set up tiered campaigns. Lets say I have T1 campaign pointing to and set T2 campaign pointing to the T1. Over time some of the T1 links will be removed by site owner while the T2 links keep on building which is pointless. So what I do is that I check the re-verify option for every Tier that has a lower tier to make sure my tiered link chain is not broken and I do not allow SER to keep posting to deleted links.
  • edited January 2015
    After i select more project and the thread have went up to 100.

    But i still facing 1 problem.

    1) I use the disable not working proxies feature and whithin 1 hour, i saw gsa have decrease the proxies from my 60 proxies i add. Then i went to test those 60 proxies again and all proxies is still working fine but have no idea why gsa disable those proxies and say that not working and look like gsa ia not accurate with that.

    So is that i need to use the disable not working proxies feature and what will happen if i not use it?

    2) Does gsa have a auto delete or disable email account that not working so that it not use it to register an account and do i need to set it?
  • Currently i am using private proxies for search engine, submission and email checking. What else should i use?
  • I use private proxies for submission only (disable for identifications). For search engines I only use public proxies around 1800+ scrapped from built in SER proxy scrapper.

    I uncheck all for email and verification.

    This has served me well for the past few months. I do not make tons of verified since I use various filters and end up getting a few hundred verified links across all my projects.
  • I have 2 tier 1 project getting warning and it write that No Target to Post to. What does it mean?

    I have around 100k keywords with 131 search enigne use to search the site and 4-5 source for each tier project to submit to
  • No surprise you are getting this message.

    When you use SER for scraping as well, your private private proxies will get banned after sometimes and SER can no longer find targets to scrape.

    That is why it is a nice idea to have public proxies set for search engines and PR checking.

    Take 5 minutes to setup SER for automatically scrapping public proxies. You will still get this message after these are banned and you should not worry and soon as new proxies are added, SER will start scraping for new targets.

  • I have run gsa for 5 day and every 6 hour i check all the private proxies by gsa and all is still working fine

    Wonder why it show the warning with No Target to Post to
  • If you do not allow to post per same site multiple times that might be a reason. SER has simply created all the accounts it was supposed to create and has nothing more to do. Check that , this might solve your problem.
Sign In or Register to comment.