Skip to content

8.86 Holding 4 Threads with Scheduler

BrandonBrandon Reputation Management Pro

15:12 (time in the screenshot) was 25 minutes ago and it's just sitting and not releasing those threads so the scheduler can continue.


  • SER does this sometimes.
    Set threads to 1, if it doesn't go to 0 in ~2min max  just end process.
  • BrandonBrandon Reputation Management Pro
    @cefege I run a lot of servers and it's only happening on the two that I upgraded to 8.86. All the rest are at 8.84 and still running as expected.
  • I have had this happen for a long time, it's quite rare however and random.
    Can you replicate this?
    I usually got those errors when I stop the projects after an out of memory message.
  • BrandonBrandon Reputation Management Pro
    @cefege, good observation, I have been having out of memory errors. I am testing again right now but haven't had any OOM errors this round.
  • BrandonBrandon Reputation Management Pro
    @cefege, I can now confirm that it only holds the threads when it has an OOM error. It works fine and releases threads unless it hits a memory error.

    @sven I can give you project backups or logs, or even a video i that would help.
  • SvenSven
    Well thats actually the problem of a OOM (oh new short term) error. You never know where this occurs and everything on this thread is lost...even a signal to the main thread that this one is over. 
  • BrandonBrandon Reputation Management Pro
    @Sven is there a way to fix it? Can SER force all threads to quit after 30 seconds or something like that?
  • SvenSven
    no, I don't want this to be done. This is just bad coding...Im not doing this.
  • @sven so what are we supposed to do?
    This bug blocks the project, only option is to restart the program. Alot of times, I had to end taks because the program could not be closed because of this error.
    I can see this affecting people who use scripts to automate ser as well.
  • BuySERListsBuySERLists Vancouver, Canada
    Having SER force close threads is a great way to cause a BSOD. I can't tell you how many times I have a full crash due to doing a stop operation in one of our active GScraper instances.

    Sven is the expert but I don't see this as that big of a deal. I deal with this multiple times per day on our dedicated servers as I'm constantly stopping and starting the scheduler to add new projects in. I would say on our boxes that run 1000+ threads I have to force close SER about 25% of the time. No big deal, takes care of things quickly and you get a nice clean instance to fire back up again. I can see @cefege point about the scripting though...
  • SvenSven
    cefege  the only option would be to stop it from causing the out of memory issue...and that can be done in lowering threads, using less content for projects or starting less projects at once.
  • I have the same problem since today.... only 1 thread running while I set it up to 180 threads as always since months.

    I want to try to go back to the previous version of Ser (the 8.85) to see if it fix this problem, but I don't remember how to go back to the last version.... I remember there is a way but I can't remember it now....
    Any help please?
  • Mmm.... I have found it (it was the file Search_Engine_Ranker_old.exe, on c:\program), I installed it, and now the threads changed from 1 to.... 80, later 60, later 15, at the moment 5.... and it's going lower and lower..

    So it's not a problem of the 8.86 version :-(
  • BrandonBrandon Reputation Management Pro
    @sven @peterperseo I'm running 8.84 and don't have the issue anymore. I still get the normal OOM errors which I always get because I push my servers to the limit, but the problem of retaining threads is not there in 8.84.
  • can someone upload 8.84 version please
  • BrandonBrandon Reputation Management Pro
    @edyculay 8.85 seems to be good as well if you're having the same errors I am.
  • @Brandon I tryed both the 8.85 and 8.86, and I'm having the same issue with both.

    Do you have the 8.84 version please?
  • BuySERListsBuySERLists Vancouver, Canada
    8.87 just got pushed out it looks like, give that one a shot and see if the problem fixes itself...
  • @Brandon i got same error as you, but i have only 8.86 the oldest version i got, can you please update the Gsa exe of 8.85 ? Thanks a lot
  • I solved the trouble!!
    My threads number was 1 since 2 days, today I tried to uncheck the 2 boxes:
    - Automatically decrease threads on a CPU usage....   and
    - Automatically decrease threads on a Memory usage.... 

    and now I'm having the same 240 threads working as before!!

Sign In or Register to comment.