[Possible Bug] Link Processor don't get all verified links ?

@Sven .. Link Processor don't get all verified links. I suspected this yesterday and I monitored it today. I guess it's not working properly.

Today , I made 230 k verified backlinks in SER but the api only got 102 k links !!!!

When I select all projects >> show verified urls >> send to indexer ..it works good.

I'm not sure if it's a bug in the @linkprocessor's api itself or in SER ?... please check.

Comments

  • SvenSven www.GSA-Online.de
    the manual sending as well as the automatid on a new verified link share the same function how it is submitted.
  • @Sven ..Not sure what's going on. But I tested it. Manual sending works perfectly and the automatic one is not sending all the links!!

    I'm not the only one with this problem by the way... please take a look here

    https://forum.gsa-online.de/discussion/comment/72144/#Comment_72144

    Can you debug and test it plz ?
  • SvenSven www.GSA-Online.de
    Accepted Answer
    I debugged this a lot ... haven't found any issues sorry. 
  • goonergooner SERLists.com
    Accepted Answer
    @mamadou - You are right, Link Processor doesn't get all my links either.
    They told me they remove dup URLs so that might explain some discrepancy. But no way it could account for the amount of missing links you are seeing.
  • edited April 2014
    @Sven ... are you saying that it's sending all the verified links on your machine for all projects ?


    @gooner .. manual sending works like a clock. The automatic sending is always way less. What % of links are you missing in your tests ?
  • goonergooner SERLists.com
    @mamadou - I saw approx 50% of links not being sent, which is roughly the same as you right?
  • @gooner ...Yes , exactly. I'm pretty sure it's a bug somewhere.

    @Sven ..create a new project ..let it run for while and then compare the verified number with the number on link processor control panel ..You will most likely find the problem.
  • SvenSven www.GSA-Online.de

    hmm just checked it all again ... no problems on my code as far as I can see.

    URLs get not sent if:

    a) URL is the same and was sent before

    b) PR or DoFollow only is checked in indexer options

    c) a timeout occurres while sending the data to the indexer (make sure it is high enough)

  • @Sven .. The incredible indexer was working perfect for me and all my links were picked up by the api. I didn't change anything in the settings ..I just changed the indexer service to link processor and now it's not sending half of my links!!!

    Maybe it's a problem in the service itself ?
  • hmm. i think i got same problem. I've 4k verified but after 2-4 days checked on ahrefs stats less than 1k indexed
  • SvenSven www.GSA-Online.de

    The way links are sent to that new service is the same as in every other indexing service. The code is 1:1 except that the URLs or parameters are different. So from @mamadou 's experience it should be an issue on link processor but I guess that there must be some other issue.

    However next version will try to send the query to each server again if no reply was given...just in case the server is over loaded or some network problem happens.

  • Damn it, just checked mine since buying Link Processor and it looks like very few links are going there. 7k links per day....should be more like 100k. I'll look at it more closely but a quick look says 7%.

    I just paid for 6 months of Link Processor as well....
  • We are debugging this and trying to find where is issue.

    @sven Users reported the issue with other indexing services here - https://forum.gsa-online.de/discussion/comment/70102
    So, it is very strange that the same issue is happining on two different services.
  • SvenSven www.GSA-Online.de

    @linkprocessor Im aware of the problem. I hope the next version where it retries to send things is improving things. Can you check if your server may sometimes be overloaded and just reply with an empty reply? Thats the only reason I see why it would fail. Also whats the response time? Should always be under 30seconds right?

  • @sven. If server is overload it can not send any reply, I mean, if it is overloaded response will be more then 30sec. You can try to increase it to 60 sec.
    It is strange that problem happen when GSA is regularly posting and sending to indexing services, but does not happen when user click on "send links to indexing services"...
  • SvenSven www.GSA-Online.de
    yep maybe its the users pc at all where it is to busy with too many threads and a too low timeout.
  • edited April 2014
    @linkprocessor @Sven... I can confirm that the incredible indexer was working perfect while I send links automatically. All my links were going through without any issues ( I doubled checked it several times ). As soon as I switched to Link Processor I suffer from this problem. And No , I didn't change any single option in my VPS setup.

    @linkprocessor ..I hope you give this problem high priority in the next few days. People are having very very low indexation percentage because of this problem and they are blaming the service itself not this bug! and they are leaving your service. ( one of the heavy users here told me that he stopped using your service for low indexation % ) ..In my tests while I send links manually .. your service have a very good indexation % but you MUST fix this issue as soon as possible.

     Currently , I 'm sending all my links manually once per day but I don't want to stay like this forever!.
  • @mamadou Sure, we are working on this. We are still trying to find where is bug as all test shows that all links are accepted on server side.
  • @linkprocessor... Thanks. Please update this thread when this issue is sorted out so we can switch back to the normal automatic mode and get rid of the annoying manual homework that we have to do every day.
  • @mamadou Please try again auto mod.
    I see last post in this thread - https://forum.gsa-online.de/discussion/comment/70102
    It was made on April 10:
    "Today I stopped SER to update to 8.16 and problem disappeared, SER didn't start to suddenly send tons of links once it stopped. I also checked both indexers and looks like the amount of links it should get was sent, so far so good"

    When did you see this issue last time?
  • @linkprocessor ...last time I saw the problem was 2 days ago and I didn't test it again since then. Did you update the code ?
  • @mamadou We are updating code on daily bases and improving overall speed. Still I'm not sure what was issue.
  • Just stopped some projects and Link Processor spent a few minutes sending links through the API, looks better than before. There are still many times it said it had failed. 

    Thanks Sven and Link Processor for jumping on this to find a fix. Sorry I can't be of any more help.
  • @linkprocessor .. I will give it a try again when Sven update SER next time. Hopefully the changes he promised to apply in ser will fix the issue. ( I'm using latest SER btw )

    @JudderMan ... did you compare your verified links number with the Link processor stats ?
  • This bug is fixed now.
Sign In or Register to comment.