Skip to content

High CPU load on VPS Recently?

Anyone else experiencing GSA giving the cpu a really hard time recently? Everything was fine for me up until a day or two ago, now its running the cpu into the ground at just a few hundred threads. I have tested this on a powerful 8 core vps just to see and its definitely an issue with GSA.

I havn't changed any settings recently, im running only 6 projects with imported lists (same as i've been doing the whole month) and its just eating up cpu like nobodies business.

Anyone else seeing this?


  • goonergooner
    I'm also seeing this on one of my dedicated servers. CPU at 100% in task manager only running SER.
    Also started 2 days ago. Usually i run SER and other tools and CPU usage is less than 50%.
  • Hmm yes two days ago something changed. If it happened to you too id say software bug? @sven any ideas?
  • SvenSven
    two days ago? Well I haven't released an update over easter.
  • goonergooner
    edited April 2014
    @sven - I think maybe it's something in version 8.22.
    I think i updated 2 days ago or maybe i only just noticed the problem 2 days ago - I'm not sure.

    But i can say for sure i am seeing 100% CPU in task manager and my server has 2x Xeon E5530 processors. Honestly, i never see more than 50 - 60% usage running SER and other tools too.

    But now just SER uses alone 100%. I tried lowering threads, reducing maximum file size to download. But it only drops to around 90% at best.

    I am running scheduler, 40 projects at 600 threads. I am pretty sure it should not be using that much CPU.

    What do you think?
  • SvenSven
    hmm 600 threads...hard to say what it might be. I can do a profileing on the current code to spot the cause but I haven'T really changed much on the code that could influence this.
  • Yea it definitely started happening about two days ago. Its just eating the cpu no matter how many threads you do. Anything past 300 and it starts choking.
  • SvenSven
    But two days ago I haven't updated. Yesterday was the first update after easter!
  • goonergooner
    @hadoken - LOL actually you are exactly right. If i drop to 300 threads i get 20 - 40% CPU usage, if i increase to 400 threads it goes right back to 90 - 100%.


    @sven - We really appreciate if you could take a look, thanks :)

  • Hehe new it was somewhere around there
  • Latest update seems to be better, which is odd if you didn't touch any code @sven. I am currently running 900 threads at mem: 1.60GB and cpu: 20-50%
  • jjumpm2 what is your server spec ?

    i'm running 2 projects 200 thread. CPu usage 60-90% lol
  • @lemonzer‌ similar timing for you as in last couple of days?
  • nope. i think it's from few days ago. 
  • @lemonzer

    (2) Quad Core Intel Xeon 2.26GHz
    24 GB RAM
  • edited April 2014
    @jjumpm2 if u don't mind where did u got that server ? is it dedicated servers ?
  • i think mine is back to normal . 
  • Blog comments, image comments, guestbook will eat your cpu
  • @randomusername the thing is I haven't changed any of my settings for this to happen. @gooner are you still experiencing this?
  • im experiencing this, used to have 25% now gettin up to 100% CPU usage :(
  • goonergooner
    @hadoken - Actually it was my fault. I usually run projects from identified or verified folder, but this time i imported many URLs directly into projects and that caused the high CPU load.

    I forgot i imported them. So i deleted the target URL cache and CPU is back to 10 - 20%.

  • @gooner I am importing urls too but I was doing so previous to this without any issue. Is it a memory issue?

    @sven would it help if I sent you my project backups? I import my lists directly from scraper - have been doing for the last month without any problem. I have a friend who is also experiencing this as well.
  • edited April 2014
    Just switched over to the method of pulling from the identified/verifieds folder and the cpu usage drastically dropped initially, but my lpm was alot lower. That was because many of the projects began verifying though. Now after I deleted all submitted urls and let it run, I am getting this issue again. 100% cpu in resource moniter on anything above 300 or so threads. I am running a 6 core ssd vps from solidseovps, and I tested this on a 8 core one was well with the same results.
  • SvenSven
    @hadoken yes please send me a project backup where you have a high cpu usage.
  • @lemonzer yes, dedicated - will PM you
Sign In or Register to comment.